Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Namen in Makro verwenden
#1
Hallo,

mittels eines Makros möchte ich die Inhalte bestimmter Zellen löschen.

Die fraglichen Zellen habe ich in unter einem Namen zusammengefasst

(da ggf. Zeilen oder Spalten ergänzt werden)

und verwende im Makro diesen Code:

...
Range("Felder").ClearContents
...

Leider werden die Felder (der Name lautet "Felder") nicht geleert.

Woran liegt das bzw. wie macht man's richtig?

Danke für Hinweise.

Steini
to top
#2
(16.03.2016, 21:49)Steini schrieb: Woran liegt das bzw. wie macht man's richtig?

Hallo Steini,

der Code ist in Ordnung.

Gruß Uwe
to top
#3
Hi

das der Code von der Syntacs her stimmt ist zwar sachliche richtig 
Es hilft dir aber sicher nicht weiter den Fehler zu finden.  Oder???

Probier mal das kleine Makro um zu sehen in welchem Sheet und mit welchem Bereich   "Felder"  verbunden ist. 
Vielleicht erkennst du dann von selbst den Fehler!  würde mich freuen wenn es dir hilft den Fehler zu finden.

mfg   Gast 123

Sub Test
MsgBox ThisWorkbook.Names("Felder").RefersTo
End Sub
to top
#4
Hi,

es ist halt nun mal so: auf ungenaue Fragen mit zu wenig Informationen können leider keine ausführlichen, auf alle Eventualitäten eingehende Antworten folgen!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#5
Hallo Steini,

falls Du den Bereich Felder in Deiner Mappe mehr als ein mal hast, könnte es sein, dass nicht der Bereich gelöscht wird, wo Du es erwartest, sondern ein anderer. In diesem Fall müsstest Du das Blatt noch dazu schreiben, z.B.
Sheets("Tabelle1").Range("Felder")...

Die Codezeile wird aber doch durchlaufen? Falls Du nicht sicher bist, Haltepunkt setzen und schauen, ob der Code auch dort anhält :-)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#6
Hallo,

den Namen habe ich nochmals neu angelegt und seitdem läuft es einwandfrei.

Vielen Dank für die Hinweise

(auch darauf, dass es richtig ist und wo ich daher nicht suchen muss,

wie ich suchen könnte und dass weitere Infos erforderlich sind)!

Steini
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste