Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Mittelwertberechnung aus Zeit nach Wochentag
#1
Hallo Freunde,

ich bitte um Formelhilfe (keine PT! - ist nach dem Originalaufbau zu umständlich) für nachstehendes Problem.

Tabelle1 (2)

ABCDEF
1DatumFTZeit 1Zeit 2Gesamt-zeit=Mittelwert, wenn das Datum kein Do oder Sa ist.
2Mi, 01.01.1400:1000:2000:30
3Do, 02.01.1400:1001:2001:30
4Fr, 03.01.1400:1000:2000:30
5Sa, 04.01.1400:1001:0001:10
6Mo, 03.02.1400:1001:2001:30
7Di, 04.02.1400:1000:2000:30
8Mi, 05.02.1400:1000:2000:30
9Do, 06.02.1400:1001:2001:30
10Fr, 07.02.1400:1000:2000:30
11Sa, 08.02.1400:1001:0001:10
Formeln der Tabelle
ZelleFormel
E2=WENN(UND(C2<>"";D2<>"");C2+D2;"")
E3=WENN(UND(C3<>"";D3<>"");C3+D3;"")
E4=WENN(UND(C4<>"";D4<>"");C4+D4;"")
E5=WENN(UND(C5<>"";D5<>"");C5+D5;"")
E6=WENN(UND(C6<>"";D6<>"");C6+D6;"")
E7=WENN(UND(C7<>"";D7<>"");C7+D7;"")
E8=WENN(UND(C8<>"";D8<>"");C8+D8;"")
E9=WENN(UND(C9<>"";D9<>"");C9+D9;"")
E10=WENN(UND(C10<>"";D10<>"");C10+D10;"")
E11=WENN(UND(C11<>"";D11<>"");C11+D11;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

In Spalte A ist das fortlaufende Datum des laufenden Jahres ohne Sonntage. Die Zeiteinträge dürften selbsterklärend sein. In F1 benötige ich den Mittelwert der Gesamtzeit ohne die Zeiten von Donnerstagen und Samstagen.

Schon mal Danke für eure Mitarbeit.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#2
Hallo Günter

Code:
{=MITTELWERT(WENN((WOCHENTAG($A$2:$A$11;2)<>4)*(WOCHENTAG($A$2:$A$11;2)<>6);$E$2:$E$11))}
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo Günter,

z.B. so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1DatumFTZeit 1Zeit 2Gesamt-zeit=Mittelwert, wenn das Datum kein Do oder Sa ist. 
2Mi 01.01.14 00:1000:2000:3000:3000:30
3Do 02.01.14 00:1001:2001:3000:30 
4Fr 03.01.14 00:1000:2000:3000:30 
5Sa 04.01.14 00:1001:0001:10  
6Mo 03.02.14 00:1001:2001:3000:4500:45
7Di 04.02.14 00:1000:2000:3000:45 
8Mi 05.02.14 00:1000:2000:3000:45 
9Do 06.02.14 00:1001:2001:3000:45 
10Fr 07.02.14 00:1000:2000:3000:45 
11Sa 08.02.14 00:1001:0001:10  

ZelleFormel
E2=SUMME(C2;D2)
F2{=WENNFEHLER(MITTELWERT(WENN(($A$2:$A$11>=A2-REST(A2;7)+2)*($A$2:$A$11<A2-REST(A2;7)+9)*(REST($A$2:$A$11;7)>0)*(REST($A$2:$A$11;7)<>5);$E$2:$E$11));"")}
G2{=WENNFEHLER(MITTELWERT(WENN(($A$2:$A$11>=A2-REST(A2;7)+2)*($A$2:$A$11<A2-REST(A2;7)+9)*(REST($A$2:$A$11;7)>0)*(REST($A$2:$A$11;7)<>5)*(KALENDERWOCHE(A2;21)<>KALENDERWOCHE(MAX(1;A1);21));$E$2:$E$11));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
Hi Detlef,

danke für die schnelle Antwort. Ein Problem dabei ist leider noch vakant. Bei dieser Matrixlösung muss der zu berücksichtigende Bereich exakt angegeben werden. In meiner Tabelle allerdings werden die Datumswerte fortlaufend geschrieben - sprich, es werden immer am aktuellen Tag die dann auftretenden Zeiten aktualisiert und die Zelle F1 muss den Mittelwert bis zum aktuellen Datum berechnen. Und daran scheitere ich hauptsächlich.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hallo Günter

Dann mache aus deiner Liste doch eine Excel-Tabelle. Mit den strukturierten Verweisen muß man nie wieder Zellbezüge anpassen.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • WillWissen
Antwortento top
#6
Hallo,

ich hatte das pro Kalenderwoche berechnet. Ohne das ginge das auch so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 H
200:40

ZelleFormel
H2{=MITTELWERT(WENN((REST($A$2:$A$11;7)>0)*(REST($A$2:$A$11;7)<>5)*($A$2:$A$11<=HEUTE());$E$2:$E$11))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • WillWissen
Antwortento top
#7
Hallo Delef, hallo Edgar,

lieben Dank für eure Vorschläge - es funktionieren nach einer kleinen Anpassung alle. Genommen habe ich Detlefs Formel, da diese am kürzesten war. Ich war aber trotzdem so frei und habe alle drei Formeln in meine Sammlung aufgenommen - man weiß ja nie. ;)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste