Das letzte Clever-Excel-Forum.de - Treffen
fand vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt.

Mit Zahl und Text in einer Zelle rechnen.
#1
Hallo,

ich habe das Problem, dass ich eine Zelle in der "300€ jährlich (November)" steht mit einer anderen Zelle addieren möchte. Ich habe es über Zellen formatieren unter Zahlen Benutzerdefiniert probiert etwas zu erstellen. Leider funktioniert es nicht.
to top
#2
Hallo,

meinst Du so?

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
12300 € jährlich (November)600
2   

ZelleFormatWert
B10 "€ jährlich (November)"300

ZelleFormel
C1=A1*B1
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Stefan
Win 7 / Office 2007
to top
#3
Hallo,

wenn du die Zahl in einer separaten Zelle haben willst dann könntest du folgende Formel verwenden:

=VERWEIS(9^99;--LINKS(A1;SPALTE(1:1)))

wobei ich davon ausgehe, dass dein Wert in A1 steht.
Gruß
Peter
to top
#4
Ja genau so.
to top
#5
Hallo Steffi,

leider funktioniert es so: 0 "€ jährlich (November)" bei mir nicht!?
to top
#6
Hallo,

das Format stimmt - wie bist du denn vorgegangen?

Zelle markieren - rechte Maus - Zellen formatieren... - Register Zahlen - Kategorie Benutzerdefiniert und dann das Format in Typ kopieren.

Bekommst du eine Fehlermeldung oder was wird in der Zelle angezeigt?
Gruß
Peter
to top
#7
Ich habe das genauso eingegeben nur das bei mir dann in der Zelle, die berechnet werden soll WERT steht.
to top
#8
Antwort gelöscht.
to top
#9
Hallo,

die Fehlermeldung #Wert könnte ein Zeichen dafür sein, dass in einer der beteiligten Zellen in Text steht.

Wie lautet denn die von dir genutzte Formel?

Hier mal ein Beispiel wie ich das meine:

Arbeitsblatt mit dem Namen 'Tabelle1'
 A
1300 € jährlich (November)
2300 € jährlich (November)
3 
4600 € jährlich (November)
5 
6t
7 
8#WERT!
9900 € jährlich (November)
10 

ZelleFormel
A4=A1+A2
A8=A4+A6
A9=SUMME(A2:A7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Formel in A8 gibt die Fehlermeldung #Wert aus da in A6 ein Text steht. Die Formel Summe() in A9 ist da toleranter.

Wenn dir der Hinweis mit dem Text in der Zelle nicht weiterhilft dann wäre es vielleicht sinnvoll deine Datei mal hochzuladen damit man sich das direkt in der Datei ansehen kann.
Gruß
Peter
to top
#10
Ich habe den Zelleninhalt gelöscht, habe die Zelle wie Steffi geschrieben hat formatiert und dann nur noch in die leere Zelle die Zahl 300 eingegeben. Und siehe da, es funktioniert. Danke
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste