Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Minus und Plus Zeiten
#1
Hallo zusammen,

ich habe ein Problem mit der berechnung von Arbeitszeiten/Fehlzeiten.

Ich bekomme es einfach nicht auf die Reihe, wenn jemand Sollzeit z.B 0:00 Uhr hat und er länger Arbeitet dass er es umrechnet. SPALTE F

Bein errechnen vom ges. Ergebnis komm ich a net weiter Sad
Ich hoffe das ihr mir helfen könnt

Sie Anhang


Angehängte Dateien
.xlsx   Arbeitszeitenanalysen.xlsx (Größe: 10,77 KB / Downloads: 7)
Liebe Grüße 

Liebe und schöne Grüße von der Ostsee Smile Heart

××××××××××××××××××××××××××××××××××××××××

EXCEL 2010 
Antwortento top
#2
hi Jürgen, ich glaube ich hab's schon geschrieben: ich würde das anders machen... und hier habe ich auch etwas abgewandelt, aber egal. schau mal ob's so geht..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHI
1    MinusPlus   
2PersonalNameZeit EndeZeit SollSaldoSaldo   
3 Patrick23:570:00 23:57   
4 Jürgen0:030:00 0:03 Minus1:00
5 Peter23:230:00 23:23 Plus22:30
6 Hans23:581:00 22:58 gesamt21:30
7 Karl1:152:000:45    
8 Dieter23:540:00 23:54   
9 Maria1:452:000:15    
10 Silke2:152:00 0:15   
11         
12         

ZelleFormatWert
E3h:mm;;0
F3h:mm;;0,997916666666667

ZelleFormel
E6=WENN(D6>C6;D6-C6;0)
F6=WENN(D6<C6;C6-D6;0)
I6=WENN(I4>I5;"-"&TEXT(I4-I5;"[hh]:mm");I5-I4)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#3
Hallo Jockel,

Danke erstmal für deine Hilfe Smile

die Formel in Spalte F macht mir Probleme.
Hab deine Formel getestet.
Leider passt Spalte F nicht Sad
Spalte G habe ich manuell die richtige Uhrzeit eingegeben.

Hättest du da eine lösung?


Angehängte Dateien Thumbnail(s)
   
Liebe Grüße 

Liebe und schöne Grüße von der Ostsee Smile Heart

××××××××××××××××××××××××××××××××××××××××

EXCEL 2010 
Antwortento top
#4
hi Jürgen, müßte das nicht in den negativsaldo..? ich denke das geht so nicht, weil du sicher nicht 00:00 und 23:57 meinst weil das sind ja in der tat 23:57 ... du meinst bestimmt 24:00 und 23:57 und das wird so nicht gehen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#5
(05.06.2014, 17:47)Jockel schrieb: hi Jürgen, müßte das nicht in den negativsaldo..? ich denke das geht so nicht, weil du sicher nicht 00:00 und 23:57 meinst weil das sind ja in der tat 23:57 ... du meinst bestimmt 24:00 und 23:57 und das wird so nicht gehen...

Hallo Jockel,

du hast Recht. Aber wie mach ich dass ich Minus0:03 herausbekomme?
Hab den ganzen Tag herumgeformelt und Formatiert.
Sad
Liebe Grüße 

Liebe und schöne Grüße von der Ostsee Smile Heart

××××××××××××××××××××××××××××××××××××××××

EXCEL 2010 
Antwortento top
#6
hi Jürgen, ich schreib's gern nochmal, das geht nicht (so leicht), weil du unterscheiden musst und vorgeben musst ob und wann du 0:00 uhr und wann du 24:00 (oder 25:00 uhr..) verwendest...


Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1    MinusPlus
2PersonalNameZeit EndeZeit SollSaldoSaldo
3 Patrick23:570:000:03 
4 Jürgen0:030:00 0:03
5 Peter23:230:000:37 
6 Hans23:581:001:02 
7 Karl1:152:000:45 
8 Dieter23:540:000:06 
9 Maria1:452:000:15 
10 Silke2:152:00 0:15
11      
12      

ZelleFormatWert
D3h:mm;@1

ZelleFormel
E3=WENN(D3>C3;D3-C3;0)
F3=WENN(D3<C3;C3-D3;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#7
Hi,

ich weiß, dass es nicht so einfach ist. Deswegen Frag ich ja auch, wie man es am Besten machen kann.
Wenn ich die Uhrzeit auf 24:00 mache kommt: 24.01.1900 00:00:00 und meine gesamt Berechnung passt nicht.

Hättest du evtl. eine andere Lösung für mich?


Angehängte Dateien Thumbnail(s)
   
Liebe Grüße 

Liebe und schöne Grüße von der Ostsee Smile Heart

××××××××××××××××××××××××××××××××××××××××

EXCEL 2010 
Antwortento top
#8
(05.06.2014, 18:40)Jürschen175 schrieb: Hi,

ich weiß, dass es nicht so einfach ist. Deswegen Frag ich ja auch, wie man es am Besten machen kann.
Wenn ich die Uhrzeit auf 24:00 mache kommt: 24.01.1900 00:00:00 und meine gesamt Berechnung passt nicht.

Hättest du evtl. eine andere Lösung für mich?

halloooooo, das ist nicht nur nicht einfach, das geht schlicht nicht... oder du zauberst ein datum jeweils dazu...

wenn man 24:00 eingibt bekommt man 01.01.1900 00:00:00 oder 1, aber nicht 24.01.1900 (unter keinen umständen..!!!)

ich weiß auch nicht, was mir dein bildchen sagen soll, ich sehe ja nicht welche formel du verwendest und welches format, bei mir sieht da so aus..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJ
1    MinusPlus    
2PersonalNameZeit EndeZeit SollSaldoSaldo    
3 Patrick23:570:000:03     
4 Jürgen0:030:00 0:03 Minus50:4801:03
5 Peter23:230:000:37  Plus00:1822:33
6 Hans23:581:001:02  gesamt-50:3021:30
7 Karl1:152:000:45     
8 Dieter23:540:000:06     
9 Maria1:452:000:15     
10 Silke2:152:00 0:15    
11          
12          

ZelleFormatWert
I4[hh]:mm2,11666666666667
J4[hh]:mm0,04375
I5[hh]:mm1,25000000000001E-02
J5[hh]:mm0,939583333333333
I6h:mm;@-50:30
J6h:mm;@0,895833333333333

ZelleFormel
I6=WENN(I4>I5;"-"&TEXT(I4-I5;"[hh]:mm");I5-I4)
J6=WENN(J4>J5;"-"&TEXT(J4-J5;"[hh]:mm");J5-J4)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#9
Hallo ,

nochmal Danke für deine kostbare Zeit.
Aber deine Auswertung ist falsch. Wie kommst du bei i4 auf 50:48?
Richtig wäre 2:48

ODER lieg ich da auch falsch?
Liebe Grüße 

Liebe und schöne Grüße von der Ostsee Smile Heart

××××××××××××××××××××××××××××××××××××××××

EXCEL 2010 
Antwortento top
#10
(05.06.2014, 19:07)Jürschen175 schrieb: Hallo ,

nochmal Danke für deine kostbare Zeit.
Aber deine Auswertung ist falsch. Wie kommst du bei i4 auf 50:48?
Richtig wäre 2:48

ODER lieg ich da auch falsch?

hallo Jürgen, da liegst du nicht falsch..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 HI
4Minus2:48
5Plus5:33
6gesamt2:45

ZelleFormel
I4=SUMME(E3:E12)
I5=SUMME(E4:E13)
I6=WENN(I4>I5;"-"&TEXT(I4-I5;"h:mm");I5-I4)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste