Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Messwerte Aufteilen
#1
Guten Tag Zusammen,

folgendes Problem habe ich, ich würde gerne die Messwerte die ich Unregelmäßig pro monat bekomme auf den gesamten monat aufteilen.
also für die Messung 05.01 und 07.01 das dann automatisch für den 06.01 ein Mittelwert zwischen den Werten vom 5 und 7 gebildet wird.

Besten Dank,
Ludger


.xlsx   Mappe1.xlsx (Größe: 10,4 KB / Downloads: 15)
to top
#2
Moin Ludger,

wie kommen diese "gar lustigen" von dir eingetragenen Zwischenwerte zustande? Irgendwie passen die nirgendwo in ein mir bekanntes oder ersichtliches Schema.
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
to top
#3
Hallo Ludger

Was ist denn der tiefere Sinn dieser Aktion?
Du erhältst dann Werte, die nie gemessen wurden.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#4
Hallöchen,

hier mal ein Ansatz. Am 8.1. hast Du Dich übriggens verrechnet.
Arbeitsblatt mit dem Namen 'Tabelle1'
 FGH
7DatumMin 
805.01.150 
906.01.157,58
1007.01.1515 
1108.01.15142,5158
1209.01.15300 
1310.01.15333333
1411.01.15367367
1512.01.15400 
1613.01.15500500
1714.01.15600 
1815.01.15700700
1916.01.15800 

ZelleFormel
H9=G8+(G10-G8)/2
H11=G10+(G12-G10)/2
H13=G12+(G15-G12)/3
H14=G13+(G15-G13)/2
H16=G15+(G17-G15)/2
H18=G17+(G19-G17)/2
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#5
moin moin,

also die Messwerte kommen von einer Pumpe die Wasser zu einem Klärwerk befördert und ich möchte in dem ich die Mittelwerte der Tage berechne an denen es keine Messwerte gibt erkennen ob in Regenarmen zeiten die Pumpe anspringt, sprich viel Fremdwasser in die Kanalisation läuft und zur Kläranlage gelangt.

Von daher wäre es praktisch wenn die Formel einmal die unrgelmäßigen Messwerte aufteilt, also in einem vollständigen Kalender einträgt und an den Tagen wo kein Messwert vorhanden ist dann einen Mittelwert ausgibt.
Also Sprich die Spalte G automatisch durch runterziehen ausgefüllt wird.


vieleicht habt ihr ja Ideen,
Gruß
to top
#6
Hallöchen,

also hier ist erst mal wieder die Theorie.

Du erzeugst eine Tabelle mit allen Tagen.
Die Messdaten kannst Du mit einer Formel mit SVERWEIS holen. Das wäre eine Hilfsspalte, die Du eventuell auch ausblenden kannst, wenn Du diese "Lückenliste" nicht sehen willst.

Anschließend wird per Formel eine vollständige Liste erzeugt, im Prinzip so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
111
2 2
3 3
444
5 5
666
7 7
8 8
9 9
101010

ZelleFormel
B1=WENN(A1<>"";A1;"")
B2=WENN(A2<>"";A2;(INDEX(A2:$A$10;VERGLEICH("?*";INDEX(A2:A1001&"";0);0);1)-D1)/VERGLEICH("?*";INDEX(A2:A1001&"";0);0)+D1)
B3=WENN(A3<>"";A3;(INDEX(A3:$A$10;VERGLEICH("?*";INDEX(A3:A1002&"";0);0);1)-D2)/VERGLEICH("?*";INDEX(A3:A1002&"";0);0)+D2)
B4=WENN(A4<>"";A4;(INDEX(A4:$A$10;VERGLEICH("?*";INDEX(A4:A1003&"";0);0);1)-D3)/VERGLEICH("?*";INDEX(A4:A1003&"";0);0)+D3)
B5=WENN(A5<>"";A5;(INDEX(A5:$A$10;VERGLEICH("?*";INDEX(A5:A1004&"";0);0);1)-D4)/VERGLEICH("?*";INDEX(A5:A1004&"";0);0)+D4)
B6=WENN(A6<>"";A6;(INDEX(A6:$A$10;VERGLEICH("?*";INDEX(A6:A1005&"";0);0);1)-D5)/VERGLEICH("?*";INDEX(A6:A1005&"";0);0)+D5)
B7=WENN(A7<>"";A7;(INDEX(A7:$A$10;VERGLEICH("?*";INDEX(A7:A1006&"";0);0);1)-D6)/VERGLEICH("?*";INDEX(A7:A1006&"";0);0)+D6)
B8=WENN(A8<>"";A8;(INDEX(A8:$A$10;VERGLEICH("?*";INDEX(A8:A1007&"";0);0);1)-D7)/VERGLEICH("?*";INDEX(A8:A1007&"";0);0)+D7)
B9=WENN(A9<>"";A9;(INDEX(A9:$A$10;VERGLEICH("?*";INDEX(A9:A1008&"";0);0);1)-D8)/VERGLEICH("?*";INDEX(A9:A1008&"";0);0)+D8)
B10=WENN(A10<>"";A10;(INDEX(A10:$A$10;VERGLEICH("?*";INDEX(A10:A1009&"";0);0);1)-D9)/VERGLEICH("?*";INDEX(A10:A1009&"";0);0)+D9)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg

Ich bastle dann mal noch im Original ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#7
Hallo,

meine Version:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
405.01.1510,0
506.01.1507,5
607.01.15115,0
708.01.150157,5
809.01.151300,0
910.01.150333,3
1011.01.150366,7
1112.01.151400,0
1213.01.150500,0
1314.01.151600,0
1415.01.150700,0
1516.01.151800,0
1617.01.150816,7

ZelleFormel
B4=ZÄHLENWENN(D:D;A4)*1
C4=WENN(B4=1;SVERWEIS(A4;D:E;2;0);(INDEX(E:E;VERGLEICH(VERWEIS(9;1/($B$3:B3=1);$A$3:A3);D:D;0))-INDEX(E:E;VERGLEICH(A4;D:D;1)+1))/(INDEX(E:E;VERGLEICH(A4;D:D;1))-VERWEIS(9;1/($B$3:B3=1);$A$3:A3)))
B5=ZÄHLENWENN(D:D;A5)*1
C5=WENN(B5=1;SVERWEIS(A5;D:E;2;0);C4+(INDEX(E:E;VERGLEICH(A5;D:D;1)+1)-INDEX(E:E;VERGLEICH(VERWEIS(9;1/($B$3:B4=1);$A$3:A4);D:D;0)))/(INDEX(D:D;VERGLEICH(A5;D:D;1)+1)-VERWEIS(9;1/($B$3:B4=1);$A$3:A4)))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Hallo Edgar,

was steht denn in Deinen "unsichtbaren" Spalten? In meinem Beispiel war anscheinend auch was versteckt, aber statt Spalte D B nehmen, dann klappt es auch mit dem Nachbarn :-)

Hier mal die angepasste Lösung.

Arbeitsblatt mit dem Namen 'Tabelle1'
 EFG
7DatumMin 
805.01.1500
906.01.15 7,5
1007.01.151515
1108.01.15 157,5
1209.01.15300300
1310.01.15 333,333333
1411.01.15 366,666667
1512.01.15400400
1613.01.15 500
1714.01.15600600
1815.01.15 700
1916.01.15800800
2017.01.15 816,666667
2118.01.15 833,333333
2219.01.15850850
2320.01.15 852,5
2421.01.15 855
2522.01.15 857,5
2623.01.15860860
2724.01.15 873,333333
2825.01.15 886,666667
2926.01.15900900
3027.01.15 1050
3128.01.1512001200
3229.01.1513001300
3330.01.15 #NV

ZelleFormel
F8=WENNFEHLER(SVERWEIS(E8;$B$7:$C$18;2;FALSCH);0)
G8=F8
F9=WENNFEHLER(SVERWEIS(E9;$B$7:$C$18;2;FALSCH);"")
G9=WENN(F9<>"";F9;(INDEX(F9:$F$38;VERGLEICH("?*";INDEX(F9:$F$38&"";0);0);1)-G8)/VERGLEICH("?*";INDEX(F9:$F$38&"";0);0)+G8)
F10=WENNFEHLER(SVERWEIS(E10;$B$7:$C$18;2;FALSCH);"")
G10=WENN(F10<>"";F10;(INDEX(F10:$F$38;VERGLEICH("?*";INDEX(F10:$F$38&"";0);0);1)-G9)/VERGLEICH("?*";INDEX(F10:$F$38&"";0);0)+G9)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#9
heje excelfreunde, elmundo,

ich denke dass elmundo mit mittelwerten aus zwei hintereinander liegenden messpunkten keine neue information erhält.
(einfache geradengleichung)

Ansatz: newtonsches approximationspolyom
alle messwert sollten als stützstellen betrachtet werden und anhand eines approximationspolyoms (aus den messwerten ermittelt)
einen kurvenlauf (Monatanfang bis Monatsende) erhält und mit dem daraus abgeleiteten Polynom die zwischenwerte ermittelt.
Vielen Dank
--Janosch
                                                     
Excel 2007 (SP3), Win 10 Pro                              
to top
#10
Hallo Andre, in C bis ist die Tabelle vom TE. @Janosch, Du scheinst ja ein helles Köpfchen zu sein, aber ich glaube, du übertreibst etwas.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste