Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Messdatei auswerten aus Uhrzeit Zeit berechnen und suchen
#1
Hallo,

ich habe eine Messdatei in Excel importiert mit Spalten Datum, Uhrzeit und Messwert.

Bei der Messung habe ich Zeiten aufgeschrieben, da das Gerät mir nur die Dauer der Messung anzeigt.

Ich möchte nun vom Mittelpunkt der notierten Zeitfenster (Beginn und Ende) 15s vor und danach den Mittelwert über die Messwerte bilden.

Ich gebe also Start- und Endzeit in Excel ein und dahinter soll mir der Mittelwert ausgegeben werden.


Die Uhrzeit wird im Format hh:mm:ss."Millisekunden" ausgegeben (Bsp. 00:00:31.200 oder 00:00:32.700).

Als erstes ersetze ich "." durch "," dann kann ich mit der Uhrzeit rechnen und lasse in einer neuen Spalte die Dauer ausgeben in dem ich im die Anfangszeit von der aktuellen Uhrzeit abziehe.

Spalten A B C D E F G
A=Datum B=Uhrzeit C=Dauer/Zeit(berechnet) D=Messwert E=Beginn F=Ende G=Mittelwert

Als nächstes wollte ich Schittweise Funktionen testen mit deren Ergebnis ich ans Ziel komme.
Der erste Test hat schon nicht so funktioniert wie er soll.
Ich möchte mir die Zeile aus Spalte C ausgeben lassen in der mein notierter Messbeginn steht.
G2=ZEILE(INDEX(C2:C12;VERGLEICH(E2;C2:C12;0)))

In E2 habe ich den Beginn eingetragen im Format 00:01:04,0 (alternativ 00:01:04). Allerdings findet er nichts. Format der Suchzellen und der Referenzzelle sind Benutzerdefiniert auf hh:mm:ss,0

In G2 wird #NV ausgegeben.

Wenn ich mir aber eine beliebige Zeit mit der Kopierfunktion in E2 kopiere, wird auch z.B. 00:00:04,0 dargestellt und die Suche funktioniert. Es wird die Zeile ausgegeben in der meine notierte Zeit gefunden wird.

Was muss ich bei den Formaten der Zellen beachten achten/wie wäre es richtig?
Und wie würdet ihr generell die Berechnung für den Mittelwert machen?

Vielen Dank
Chris
Antwortento top
#2
Hola,


Zitat:In G2 wird #NV ausgegeben.


dann gibt es den Wert aus G2 nicht in der Form in C2:C12.


Ohne eine Beispieldatei wird das nur wildes Raten.

Gruß,
steve1da
Antwortento top
#3
Okay, ich habe mal ein Beispiel hochgeladen.

Dort ist zu sehen, dass einmal der Wert gefunden wird und die Zeile ausgegeben wird und einmal nicht.

Es sollen zwischen Beginn und Ende die Mitte genommen werden und von da aus in einem Intervall +- z.B. 1s der Mittelwert aus den in diesem Bereich liegenden Messwerten gebildet werden.

Gruß
chris


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 58,89 KB / Downloads: 5)
Antwortento top
#4
Hallo,

Verständnisfrage: wenn der Mittelwert einer speziell definierten Dauer berechnet werden soll, wiese dann eine Formel mi Index?

Da die Messwerte nur 1 oder 0 sind, sind das einfach Dummy-Zahlen?

mfg
Antwortento top
#5
Messwerte sind nur Dummy Zahlen.

Es war ein erster Test durch einen Abgleich sich den Index ausgeben zu lassen und damit zu sehen ob die Suche funktioniert. Aber das ist es schon gescheitert udn ich weiß nicht warum Excel das nicht findet.

Ich wollte mir die Zelle vom Start und Ende ausgeben lassen und mit der Info dann die Mitte. So dass ich am Ende an die Zellennummern komme über die ich den Mittelwert bilden will.

Das Intervall zur Mittellung entspricht nicht dem Intervall von Beginn und Ende, da etwas Sicherheit einbezogen werden soll.
Antwortento top
#6
(24.05.2016, 14:01)chris13u schrieb: Hallo,
...
Ich möchte mir die Zeile aus Spalte C ausgeben lassen in der mein notierter Messbeginn steht.
G2=ZEILE(INDEX(C2:C12;VERGLEICH(E2;C2:C12;0)))
...
Vielen Dank
Chris

Hallo Chris, du kannst getrost ZEILE() und INDEX() weglassen, da reicht ein einfacher VERGLEICH() den Wert aus F2 gibt's in C nicht (Stichwort: Rundungsfehler) Versuch mal

=VERGLEICH(F2;C2:C22;1)+1
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#7
Hallo

Für den Mittelwert ist die Formel:
Code:
=MITTELWERT(INDEX($D$2:$D$22;VERGLEICH(F2;$C$2:$C$22;0)):INDEX($D$2:$D$22;VERGLEICH(G2;$C$2:$C$22;0)))
Das Problem mit #NV liegt an der Tatsache dass Zeiten immer als Bruchteil eines Tages dargestellt werden (1 = ein Tag) und damit letztendlich auch an der Gleitkommaproblematik.

Abhilfe:
In F2:G4 eine Gültigkeitsprüfung einbauen mit Bezug auf C2:C22.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#8
Vielen Dank für die Hilfe.

Der Hinweis mit dem Gleitkomma und damit die angezeigten Zeiten nicht exakt dem entspricht, was man sieht hat geholfen.
Suche jetzt nicht nach "genauer Übereinstimmung" sondern nach Werten nahe der eingegebenen Zeit. Dann klappt es mit der Suche und damit mit der weiteren Berechnung.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste