Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Mehrere Wenn...
#1
Hallo zusammen,

ich steh mal wieder vor einem Excel Problem obwohl ich dachte ich würde endlich mal die Wenn Formel verstehen...

Ich habe eine Urlaubsplan im Tabellenblatt Urlaubsplan in dem in der Zeile 8 das Datum mit vorherige Zelle+1 jeweils erweitert wird.
In der Zeile 9 trage ich am jeweiligen Tag ein u für Urlaub ein.

Dann habe ich noch ein Tabellenblatt Dispoplan mit dem aktuellen Datum in Zelle B2.

Ich möchte nun in der Zelle D4 folgende Formel : Wenn das Datum im Urlaubsplan mit dem aktuellen Datum aus Dispoplan übereinstimmt und in der Zeile 9 ein u steht soll der Text Urlaub erscheinen.

Das habe ich probiert: =WENN(B2=Urlaubsplan!D8:AE8;WENN(Urlaubsplan!D9:AF9="u";"urlaub";""))

Aber irgendwas mach ich falsch...

kann mir bitte jemand helfen?

Vielen Dank schonmal im Voraus!
Antwortento top
#2
Hola,


Zitat:Aber irgendwas mach ich falsch..

mit Wenn kannst du nur Zelle mit Zelle vergleichen, keine Bereiche.


Code:
=WENN(WVERWEIS(B2;Urlaubsplan!D8:AE9;2;0)="u";"Urlaub";"")

Gruß,
steve1da
Antwortento top
#3
Hallo,


Zitat:Aber irgendwas mach ich falsch...


stimmt, aber ohne Tabelle ist das wie Stochern im Nebel. ZÄHLENWENN wäre hier vielleicht hilfreich. Google findet bzgl. Urlaubsplänen mit Sicherheit Tausende von Treffern, an denen Du Dich orientieren kannst.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
wow vielen Dank steve1da,

das funktioniert super!
Darf ich dich noch fragen ob ich da noch eine 2. Abfrage einbauen kann, also z.B. wenn statt "u" ein"k" steht, das dann der Text "Krank" erscheint?

Danke, danke, danke!

Thomas
Antwortento top
#5
Hola,

eine Möglichkeit:


Code:
=WENNFEHLER(WAHL(VERGLEICH(WVERWEIS(B2;Urlaubsplan!D8:AE9;2;0);{"u"."k"};0);"urlaub";"krank");"")

Gruß,
steve1da
Antwortento top
#6
Hi Thomas,


Code:
=WENN(WVERWEIS(B2;Urlaubsplan!D8:AE9;2;0)="u";"Urlaub";WENN(WVERWEIS(B2;Urlaubsplan!D8:AE9;2;0)="k";"krank";"")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#7
Thumbs Up 
Und wieder eine schnelle Antwort [Bild: thumbsup.gif]

Wenn ich das richtig verstehe vergleicht er mit dieser Formel einen Bereich. Aber ich habe natürlich wieder das wichtigste vergessen:

Ich habe in diesem Urlaubsplan mehrere Mitarbeiter, der erste funktioniert mit dieser Formel super, der zweite in der Zeile darunter (Urlaubsplan 10) und die weiteren funktionieren so nicht. Ich müsste die Formel also so abändern, dass Mitarbeiter 1 nur die Zeile 9, Mitarbeiter 2 nur die Zeile 10 usw. vergleicht. Das Datum steht immer in Zeile 8.

Wie muss ich die Formel dahingehend abändern?

Sorry für die viele Arbeit, aber ich lerne mit jeder Antwort...

Vielen Dank!
Antwortento top
#8
Hola,

jetzt hätte ich dann (wie Bosko) auch gerne eine Beispieldatei.

Gruß,
steve1da
Antwortento top
#9
Na klar, 

ist einfacher als meine wirren Gedankengänge [Bild: smile.gif]


Angehängte Dateien
.xlsm   test upload.xlsm (Größe: 68,17 KB / Downloads: 5)
Antwortento top
#10
Hola,


Code:
=WENNFEHLER(WAHL(VERGLEICH(INDEX(Urlaubsplan!$B$8:$NJ$28;VERGLEICH($B4;Urlaubsplan!$B$8:$B$28;0);VERGLEICH($B$2;Urlaubsplan!$B$8:$NJ$8;0));{"u"."k"};0);"urlaub";"krank");"")

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste