Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Maximale Summe ohne definierten Bereich finden
#1
Hallo liebe Forenmitglieder,
ich stehe gerade irgendwie auf dem Schlauch. Vielleicht könnt ihr mir helfen.

In vereinfachter Form:
Ich habe folgende Tabelle:
Code:
    A
1    3
2    5
3    2
4    4
5    6
6    8
7    9
8    3
9    4
10    1


Mein Ziel ist es, die maximale Summe und die zugehörige Anfangszeile von 3 hintereinanderstehenden Zahlen zu finden, also hier (6+8+9 mit Beginn A5) und das im Bereich von A1 bis A10. Wenn es sich irgendwie vermeiden lässt, würde ich ungern eine weitere Spalte anlegen.

Hat jemand eine Idee?

Habe schon eine Schleife als Makro überlegt, aber da ich da nicht so fit drin bin, hoffe ich, dass es auch einfacher geht. Und ich wüsste nicht, ob ich so überhaupt ein Maximum ermitteln kann.

Ganz liebe Grüße
Blesbie
Antwortento top
#2
Moin,

verwende eine Hilfsspalte. In B3 die Formel =SUMME(A1:A3) und ndann bis zur letzten belegten Zeile (Spalte_A) runter ziehen. Dann per =MAX(B:B) den höchsten Wert errechnen.
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
[-] Folgende(r) 1 Benutzer sagt Danke an GMG-CC für diesen Beitrag:
  • Blesbie
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste