Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Matrixübertragung
#1
hallo,

ich habe ein Arbeitsblatt mit folgender vereinfachten Matrix

                    Betty      Heino     Samy
Methode A    Experte
Methode B    Experte              Experte
Methode C                Experte



Jetzt habe ich ein anderes Arbeitsblatt wo zur methode die Namen der experten gelistet werden sollen:

Methode A       Methode B        Methode C    

Experte        Experte          Experte


Und unter die experten sollen die Namen angegeben werden untereinander die experte zu der dazugehörigen Methode in Zeile 1 ist......

Wie ist die Formel dazu? wie mache ich das am besten

Vielen Dank und schönen Tag noch
twobbi


Angehängte Dateien
.xlsx   Matrix.xlsx (Größe: 9,3 KB / Downloads: 5)
to top
#2
Hallo,

so z.B.:

Arbeitsblatt mit dem Namen 'User Skills'
 ABCDEFGH
1Methode AMethode BMethode CMethode DMethode EMethode FMethode GMethode H
2        
3ExperteExperteExperteExperteExperteExperteExperteExperte
4Joseph, MariaBarclay, BettyDeluxe, Samy Mustermann, Heinz Müller, Heinz 
5        
6        
7        
8        
9        

ZelleFormel
A4{=WENNFEHLER(INDEX(Matrix!$A$2:$F$2;KKLEINSTE(WENN(INDEX(Matrix!$A$3:$F$10;SPALTE(A1);)=A$3;SPALTE(INDEX(Matrix!$A$3:$F$10;SPALTE(A1);)));ZEILE(A1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hallo Bosko,

habe das mal meiner Matrix angepasst, aber die Angaben stimmen nicht überein.

Habe daher mal das verfälschte Original angehängt.


VG
Twobbi

P.s. was hat es mit { und }  auf sich??


Angehängte Dateien
.xlsm   Matrix2.xlsm (Größe: 106,06 KB / Downloads: 6)
to top
#4
Hallo,

Zitat:habe das mal meiner Matrix angepasst

wohl eher nicht! Das kommt davon, wenn man verfälschte Dateien einstellt! Leerzeilen in einer Tabelle sind vielleicht gut für die Optik aber ansonsten Sch...



Code:
=WENNFEHLER(INDEX(Matrix_Skills!$2:$2;KKLEINSTE(WENN(INDEX(Matrix_Skills!$I$4:$AS$121;VERGLEICH('User Skills'!B$1;Matrix_Skills!$B$4:$B$121;0);)=B$3;SPALTE(Matrix_Skills!$I$4:$AS$4));ZEILE($A1)));"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • twobbelix
to top
#5
vieeeeeeeelen lieeeeeben Dank Bosko,

da brauch ich jetzt nur noch ein paar Wochen um dies jetzt auch zu verstehen 05

Wünsch Dir ein schönes WE

VLG
Twobbi
to top
#6
(04.03.2016, 15:53)twobbelix schrieb: vieeeeeeeelen lieeeeeben Dank Bosko,

da brauch ich jetzt nur noch ein paar Wochen um dies jetzt auch zu verstehen  05

Wünsch Dir ein schönes WE

VLG
Twobbi

Hallo, hoffentlich postest du die Lösung auch ins Nachbar-Forum..!!!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste