Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Matrixformel
#1
Hallo zusammen,

ich habe folgendes Problem:
Ich habe in einer Datei eine Matrixformel erstellt, die sich die Daten aus einer anderen Datei (Lagerplatzliste) holen soll, was auch Problemlos funktioniert hat. Als ich die Datei einige Zeit später erneut geöffnet habe, kam dann ein Pop-Up bezüglich "Verknüpfung zu anderen Datenquellen" man hat dann die Auswahl zwischen "Aktualisieren" // "Nicht aktualisieren" // "Hilfe". Anfangs war es dann so, wenn ich "Nicht aktualisieren" auswählte funktionierte es weiterhin, doch sobald ich "Aktualisieren" auswähle, erscheint kein Ergebniss mehr (was jetzt auch passiert wenn ich "nicht aktualisieren" verwende).

Die Formel sieht so aus:

{=WENNFEHLER(INDEX('L:\30_ROT_Kanban_Supermarkt\Lagerplätze\Rottenburg\[Lagerplatzdaten.xls]Lagerplatzdaten'!$I$2:$I$3148;KGRÖSSTE(('L:\30_ROT_Kanban_Supermarkt\Lagerplätze\Rottenburg\[Lagerplatzdaten.xls]Lagerplatzdaten'!$A$2:$A$3148=$C$2)*(ZEILE('L:\30_ROT_Kanban_Supermarkt\Lagerplätze\Rottenburg\[Lagerplatzdaten.xls]Lagerplatzdaten'!$A$2:$A$3148)-1);ZÄHLENWENN('L:\30_ROT_Kanban_Supermarkt\Lagerplätze\Rottenburg\[Lagerplatzdaten.xls]Lagerplatzdaten'!$A$2:$A$3148;$C$2)+1-ZEILE(A1)));"")}

Woran liegt es nun, dass ich die Datei "Lagerplatzliste" öffnen muss um ein Ergebniss zu erhalten?Huh

Vielen Dank vorab für eure Hilfe!
Gruß Sven
MfG
Sven
Antwortento top
#2
Hallo,

zumindest die Funktion Zählenwenn() kann nicht auf geschlossene Dateien zugreifen.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Sven_1991
Antwortento top
#3
Hallo Peter,

Danke für deine schnelle Antwort!
Gibt es eine Möglichkeit, wie ich die Zählenwenn-Funktion umgehen kann oder eventuell eine Alternative?

Gruß Sven
MfG
Sven
Antwortento top
#4
Hallo,

du könntest Zählenwenn() durch die Funktion Summenprodukt() ersetzen:

Tabelle1

ABC
12
2a2a
3b
4c
5a
6d
7
Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN(A2:A10;C2)
B2=SUMMENPRODUKT(--(A2:A10=C2))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Sven_1991
Antwortento top
#5
Super, hat geklappt!Smile

Vielen Dank!28
MfG
Sven
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste