Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Matrix für Tarifvergleiche
#1
Guten Morgen,

hoffe ihr könnt mir weiterhelfen. Und zwar vergleichen wir akutell die Tarife unserer Dienstleister (Speditionen). Daher möchte ich mich den letztjährigen Sendungsdaten (Empfangs-PLZ & Gewicht) die einzelnen Tarife vergleichen.

Der Tarif ist z.B. wie folgt aufgebaut:

?mage

Ich habe nun z.B. eine Sendung mit 60kg in die PLZ 10 - sprich er sollte mit 31,30 ausspucken usw.....ich denke ihr wisst was ich meine.
Wie muss die SVERWEIS Formel aussehen?! Aktuelle habe ich: =WENNFEHLER(SVERWEIS(G4;Tabelle1!$B$2:$BZ$59;1+SVERWEIS(C4;Tabelle1!$B$1:$BZ$1;1;0);WAHR)*$H3;0)

Ich stehe irgendwie auf dem Schlauch - hoffe ihr könnt mir helfen! Danke im voraus.

Gruß Marco
to top
#2
Hola,

ungetestet:


Code:
=INDEX(A1:I10;VERGLEICH(60;A1:A10;0);VERGLEICH(10;A1:I1;0))


Siehe auch:

http://www.excelformeln.de/formeln.html?welcher=39

Gruß,
steve1da
to top
#3
Hi,

wie würde das ganze Aussehen wenn der Tarif in dem die Ergebnisse zu finden sind in einem separaten Blatt sind?
to top
#4
Hola,

dann musst du den Blattnamen vor die Suchbereiche schreiben.

Gruß,
steve1da
to top
#5
Ich blick's irgendwie nicht.

Ich habe als Sendungs z.b 60 kg in die PLZ 10.
Das heisst ich suche sowohl die PLZ als auch die KG. In dieser Matrix steht dann bei 60kg bei PLZ 10 ein Wert XY.

Dieser Wert soll mir in einem Blatt in einer Spalte meiner Wahl wiedergegeben werden.

Bisher hat unsere EDV das ganze immer über einen komplizierten SVERWEIS gelöst - diesen zu kopieren und anzupassen hat leider bisher nicht funktioniert.
to top
#6
(22.03.2016, 08:49)steve1da schrieb: Hola,

ungetestet:


Code:
=INDEX(A1:I10;VERGLEICH(60;A1:A10;0);VERGLEICH(10;A1:I1;0))


Siehe auch:

http://www.excelformeln.de/formeln.html?welcher=39

Gruß,
steve1da

HI Steve, vielleicht wäre es besser, bei den VERGLEICH()en WAHR bzw. 1 zu wählen...

btw.:das ginge sicher auch mit einem SVERWEIS() ...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
(22.03.2016, 09:11)ElLubinho schrieb: Ich blick's irgendwie nicht.

Ich habe als Sendungs z.b 60 kg in die PLZ 10.
Das heisst ich suche sowohl die PLZ als auch die KG. In dieser Matrix steht dann bei 60kg bei PLZ 10 ein Wert XY.

Dieser Wert soll mir in einem Blatt in einer Spalte meiner Wahl wiedergegeben werden.

Bisher hat unsere EDV das ganze immer über einen komplizierten SVERWEIS gelöst - diesen zu kopieren und anzupassen hat leider bisher nicht funktioniert.

Hallo, poste doch mal (d)eine (Beispiel)datei... ... der SVERWEIS() auf einem Blatt geht so..: =SVERWEIS(M11;A2:I10;VERGLEICH(M12;A1:I1;1);1)
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Beispiel anbei - die echte Matrix ist natürlich bedeutend umfangreicher....


Angehängte Dateien
.xls   Beispiel Matrix.xls (Größe: 84,5 KB / Downloads: 4)
to top
#9
Hola,

wie gesagt, einfach den Blattnamen vor die Bereiche schreiben....

Code:
=INDEX(Tabelle1!$A$1:$I$10;VERGLEICH(D3;Tabelle1!$A$1:$A$10;0);VERGLEICH(C3;Tabelle1!$A$1:$I$1;0))


Allerdings hast du immer unterschiedliche Formate in den Tabellen, mal TEXT, mal ZAHLEN. Vorher also in C3:

=TEXT(LINKS(A3;LÄNGE(A3)-2);"00")*1

Und in Tabelle 1 die KG Werte in Zahlen umwandeln.

Gruß,
steve1da
to top
#10
(22.03.2016, 09:25)ElLubinho schrieb: Beispiel anbei - die echte Matrix ist natürlich bedeutend umfangreicher....

Hallo, das glaub ich gern... ... wieso stehen in der Spalte A keine Zahlen ...? Das ist wenig verständlich und kompliziert die Sache unnötig...!!! Gibt es auch PLZ's mit führender Null..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste