Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Matrix - Formel komprimierbar?
#1
Smile 
Hallo zusammen,

aktuell versuche ich den zeitlichen Ablauf von einem Produktionsprozess abzubilden. Die (Rüst)Zeiten ergeben sich durch die Umrüstung von der Merkmalskombination (vertikal) der Zeile auf die Merkmalskombination (horizontal) der Spalte.

Schematisch sieht die Matrix so aus:

_____________ a ab .......
_____________ b b
_____________ c c
_____________ d d
_____________ e e
a b c d e____ 10 15
.
.
.

Die Zeiten die ein Umrüsten von z.B. Komponente "a" auf "ab" verursacht werden aus einem anderen Tabellenblatt(Datenbasis) gezogen.
Hier sind die Zeiten für die Wechsel auf die verschiedenen Komponenten abgebildet.

Datenbasis:

a auf a 10 minuten
a auf ab 15 Minuten

Die Zeiten in der Matrix werden nun durch folgende Formel bestimmt:

=WENN(UND(Matrix!A6=Datenbasis!A1;Matrix!F1=Datenbasis!B1);SUMME(Datenbasis!C1))

Hier wird nun geprüft ob Komponente "a" z.B. auf Komponente "a" auf der Komponentenkombination der horizontalen trifft. Wenn das zutrifft, wird die hinterlegte Zeit aus der Datenbasis gezogen.

Das Problem:

Es gibt so viele Kombinationsmöglichkeiten, dass die Abbildung mit dieser Formel:"=WENN(UND(Matrix!A6=Datenbasis!A1;Matrix!F1=Datenbasis!B1);SUMME(Datenbasis!C1))" die Zeichenbegrenzung sprengt.

Die Frage:

gibt es eine platzsparendere Möglichkeit bzw. Formel, die die Zeiten aus der Datenbasis in der Matrix abbilden kann? Auch Vorschläge für eine komplett andere Herangehensweise sind willkommen Smile

Ich bedanke mich schon mal im Voraus für jede Hilfe!

Liebe Grüße,
Jonas
to top
#2
Hola,

auch hier der Hinweis.

http://www.clever-excel-forum.de/Thread-Crossposting

Gruß,
steve1da
to top
#3
Sorry da hatte ich mir tatsächlich keine Gedanken drüber gemacht.

Hier die die Links zu den anderen Foren, in denen diese Problematik außerdem gepostet wurde:

http://www.office-loesung.de/p/viewtopic.php?f=166&t=713141&p=2950050#wrap

http://www.office-hilfe.com/support/show...post148362

Liebe Grüße,
Jonas
to top
#4
Hi Jonas,

ich galube, ohne Beispieltabelle wird das nichts. Lade doch bitte deine anonymiserte Tabelle mit einigen wenigen Zeilen hoch. Vielleicht wird es dann klarer.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#5
Hallo zusammen,

hier eine schmatische Darstellung des Problems. Ich hoffe das verdeutlicht die Problematik Smile


Liebe Grüße,
Jonas


Angehängte Dateien
.xlsx   Matrix_Schema.xlsx (Größe: 14,72 KB / Downloads: 7)
to top
#6
Hallo,

wenn Du noch zwei drei weitere Ergebnisse darstellen könntest, könnte man es vielleicht verstehen.
Gruß Atilla
to top
#7
Hallo,

hier noch eine ausführlichere Datei, ich hoffe das Problem wird hier klarer.

Schöne Grüße,
Jonas


Angehängte Dateien
.xlsx   Matrix_Schema 2.0.xlsx (Größe: 9,57 KB / Downloads: 7)
to top
#8
Hallo,

die Datei ist ein absolut schlechtes und schlampiges Beispiel, die Namen haben unterschiedliche Schreibweisen und das Ergebnis stimmt z.T. nicht! Aber in drei Foren die Leute beschäftigen!!!! 24 Angrysmiley


Arbeitsblatt mit dem Namen 'Matrix'
 ABCDEFG
1    ModellTyp ITyp II
2    Türab
3    Fenstercd
4    Griffef
5ModellTürFensterGriff   
6Typ Iace 15 
7Typ IIbdf 35 

ZelleFormel
F6=MAX(SUMMEWENNS(Datenbasis!$D$2:$D$5;Datenbasis!$B$2:$B$5;B6;Datenbasis!$C$2:$C$5;INDEX($F$2:$G$4;1;VERGLEICH(A6;$F$1:$G$1;0)));SUMMEWENNS(Datenbasis!$D$7:$D$9;Datenbasis!$B$7:$B$9;C6;Datenbasis!$C$7:$C$9;INDEX($F$2:$G$4;2;VERGLEICH(A6;$F$1:$G$1;0)));SUMMEWENNS(Datenbasis!$D$11:$D$13;Datenbasis!$B$11:$B$13;D6;Datenbasis!$C$11:$C$13;INDEX($F$2:$G$4;3;VERGLEICH(A6;$F$1:$G$1;0))))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#9
Hallo,

wenn in Zelle F7, so wie bei Edgar, die 35 gestanden hätte, dann hätte ich das auch schon so wie Edgar gelöst.  24 47

Den Beitrag habe ich jetzt nur geschrieben, weil Edgar Smileys mir so gefallen haben. 19
Ich kann ihn mir fast leibhaftig vorstellen, wie er vor einem steht und einen mit diesen Blicken anguckt.
Gruß Atilla
to top
#10
Hi atilla,

ich stelle mal ein Bild von mir, auf dem ich den bösen Blick drauf habe. Kleine Kinder fangen dann vor Angst an zu schreien. 19 19 19
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste