Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Matrix Auswertung (Formeln?)
#1
Siehe Beilage

Ich benötige eine Formel pro Zeile, welche folgendes aus dem Beispiel ausliest und ausweist

Pro Zeile die Reihenfolge, gemäss Zelleninhalte 1 2 3, also in gemäss der

Ersten Zeile: 622, 623, 600
Zweite Zeile: 622, 623, 601
Dritte Zeile: 622, 623, 603
etc.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hi,

meinst du so?

Tabelle3

ABCDEFGHIJK
1600601602603604605606
2321606605600
3321606605601
4321606605602
5321606605603
Formeln der Tabelle
ZelleFormel
I2=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A2:$G2;SPALTE(A1));$A2:$G2;0))
J2=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A2:$G2;SPALTE(B1));$A2:$G2;0))
K2=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A2:$G2;SPALTE(C1));$A2:$G2;0))
I3=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A3:$G3;SPALTE(A2));$A3:$G3;0))
J3=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A3:$G3;SPALTE(B2));$A3:$G3;0))
K3=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A3:$G3;SPALTE(C2));$A3:$G3;0))
I4=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A4:$G4;SPALTE(A3));$A4:$G4;0))
J4=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A4:$G4;SPALTE(B3));$A4:$G4;0))
K4=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A4:$G4;SPALTE(C3));$A4:$G4;0))
I5=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A5:$G5;SPALTE(A4));$A5:$G5;0))
J5=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A5:$G5;SPALTE(B4));$A5:$G5;0))
K5=INDEX($A$1:$G$1;;VERGLEICH(KKLEINSTE($A5:$G5;SPALTE(C4));$A5:$G5;0))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Gib die Formel in I2 ein und ziehe sie nach rechts und dann nach unten.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallo,

hier noch zwei andere Möglichkeiten:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNO
1601602603604612614615617620622623   622
23        12622623601623
3 3       12622623602601
4  3      12622623603622
5   3     12622623604623
6              602
7              622
8              623
9              603

ZelleFormel
L2=INDEX($A$1:$K$1;VERGLEICH(SPALTE(A1);$A2:$K2;0))
O1=INDEX($A$1:$K$1;VERGLEICH(REST(ZEILE(A1)-1;3)+1;INDEX($A$2:$K$5;KÜRZEN((ZEILE(A1)-1)/3;)+1;);0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
Hi,

da bekanntlich viele Wege nach Rom und viele Lösungen zum Ziel führen, hab' ich hier noch einen zur WAHL ;)

Tabelle3

ABCDEFGHIJK
1600601602603604605606
2321606605600
3321606605601
4321606605602
5321606605603
Formeln der Tabelle
ZelleFormel
I2=WVERWEIS(KKLEINSTE($A2:$G2;SPALTE(A1));WAHL({1;2};2:2;$1:$1);2;0)
J2=WVERWEIS(KKLEINSTE($A2:$G2;SPALTE(B1));WAHL({1;2};2:2;$1:$1);2;0)
K2=WVERWEIS(KKLEINSTE($A2:$G2;SPALTE(C1));WAHL({1;2};2:2;$1:$1);2;0)
I3=WVERWEIS(KKLEINSTE($A3:$G3;SPALTE(A2));WAHL({1;2};3:3;$1:$1);2;0)
J3=WVERWEIS(KKLEINSTE($A3:$G3;SPALTE(B2));WAHL({1;2};3:3;$1:$1);2;0)
K3=WVERWEIS(KKLEINSTE($A3:$G3;SPALTE(C2));WAHL({1;2};3:3;$1:$1);2;0)
I4=WVERWEIS(KKLEINSTE($A4:$G4;SPALTE(A3));WAHL({1;2};4:4;$1:$1);2;0)
J4=WVERWEIS(KKLEINSTE($A4:$G4;SPALTE(B3));WAHL({1;2};4:4;$1:$1);2;0)
K4=WVERWEIS(KKLEINSTE($A4:$G4;SPALTE(C3));WAHL({1;2};4:4;$1:$1);2;0)
I5=WVERWEIS(KKLEINSTE($A5:$G5;SPALTE(A4));WAHL({1;2};5:5;$1:$1);2;0)
J5=WVERWEIS(KKLEINSTE($A5:$G5;SPALTE(B4));WAHL({1;2};5:5;$1:$1);2;0)
K5=WVERWEIS(KKLEINSTE($A5:$G5;SPALTE(C4));WAHL({1;2};5:5;$1:$1);2;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hallo Zusammen

Wow, super danke für euren Input, genau das hatte ich gesucht.

Jetzt noch ein Nachtrag bzw. weitere ergänzende Anfrage:

Habe auch teilweise nicht nur 1 bis 3 sondern bis zu 15 Reihenfolgen.
Wenn ich über alles Kopiere, kommt bei der Zeile wo nur 1 bis 3 Reihenfolgen die Fehler #Zahl!
Zudem habe ich dazwichen auch Zeilen ohne Werte, was wiederum den Fehler #Zahl! anzeigt.

a) Kann man dies elminieren, dass nichts da drin steht.

=> habes mit ISTFEHLER eliminieren könnnten

b) Kann man dies allenfalls auch noch in eine Zelle zusammenfügen, also einen zusammengefasten Zellenwert z.B. "601, 602, 623" - damit ich nicht 15-spalten habe, sondern genau eine Spalte mit den gesamthaften Werte in einer Zelle pro Zeile

c) Sorry jetzt habe ich noch eine andre ähnliche Matrix

Oben ist 400 401 402 403 404
ZeileUnten W899 W999 N111 X555
ZeileUnten W899 W999
ZeileUnten W999 X555

Erwartetes Resulate

einfach
1. Zeile "400, 401, 402, 404"
2. Zeile "400, 401"
3. Zeile "401, 404"

Wie geht das? Mit VERKETTEN geht das nicht


Gruss, Roger
Antwortento top
#6
Hi Roger,

stelle uns doch bitte einen Tabellenausschnitt (so wie wir es getan haben) vor oder lade eine Mustertabelle, die exakt deinem Original entspricht, hoch. Sonst kann dir nicht gezielt geholfen werden, ohne 20 mal nachfragen zu müssen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#7
Hallo Günter

Ja, sorry, würde es gerne, aber wie geht das?


Angehängte Dateien Thumbnail(s)
       
Antwortento top
#8
Hallo Roger, du kannst doch Bildchen posten...! Anstatt der Bilder eonfach (d)eine (beispiel)Datei... hochladen...!?!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#9
Hallo Roger,

Tabellentools gibt es mehrere, siehe der wichtige Beitrag
http://www.clever-excel-forum.de/Thread-...einstellen

Ich nutze bevorzugt das zweite aus dem http://www.office-loesung.de/ftopic383163_0_0_asc.php

Zur Not habe ich auf meiner Seite noch einen VBA-Code bzw. zwei Dateien mit dem code, der aber nur Mindestanforderungen erfüllt - Daten und Formeln ... Man muss das auch manuell vom code aus starten ...
http://www.xltips.de/ftxt/lnk-dow/table2www.htm
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#10
Hallo,

zum ersten Punkt:

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
 ABCDEFGHIJKLMN
1601602603604612614615617620622623   
2l        yb601622623
3 r       bd602622623
4  p      ak603622623
5   x     vz604622623

ZelleFormel
L2{=INDEX($A$1:$K$1;KKLEINSTE(WENN($A2:$K2<>"";SPALTE($A$2:$K$2));SPALTE(A1)))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Der zweite Punkt wird so ohne Weiteres nicht funktionieren (mit Verketten geht das definitiv nicht!)

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOP
1601602603604612614615617620622623     
2l        yb601;622;623601601;622601;622;623 
3 r       bd602;622;623602602;622602;622;623 
4  p      ak603;622;623603603;622603;622;623 
5   x     vz604;622;623604604;622604;622;623 

ZelleFormel
L2=VERWEIS(9;1/(M2:DD2<>"");M2:DD2)
M2{=INDEX($A$1:$K$1;KKLEINSTE(WENN($A2:$K2<>"";SPALTE($A$2:$K$2));SPALTE(A1)))}
N2{=WENNFEHLER(M2&";"&INDEX($A$1:$K$1;KKLEINSTE(WENN($A2:$K2<>"";SPALTE($A$2:$K$2));SPALTE(B1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste