Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Liste der Größten Kunden pro Einkäufer
#1
Hallo zusammen,

ich versuche eine dynamische Liste der grössten Kunden pro Einkäufer herzustellen und komme nicht weiter.
Kann mir jemand bitte helfen?

Hier ist ein Beispiel:

Einkäufer Kunde Menge
Schmidt   A        10
Schmidt   B        8
Schmidt   C        4
Müller      D        9
Müller      E        5
Müller      F        3

Wenn ich herausfinden will, welche insgesamt die x größten Kunden sind habe ich z.B. folgende Formel: =KGRÖSSTE($C$3:$C$13;ZEILE()-1) und gezogen.
Wenn ich herausfinden will, welcher Kunde pro einkäufer der größte ist, habe ich folgende Formel: {=MAX(WENN(A2:A10="Schmidt";C2:C10))}
Aber wie soll ich da herausfinden, welche die wichtigste 20 Kunden pro Einkäufer sind?  Huh

Es wäre toll, wenn jemand eine Idee hat! 19

Besten Dank im voraus
Alex
Antwortento top
#2
Hallo,

ich würde das alles mit einer Pivottabelle machen: Eine Zelle in der Datentabelle markieren - Einfügen - Pivottable und dem Assistenten folgen.

Zitat:die x größten Kunden sind

Ziehe das Feld Kunden in die Zeilenbeschriftung und das Feld Menge in Werte. Markiere eine Zelle in der Zeilenbeschriftung - rechte Maus - Filter - Top10.

Zitat:Kunde pro einkäufer der größte

Ziehe das Feld Einkäufer zusätzlich in die Zeilenbeschriftung und positioniere das Feld Einkäufer vor dem Feld Kunde.

Zitat:welche die wichtigste 20 Kunden pro Einkäufer

Setze einen Top10-Filter.
Gruß
Peter
Antwortento top
#3
Hallo,

oder auch so, mit allen Nachteilen der Matrixformeln!:

Arbeitsblatt mit dem Namen 'Tabelle1'
 HIJKLM
1EinkäuferKundeMenge   
2SchmidtA       10A       SchmidtA       
3SchmidtB       8E  
4SchmidtC       4D  
5MüllerD9   
6MüllerE5   
7MüllerF3   

ZelleFormel
K2=INDEX(I2:I7;VERGLEICH(KGRÖSSTE($J$2:$J$7;ZEILE(A1));$J$2:$J$7;0))
M2{=INDEX(I:I;VERGLEICH(MAX(WENN(H:H=L2;J:J));J:J;0))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
Hallo ihr zwei,

vielen Dank für diese zwei Möglichkeiten.
Ich habe am Ende doch noch eine andere Möglichkeit gefunden und zwar mit Summenprodukt:
=SUMMENPRODUKT(--($H$2:$H$500=H2);--($J$2:$J$500>C2))+1

Grüße
Alex
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste