Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Komplexe Abfrage
#1
Hallo,

ich habe mich heute hier angemeldet da ich zu einer komplexen Fragestellung keine Umsetzungsmöglichkeit finde:

Hintergrund:

Es gibt eine Tabelle siehe Anhang.
Das Ergebnis soll automatisch erscheinen und die Logik dahinter ist simpel:

WENN
  • AP = AP (über die gesamte Spalte gesehen)
UND
  • TYP = TYP (eigentlich nur über die vorherige Einschränkung geprüft)
UND
  • TP <> TP (ebenfalls über die vorherigen beiden Einschränkungen geprüft)
DANN
  • Füge als Ergebnis eine 1 ein
SONST
  • Füge als Ergebnis eine 0 ein
Das Problem dabei ist die Umsetzung.
Habe schon verschiedene Dinge probiert ( =WENN(ZÄHLENWENN(bla:bla;bla) > 1;"1";"0") ) oder via SVERWEIS. Leider komme ich nicht auf das gewünschte Ergebnis.
Aktuell ist das Ergebnis manuell eingetragen als Orientierungshilfe, aber das Ergebnis soll eigentlich automatisch anhand einer Formel erscheinen oder muss man hier doch eher ein Makro verwenden?

Vielen Dank für die Unterstützung.


Angehängte Dateien
.xlsx   Test - Kopie.xlsx (Größe: 12,53 KB / Downloads: 6)
Antwortento top
#2
Hola,

mit Zählenwenns() kann man mehrere Bedingungen abfragen.

Code:
=ZÄHLENWENNS($A$2:$A$8;A2;$B$2:$B$8;"<>"&B2;$C$2:$C$8;C2)


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Socimy
Antwortento top
#3
Manchmal ist es einfach zu einfach.

Genau das war es was ich brauchte.

Vielen herzlichen Dank für die schnelle und kompetente Hilfe.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste