Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Komme nicht meht weiter
#1
Hall Zusammen,
erstmal ein gutes neues Jahr zusammen.

habe folgende Frage
Ich möchte das wenn in C33 und C34 nichts steht in Zeile O33 und O34 ein leeres Feld haben.
steht in O33 oder O34 ein X dann soll er aus der verweisliste eine Zahl einfügen.


Masseneinheiten

ABCDEFGHIJKLMNO
18Flächengröße Fassade gesamt80Fassade-Sockel70
19Dämmstärke EPS140mmZeit13minPreisfaktor0,222€/mm/m²0
20Flächengröße Sockel10
21Dämmstärke XPS160mmZeit13minPreisfaktor0,344€/mm/m²
22Brandriegel160mmZeit5minPreisfaktor44,16€/mm/m²
23Brandriegel4StkLänge1,25mMenge5,00m
24Diagonalpfeile0Stk
25Apuleisten0,00m
26Sockelleiste20m
27Folie Fenster0
28Klebeband Folie0m
29Abdeckvlies20m
30Fugendichtband20
31Leibungen0
32Dübel480StkZeit8minolid; border-bottom-width:1px; border-bottom-color:#000000; ">
33Dübellänge Neubau0Länge175mmPreisfaktor0,67€/mm/m²olid; border-right-width:1px; border-right-color:#000000; ">Artikelnummerolid; border-bottom-styleConfusedolid; border-right-width:1px; border-bottom-width:1px; border-right-color:#000000; border-bottom-color:#000000; ">44
34Dübellänge Altbaubau0Länge195mmPreisfaktor1,11€/mm/m131Artikelnummer55
35
Formeln der Tabelle
ZelleFormel
D18=SUMME((Massenermittlung!B26+Massenermittlung!B22+Massenermittlung!B12)*2)
H18=SUMME(Massenermittlung!$L$33)
H19=SVERWEIS($D19;'Daten zur Kalkulationsübersicht'!B12:D25;SPALTE(B$1);0)
K19=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!$B$12:$D$25;SPALTE($C$1);0)
O19=SUMME(D19)
D20=SUMME(Massenermittlung!$K$31)
H21=SVERWEIS($D21;'Daten zur Kalkulationsübersicht'!H12:J25;SPALTE(B$1);0)
K21=SVERWEIS($D$21;'Daten zur Kalkulationsübersicht'!$H$12:$J$25;SPALTE($C$1);0)
H22=SVERWEIS($D22;'Daten zur Kalkulationsübersicht'!M12:O17;SPALTE(B$1);0)
K22=SVERWEIS($D$22;'Daten zur Kalkulationsübersicht'!$M$12:$O$17;SPALTE($C$1);0)
K23=SUMME($D$23*$H$23)
D24=SUMME(Massenermittlung!$H$13:$H$30)
D25=SUMME(Massenermittlung!$I$35+Massenermittlung!$J$35)
D26=SUMME(2*Massenermittlung!$B$30)+(2*Massenermittlung!$B$8)
D27=SUMME(Massenermittlung!$K$35)
D28=SUMME(2*Massenermittlung!$I$35+2*Massenermittlung!$J$35)
D29=SUMME(2*Massenermittlung!$B$30)+(2*Massenermittlung!$B$8)
D30=SUMME((2*Massenermittlung!$B$30)+(2*Massenermittlung!$B$8)+(4*Massenermittlung!$B$30*1,25))
D31=SUMME($D$25*$D$10/100)
D32=WENN($D$19=0;0;$D$18*6)
H32=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!$B$38:$E$51;SPALTE($B$1);0)
D33=WENN($D$19=0;0;WENN(C33="x";$D$18*6;0))
H33=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!$B$38:$E$51;SPALTE($D$1);0)
K33=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!$B$38:$D$51;SPALTE($C$1);0)
O33=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!B38:F51;SPALTE($E$1);0)
D34=WENN($D$19=0;0;WENN(C34="";0;$D$18*6))
H34=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!H38:K51;SPALTE($D$1);0)
K34=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!H38:K51;SPALTE($C$1);0)
O34=SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!H38:L51;SPALTE($E$1);0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
to top
#2
Hallo,

meinst Du so:

=WENN(O33="x";Deine SVERWEIS() Formel;"")
Gruß Atilla
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
  • wavemaster
to top
#3
Hallo atilla,

fast richtig wenn ich die formel wie folgt eingebe
=WENN(C33="x";SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!B38:F51;SPALTE($E$1);0))

zeigt die Zelle folgenden Wert " Falsch"an. Kann der Wert "Falsch" auch eine lerre Zelle sein.
to top
#4
Hallo Atilla ,

habe den Fehler gefunden.
=WENN(C33="x";SVERWEIS($D$19;'Daten zur Kalkulationsübersicht'!B38:F51;SPALTE($E$1);0);"")
die Rote markierten Gänsefüsschen mußte Ich noch anfügen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste