Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

KGRÖSSTE in Verbindung mit MITTELWERT in nicht zusammenhängendem Bereich
#1
Ich brauche mal wieder Hilfe 05

Die Funktion KGrösste {1;2;3}soll angewendet auf Zellen, die nicht direkt neben einander liegen. (D5+F5+H5+J5+L5+N5) leider erhalte ich da als Ergebnis #Zahl!. Hier die ganze Formel: =SUMME(KGRÖSSTE(D5+F5+H5+J5+L5+N5;{1;2;3}))/3
Durch 3 am Ende, weil aus den Drei besten Ergebnissen eine Art Mittelwert errechnet werden soll.
Wo liegt mein Fehler?

Vielen Dank schon mal für eure Hilfe.
?mage
to top
#2
Hi Claudia,

was hast du zwischen den jeweiligen Spalten stehen? Sollten die Zellen leer oder Textwerte sein, kannst du mit

Code:
=SUMME(KGRÖSSTE(D5:N5;{1;2;3}))/3

deinen Mittelwert berechnen. Falls aber dort ebenfalls numerische Werte stehen, dann so:

Code:
=MITTELWERT(KGRÖSSTE((D5;F5;H5;J5;L5;N5);{1;2;3}))
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
ja, in den anderen Zellen stehen andere nummerische Werte....
?mage
to top
#4
Hi Claudia,

habe deinen letzten Beitrag nicht gesehen - wieder einmal nicht aktualisiert. Sad

Ich habe meinen vorigen editiert und die entsprechende Formel gepostet.

Bitte mache doch, auch wenn die Themen ähnlich sind, für neue Fragen nach so langer Zeit ein neues Thema mit aussagekräftigem Titel aus. Dann finden User, die die Suchfunktion benutzen, die Beiträge sicherer. Daher werde ich die jetzen Beiträge abtrennen und in einem neuen Thema einfügen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#5
Danke schön für deine Hilfe und Formel.

Ich kenne es aus anderen Foren, dass es nicht gern gesehen ist, wenn für artverwandte Themen neue Posts aufgemacht werden. Ich gelobe Besserung.
?mage
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste