Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Jeden Sonntag eintragen
#1
Hallo,
nachdem ich nun mit der Suche vollstänig gescheitert bin, suche ich nach einer Möglichkeit in den Spalten ab D nur die Sonntage des aktuellen Jahres mit Datum einzutragen.
Ob dies nun per VBA oder Formel geschieht ist egal.
Ich hoffe Ihr könnt mir helfen.

Danke und Gruß
Thomas
to top
#2
Hallo

meinst du so?
Tabelle1

ABCDEF
101.01.2014Sonntag, 5. Januar 2014Sonntag, 12. Januar 2014Sonntag, 19. Januar 2014
Formeln der Tabelle
ZelleFormel
D1=WENN(WOCHENTAG(A1;2)=1;A1;8-WOCHENTAG(A1;2)+A1)-1
E1=D1+7
F1=E1+7

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Tom
[-] Folgende(r) 1 Benutzer sagt Danke an Crazy Tom für diesen Beitrag:
  • knallebumm
to top
#3
Super ich danke Dir.
Klappt wunderbar

Gruß
Thomas
to top
#4
Hallo,

hier mal zwei Alternativen:


Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
101.01.2017 So 01.01So 08.01So 15.01So 22.01
2  So 01.01   
3  So 08.01   
4  So 15.01   

ZelleFormel
C1=7*(SPALTE(A1)-(REST($A$1;7)=1))+1+$A$1-REST($A$1;7)
C2=7*(ZEILE(A1)-(REST($A$1;7)=1))+1+$A$1-REST($A$1;7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hallo zusammen,

und hier noch eine Version völlig ohne Formeln.

In A1 (kann natürlich jede beliebige Zelle sein) das Datum des ersten gewünschten Sonntags eintragen. Dann mit rechter gedrückter Maustaste so viele Zellen nach rechts oder nach unten (je nachdem, ob zeilen- oder spaltenweise ausgefüllt werden soll) markieren und danach die Maustaste loslassen. Im sich öffnenden Menü den letzten Punkt (Reihe...) anklicken und danach bei Inkrement die Zahl 7 eintragen.

Natürlich kann man die Reihe oder Spalte beliebig vom letzten eingetragenen Datum fortführen.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • HeinzBRAms
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste