Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Inventar Monatsvergleich
#1
Geschätztes Clever-Excel-Forum

Danke bereits im Voraus für Eure Bemühungen

Im Anhang habe ich ein Screenshot, das zwei Excel Files anzeigt.

Excel File Links:

Inventar Monat Mai

Excel File Rechts:

Inventar Monat Juni


Nun möchte ich mittels Funktionen ermitteln, welche Artikel waren im Monat Mai vorhanden und im Monat Juni nicht. Wie auch umgekehrt, welche Artikel habe ich im Juni inventiert und im Mai nicht. Kann man das über irgendeine Funktion ermitteln?

Müsste letztendlich so aussehen:

Nicht enthalten im Mai aber im Juni:
- Art. Nr. 4, Einheit kg, Menge X, Bezeichnung
- Art. Nr. 5, Einheit kg.....

Nicht enthalten im Monat Juni, aber im Mai schon:
- Art. Nr. 6....
- Art. Nr. 9.....

etc.


Ich bedanke mich herzlich und wünsche einen wunderschönen Tag


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hi,
bin nur am Handy - probiere mal ZÄHLENWENN
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Baani10
Antwortento top
#3
Hallo Willwissen

Danke herzlich für Deine Antwort!

Leider geht dies bei mir nicht - oder evtl. mache ich es falsch.
Hast Du eine genauere Beschreibung?

Danke herzlich und einen schönen Nachmittag
Antwortento top
#4
Hi Baani,

im folgenden Ausschnitt habe ich der Einfachheit halber die Artikellisten für Mai und Juni auf ein Blatt gelegt. Ist aber kein Problem auf tatsächlich bestehende Blätter anzupassen.

Tabelle1

ABCDEFGHIJK
1MaiJuni
2ArtikelEinheitMengeBezeichnungArtikelEinheitMengeBezeichnung
31Kg2Haxen1Kg2Haxen
42Kg5Lende2Kg5Lende
53Stk3Stangensalaminicht im Juni6Stk1Schweinehälfenicht im Mai
64Stk1Leberkäs4Stk1Leberkäs
75Stk3Lyonernicht im Juni7Kg2Hähnchenbrustnicht im Mai
Formeln der Tabelle
ZelleFormel
E3=WENN(ZÄHLENWENN($A$3:$A$7;G3);"";"nicht im Juni")
K3=WENN(ZÄHLENWENN($G$3:$G$7;A3);"";"nicht im Mai")
E4=WENN(ZÄHLENWENN($A$3:$A$7;G4);"";"nicht im Juni")
K4=WENN(ZÄHLENWENN($G$3:$G$7;A4);"";"nicht im Mai")
E5=WENN(ZÄHLENWENN($A$3:$A$7;G5);"";"nicht im Juni")
K5=WENN(ZÄHLENWENN($G$3:$G$7;A5);"";"nicht im Mai")
E6=WENN(ZÄHLENWENN($A$3:$A$7;G6);"";"nicht im Juni")
K6=WENN(ZÄHLENWENN($G$3:$G$7;A6);"";"nicht im Mai")
E7=WENN(ZÄHLENWENN($A$3:$A$7;G7);"";"nicht im Juni")
K7=WENN(ZÄHLENWENN($G$3:$G$7;A7);"";"nicht im Mai")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Baani10
Antwortento top
#5
Hi Baani,

noch ein Vorschlag - dieses Mal mit VERGLEICH

Tabelle1

ABCDEFGHIJK
1MaiJuni
2ArtikelEinheitMengeBezeichnungArtikelEinheitMengeBezeichnung
31Kg2Haxen1Kg2Haxen
42Kg5Lende2Kg5Lende
53Stk3Stangensalaminicht im Juni6Stk1Schweinehälfenicht im Mai
64Stk1Leberkäs4Stk1Leberkäs
75Stk3Lyonernicht im Juni7Kg2Hähnchenbrustnicht im Mai
Formeln der Tabelle
ZelleFormel
E3=WENN(ISTNV(VERGLEICH(A3;$G$3:$G$7;0));"nicht im Juni";"")
K3=WENN(ISTNV(VERGLEICH(G3;$A$3:$A$7;0));"nicht im Mai";"")
E4=WENN(ISTNV(VERGLEICH(A4;$G$3:$G$7;0));"nicht im Juni";"")
K4=WENN(ISTNV(VERGLEICH(G4;$A$3:$A$7;0));"nicht im Mai";"")
E5=WENN(ISTNV(VERGLEICH(A5;$G$3:$G$7;0));"nicht im Juni";"")
K5=WENN(ISTNV(VERGLEICH(G5;$A$3:$A$7;0));"nicht im Mai";"")
E6=WENN(ISTNV(VERGLEICH(A6;$G$3:$G$7;0));"nicht im Juni";"")
K6=WENN(ISTNV(VERGLEICH(G6;$A$3:$A$7;0));"nicht im Mai";"")
E7=WENN(ISTNV(VERGLEICH(A7;$G$3:$G$7;0));"nicht im Juni";"")
K7=WENN(ISTNV(VERGLEICH(G7;$A$3:$A$7;0));"nicht im Mai";"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Baani10
Antwortento top
#6
(20.07.2015, 15:09)WillWissen schrieb: Hi Baani,

noch ein Vorschlag - dieses Mal mit VERGLEICH 
...

Hi Günter, noch ne Variante mit ISTZAHL()

=WENN(ISTZAHL(VERGLEICH(A3;$G$3:$G$7;0));"";"nicht im Juni")

Übrigens: der TE meint zwei Dateien nicht zwei TabellenBlätter...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Baani10
Antwortento top
#7
Hi Jörg,

Zitat:noch ne Variante mit ISTZAHL()

auch'ne prima Lösung.


Zitat:Übrigens: der TE meint zwei Dateien nicht zwei TabellenBlätter...

Das habe ich ja total übersehen. Naja, wer lesen kann, ist klar im Vorteil. Aber unsere Lösungsvorschläge klappen auch bei zwei verschiedenen Dateien. Die Pfade passen sich ja an. Lästig dabei ist eigentlich nur die Abfrage, ob die Verknüpfungen aktualisiert werden sollen. In meinem Beispiel:


Zitat:=WENN(ISTNV(VERGLEICH(A5;'D:\01-Meine Daten\Forum\Testmappen\erstellte Testmappen\Baani-Inventarlisten\[Mai.xlsb]Tabelle1'!$A$3:$A$7;0));"nicht im Mai";"")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste