Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Index mit Vergleichen
#1
Hallo allerseits

Habe noch ein grosses Problem..

In der Datei gibt es das Blatt "Schiri Navi". Dort trage ich händisch die Distanzen ein, die Ein Schiri braucht um von A nach B zu kommen.
In Abhängigkeit vom Spielort (Zeilen A und B) und dem Schiri Namen (Zeile F)
soll in Spalte AV des Blattes "Auslagen" die richtige Distanz eingetragen werden.
In den Auslagen ist ebenfalls Schiri Name ausschlaggebend, zudem kann daraus geschlossen werden, wenn eine Zahl in der gleichen Zeile von D:AU steht, dass der Ort aus Zeile 3 gesucht wird.

Habe aber die andern Sheets auch mitgesendet, vielleicht muss man das ja anders verknüpfen.
Ich habe es bereits geschafft, diese Verknüpfung hinzubekommen, siehe Blatt Aufgebot2, C20. Das funktioniert aber bei Auslagen AV nicht, die zweite Bedingung fehlt...

Herzlichen Dank und einen schönen Abend Angel

Dänel


Angehängte Dateien
.xlsx   Bezüge mit versch. Variablen.xlsx (Größe: 506,68 KB / Downloads: 9)
Antwortento top
#2
(02.05.2014, 16:32)Daenel schrieb: Hallo allerseits

Habe noch ein grosses Problem..

...

Dänel

hi, ist denn das andere problem gelöst...? ich sehe kein feedback von dir...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#3
Hallo Jockel

Bist du hier der Polizist?

Ich tue, was ich kann, und antworte so schnell ich kann. Du scheinst irgendwie ein Problem zu haben.

Lass dich nicht unterkriegen, das leben ist schön.

Liebe Grüsse
Dänel
Antwortento top
#4
(02.05.2014, 16:53)Daenel schrieb: Hallo Jockel

Bist du hier der Polizist?

Ich tue, was ich kann, und antworte so schnell ich kann. Du scheinst irgendwie ein Problem zu haben.

Lass dich nicht unterkriegen, das leben ist schön.

Liebe Grüsse
Dänel

hi, nein, ich bin kein polizist, aber du ballerst aus der hüfte... anstatt ein problem abzuarbeiten, dann das nächste zu präsentieren... aber okay, wenn das deine arbeitsweise ist...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#5
Hallo Jockel

Wenn ich zwei Probleme habe, die im Prinzip nichts miteinander zu tun haben, dann glaube ich, dass ich die schon gleichzeitig Posten kann. Ich bin ja froh, gibt es Cracks wie dich, die solche Probleme lösen können.

Vielleicht kann der eine Dies und der andere Jenes.

Ja, so arbeite ich.

Dänel
Antwortento top
#6
hi, vielleicht verstehe ich das problem auch nicht... ich sehe in der datei (zu) viele baustellen... für die formel in C20 schlage ich alternativ die in C21 vor...:

Arbeitsblatt mit dem Namen 'AUFGEBOT2'
 ABC
19SchiedsrichterTaggeld
(CHF) *)
Fahrspesen
(CHF) **)
20Meier Daniel30,000,00
21Gugerli Arthur30,0025,00

ZelleFormel
C20{=WENN(A20="";"";INDEX('Schiri Navi'!A1:AS250;VERGLEICH(A20;'Schiri Navi'!E1:E250;0);VERGLEICH(B11&E10;'Schiri Navi'!A1:AS1&'Schiri Navi'!A2:AS2;0)))}
C21=WENNFEHLER(SVERWEIS(A21;'Schiri Navi'!$E$3:$AI$189;VERGLEICH($B$11;'Schiri Navi'!$E$1:$AI$1;0);0);0)
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#7
Hallo Jockel

Danke für den Lösungsvorschlag. Das Problem ist, dass ich teilweise Vereine habe, die auf verschiedenen Anlagen spielen. Mit deiner Lösung vergleicht er zwar den ausführenden Verein, nicht aber den Austragungsort.
Ausserdem funktioniert diese Formel ja prächtig, ich brauche eine Lösung für das Blatt "Auslagen", Spalte AV.

Danke und Gruss, dänel
Antwortento top
#8
(02.05.2014, 17:37)Daenel schrieb: Hallo Jockel

Danke für den Lösungsvorschlag. Das Problem ist, dass ich teilweise Vereine habe, die auf verschiedenen Anlagen spielen. Mit deiner Lösung vergleicht er zwar den ausführenden Verein, nicht aber den Austragungsort.
Ausserdem funktioniert diese Formel ja prächtig, ich brauche eine Lösung für das Blatt "Auslagen", Spalte AV.

Danke und Gruss, dänel


okay, okay, ich will nicht streiten, wenn du meinst, deine formel sei pratkikabler (prächtig), als meine bitte... ich gebe nur zu bedenken in dem fall hier in deiner dieser datei kommen wir wohl immer zum gleichen ergebnis...

in deinem VERGLEICH() -->
PHP-Code:
VERGLEICH(B11&E10;'Schiri Navi'!A1:AS1&'Schiri Navi'!A2:AS2;0


beziehst du dich auf
Arbeitsblatt mit dem Namen 'AUFGEBOT2'
 BCDEF
10Würenlos Platz:Ländli
11TV WürenlosBesammlung:13.30 Uhr

ZelleFormel
B10=SVERWEIS(Dateneingabe!B6;Spieldetails!A3:I106;4;1)
E10=SVERWEIS(Dateneingabe!B6;Spieldetails!A3:I106;5;0)
B11=SVERWEIS(Dateneingabe!B6;Spieldetails!A3:I106;6;0)
F11=E9-"003000"
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

und bei diesem SVERWEIS() beziehst du dich wiederum auf die gleiche matrix...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#9
Hallo Jockel

Du hast recht, ich finde deine Formel auch besser, vor allem weil sie keine Matrixformel ist. In meiner Formel (die ich auch nicht selber erstellt habe), müssen eben beide Zeilen übereinstimmen, also Schiri Navi Zeile 1 mit B11 UND Schiri Navi Zeile 2 mit E10.

Kann die 2. Bedingung auch in diese Formel?

Gruss
Antwortento top
#10
(02.05.2014, 17:58)Daenel schrieb: Kann die 2. Bedingung auch in diese Formel?

klar, Jörg kann das. Und wenn nicht mit dieser Formel, dann kennt er eine andere! Ich habe da vollstes Vertrauen!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste