Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Index + Vergleich
#1
Hallo an alle,

ich habe eine Schirigkeit mit dem Index berechnung, anbei die Tabelle

bis auf die PLZ 60 rechnet es gut aus aber ab der PLZ 61 gibt es ein Bezug fehler
obwohl der Bezug gleich bleibt.

=INDEX($C$4:$H$43;VERGLEICH(1;Gewicht;0);VERGLEICH($K$17;B4:B43;0))

ich habe es schon auf verschiedene Formel versucht und komme nicht hin.

jeder tipp wird mehr als gut angekommen sein

danke


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 11,06 KB / Downloads: 8)
to top
#2
(25.02.2016, 16:05)Winkler schrieb: Hallo an alle,
..
jeder tipp wird mehr als gut angekommen sein

danke

Hallo, tausche mal die beiden VERGELEICH()e... ein Blick in die Syntax beim INDEX() würde da helfen... (^_-)

EDITH: ohne deine Hilfskonstrukte ginge..:

=INDEX($C$4:$H$43;VERGLEICH(KGRÖSSTE(B4:B43;ZÄHLENWENN(B4:B43;">="&K17));B4:B43;0);VERGLEICH(KGRÖSSTE(C3:H3;ZÄHLENWENN(C3:H3;">="&K16));C3:H3;0))
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo,

da reicht aber das:


Code:
=INDEX($C$4:$H$43;VERGLEICH($K$17;$B$4:$B$43;0);VERGLEICH(K16;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;K16)=0))


Wenn man die PLZ rausnimmt, dann ginge das auch so:
Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHIJKLMN
1Preistabelle Zusatzkosten    
2             
3PLZ/Gewicht250500750100015002000 AVIS7,5   
410,830,800,770,740,680,62    PLZPreisgrp.
520,640,600,560,520,440,36 Volumengewicht:800 341
6        PLZ90 370
7        Preis pro KG0,520,52551
8        Preis gesamt416,00 € 570
9           601
10           660
11           701
12           902
13           941
14           952

ZelleFormel
K7=WENNFEHLER(INDEX($C$4:$H$5;VERWEIS($K$6;{34;37;55;57;60;66;70;90;94;95};{1;0;1;0;1;0;1;2;1;2});VERGLEICH($K$5;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;L16)=0));"PLZ nicht gelistet")
L7=WENNFEHLER(INDEX($C$4:$H$5;SVERWEIS($K$6;$M$5:$N$14;2;1);VERGLEICH($K$5;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;M16)=0));"PLZ nicht gelistet")
K8=WENNFEHLER(K7*K5;"nicht möglich")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#4
(25.02.2016, 16:18)Jockel schrieb:
(25.02.2016, 16:05)Winkler schrieb: Hallo an alle,
..
jeder tipp wird mehr als gut angekommen sein

danke

Hallo, tausche mal die beiden VERGELEICH()e... ein Blick in die Syntax beim INDEX() würde da helfen... (^_-)

EDITH: ohne deine Hilfskonstrukte ginge..:

=INDEX($C$4:$H$43;VERGLEICH(KGRÖSSTE(B4:B43;ZÄHLENWENN(B4:B43;">="&K17));B4:B43;0);VERGLEICH(KGRÖSSTE(C3:H3;ZÄHLENWENN(C3:H3;">="&K16));C3:H3;0))
Danke um die Schnelle Antwort Passt perfekt
to top
#5
(25.02.2016, 16:28)BoskoBiati schrieb: Hallo,

da reicht aber das:


Code:
=INDEX($C$4:$H$43;VERGLEICH($K$17;$B$4:$B$43;0);VERGLEICH(K16;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;K16)=0))


Wenn man die PLZ rausnimmt, dann ginge das auch so:
Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHIJKLMN
1Preistabelle Zusatzkosten    
2             
3PLZ/Gewicht250500750100015002000 AVIS7,5   
410,830,800,770,740,680,62    PLZPreisgrp.
520,640,600,560,520,440,36 Volumengewicht:800 341
6        PLZ90 370
7        Preis pro KG0,520,52551
8        Preis gesamt416,00 € 570
9           601
10           660
11           701
12           902
13           941
14           952

ZelleFormel
K7=WENNFEHLER(INDEX($C$4:$H$5;VERWEIS($K$6;{34;37;55;57;60;66;70;90;94;95};{1;0;1;0;1;0;1;2;1;2});VERGLEICH($K$5;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;L16)=0));"PLZ nicht gelistet")
L7=WENNFEHLER(INDEX($C$4:$H$5;SVERWEIS($K$6;$M$5:$N$14;2;1);VERGLEICH($K$5;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;M16)=0));"PLZ nicht gelistet")
K8=WENNFEHLER(K7*K5;"nicht möglich")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
 Auf bester form geht das Auch danke auch dir
to top
#6
(25.02.2016, 16:28)BoskoBiati schrieb: Hallo,

da reicht aber das:


Code:
=INDEX($C$4:$H$43;VERGLEICH($K$17;$B$4:$B$43;0);VERGLEICH(K16;$C$3:$H$3;1)+(ZÄHLENWENN($C$3:$H$3;K16)=0))

...
Hi Edgar, über die Brücke mit dem ersten VERGLEICH() würde ich ich gehen... wegen der 0, oder als Ergebnis soll dann "nicht möglich" kommen, falls mal eine Zahl wie 40 eingegeben wird... ... und was passiert bei deiner Berechnung bei einem Gewicht von 249 (gr)... Oooops. Wenn das so soll okay. Dann hast du (wie immer) Recht... 100
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo Jörg,

ich kann Dir bei letzterem nicht widersprechen. Ich wäre Dir nicht böse, wenn Du dazu eine Verbesserung liefern würdest.


Code:
=INDEX($C$4:$H$43;VERGLEICH($K$17;$B$4:$B$43;0);VERGLEICH(K16+249+(K16>1000)*250;$C$3:$H$3;1))
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Hi Edgar, ich bin aus dem Thema schon weg, der TE schien ja sein Wunschergebnis zu haben... Ich hatte zudem was gepostet, ob das nun besser oder schlechter ist...wer weiß das schon, Für Anders (und meist besser) bist ja du zuständig... Vielleicht sollten wir dich nominieren beim XL-Treffen... Für "Formel national alternativ"  (^_-) 15
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste