Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


In nächste leere Zelle schreiben ohne VBA möglich?
#1
Hallo Excel-Community,

ich sitze seit längerem vor folgendem Problem:

Ich habe eine Datei, die aus 2 Mappen besteht. In Mappe 1 ("Upload") wird eine Eingabe gemacht, in Mappe 2 ("Liste") soll nun nach einer bestimmten Zahl (123456789) in Spalte G (der ersten Mappe) gesucht werden, die häufiger vorkommt und in Spalte A der Mappe "Liste" ausgegeben werden, ohne dass Leerzeilen (wie bei einer simplen "=wenn()"-Funktion) enstehen.


Ich hoffe das war nicht zu kompliziert, ist das ohne VBA möglich und wenn ja, hat jemand eine Idee zu einer Formel?

Vielen Dank im Voraus!

Beste Grüße
lavici


Angehängte Dateien
.xlsx   Beispieldatei Upload - Kopie.xlsx (Größe: 9,55 KB / Downloads: 4)
Antwortento top
#2
Hallo lavici

Daten mittels Filterkriterium an eine andere Stelle kopieren:
Mit einfachen Bordmitteln: Autofilter (+ Kopieren/Einfügen) bzw. Spezialfilter.
Mit Matrix-Formeln:
Mit INDEX() und KKLEINSTE().
Die Variante ohne Duplikate.
Mit normalen Formeln:
Mit  VERGLEICH() und ZÄHLENWENN()-
Die Erweiterung zu Vorteil von VERGLEICH gegenüber SVERWEIS.
Mit VBA:
Autofilter bzw. Spezialfilter in Kombination mit einem Makro.
Spezialfilter in Kombination mit einem Makro.
Mit Datenmodell:
Seit Excel 2013..
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • lavici
Antwortento top
#3
Hi,

zuerst einmal (zum besseren Verständnis für alle ;)  ): du hast keine Datei mit zwei Mappen, sondern eine Datei (oder! eine Mappe) mit zwei Arbeits- oder Tabellenblätter.

Hier mal ein Lösungsvorschlag (ausgehend davon, dass du ausschließlich nur die "123456789" ausgelesen haben möchtest.

1. Füge vor der Vertragsspalte eine Hilfsspalte ein, die du dann ausblenden kannst.
2. Dort packst du die Formel =WENN(H2=123456789;MAX($G$1:G1)+1;"") in die Zelle G2 rein und ziehst sie runter.
3. Im Tabellenblatt Liste!A5 dann die Formel =WENNFEHLER(VERWEIS(KKLEINSTE(Upload!G:G;ZEILE(Upload!A1));Upload!G:G;Upload!H:H);"") und ebenfalls runterziehen.

So sieht's dann aus:

Upload

FGH
1MengeHSVertrag
251123456789
35999999999
4522222222222
55999999999
6511111111111
75999999999
852123456789
95999999999
105999999999
11511111111111
1253123456789
Formeln der Tabelle
ZelleFormel
G2=WENN(H2=123456789;MAX($G$1:G1)+1;"")
G3=WENN(H3=123456789;MAX($G$1:G2)+1;"")
G4=WENN(H4=123456789;MAX($G$1:G3)+1;"")
G5=WENN(H5=123456789;MAX($G$1:G4)+1;"")
G6=WENN(H6=123456789;MAX($G$1:G5)+1;"")
G7=WENN(H7=123456789;MAX($G$1:G6)+1;"")
G8=WENN(H8=123456789;MAX($G$1:G7)+1;"")
G9=WENN(H9=123456789;MAX($G$1:G8)+1;"")
G10=WENN(H10=123456789;MAX($G$1:G9)+1;"")
G11=WENN(H11=123456789;MAX($G$1:G10)+1;"")
G12=WENN(H12=123456789;MAX($G$1:G11)+1;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Liste

ABC
4VertragProduktKondition
5123456789
6123456789
7123456789
8
9
Formeln der Tabelle
ZelleFormel
A5=WENNFEHLER(VERWEIS(KKLEINSTE(Upload!G:G;ZEILE(Upload!A1));Upload!G:G;Upload!H:H);"")
A6=WENNFEHLER(VERWEIS(KKLEINSTE(Upload!G:G;ZEILE(Upload!A2));Upload!G:G;Upload!H:H);"")
A7=WENNFEHLER(VERWEIS(KKLEINSTE(Upload!G:G;ZEILE(Upload!A3));Upload!G:G;Upload!H:H);"")
A8=WENNFEHLER(VERWEIS(KKLEINSTE(Upload!G:G;ZEILE(Upload!A4));Upload!G:G;Upload!H:H);"")
A9=WENNFEHLER(VERWEIS(KKLEINSTE(Upload!G:G;ZEILE(Upload!A5));Upload!G:G;Upload!H:H);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • lavici
Antwortento top
#4
Vielen Dank für die schnellen Antworten!
Ich habe es nach dem Vorschlag von Günter gemacht, hat wunderbar geklappt!

Vielen Dank für die Hilfe!

Beste Grüße
lavici
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste