Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


Hilfe bei Sortierung
#1

.xlsx   Sortierung.xlsx (Größe: 9,71 KB / Downloads: 11)
Hallo Zusammen,

Ich habe schon viel Hilfe von Euch bekommen und möchte mich daher auch nochmals bedanken.Smile

Ich hätte nun ein anderes Problem wo ich gerne einfach lösen würde da es 8000 Zeilen sind und manuell es einfach zu aufwendig ist.

Folgendes:
Ich habe in Spalte A jeweils die Artikelnummer
In Spalte B ist der Bildlink
In Splate C ist die Bildnummer

Ich habe ein File angehängt wo ich ein Beispiel habe wie es aussieht und wie ich es gern hätte (alles auf einer Linie)

Hätte da wer ein Tipp?

Ich glaube mit einer Wenn Formel müsste es gehen aber irgendwie mit einem Vergleich. Leider habe ich bis jetzt nichts gefunden.

Besten Dank für ein Feedback.

Oli
Antwortento top
#2
Hola,


Code:
=WENNFEHLER(INDEX($B$4:$B$9;AGGREGAT(15;6;ZEILE($B$4:$B$9)-3/($A$4:$A$9=$A17);SPALTE(A1)));"")

nach rechts und nach unten kopieren.

Gruß,
steve1da
Antwortento top
#3
Hallo Steve,

Besten Dank für die Hilfe.

Ich hoffe ich klinge hier nicht zu dämlich aber ich weiss nicht genau wo einfügen und dann nach rechts und nach unten.
Meinst Du Spalte D? 

Auf alle Fälle kommt oder passiert nichts.

Da es zum Teil bis 17 Bilder sind für eine Artikelnummer und 8000+ Zeilen sollte die Lösung ja trozdem gehen?

Sorry für die viele Fragen.

Gruss

Oli
Antwortento top
#4
Moin!
Warum filterst Du Spalte A nicht einfach?
Ist imo erheblich übersichtlicher als sich mühsam horizontal durch Spalten zu scrollen.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Hallo, gemeint war das sicher so...:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
12Und so hätte ich es gern am Schluss    
136130http://jamara-shop.com/bilder/produkte/g...ausatz.pnghttp://jamara-shop.com/bilder/produkte/g...atz_b2.pnghttp://jamara-shop.com/bilder/produkte/g...atz_b3.png 
146131http://jamara-shop.com/bilder/produkte/g...ausatz.pnghttp://jamara-shop.com/bilder/produkte/g...atz_b2.pnghttp://jamara-shop.com/bilder/produkte/g...atz_b3.png 

ZelleFormel
A13=MIN($A$4:$A$9)
B13=WENNFEHLER(INDEX($B$4:$B$9;AGGREGAT(15;6;ZEILE($B$4:$B$9)-3/($A$4:$A$9=$A13);SPALTE(A1)));"")
A14=WENN(MAX($A$4:$A$9)=MAX(A$13:A13);"";KGRÖSSTE($A$4:$A$9;ZÄHLENWENN($A$4:$A$9;">"&A13)))
B14=WENNFEHLER(INDEX($B$4:$B$9;AGGREGAT(15;6;ZEILE($B$4:$B$9)-3/($A$4:$A$9=$A14);SPALTE(A2)));"")
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg

Wobei die Bereiche anzupassen sind und zu bedenken, dass die links dann noch keine Hyperlinks sind, wenn du das willst muss noch die Formel HYPERLINK() umzu...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Gabifat
Antwortento top
#6
Hallo Ralf,

2 Gründe:

1 Grund, alles filtern und Manuell umschieben wäre eine Lösung da hast du Recht aber bei so vielen Werten auch sehr Zeitaufwändig.
2 Grund, ich lerne sehr gern neue Sachen im Excel und finde es super, wenn man so Sachen einfach lösen kann. Möchte gern mehr effektiv arbeiten.Smile

Oder meinst Du was anderes?
Antwortento top
#7
Hi Gabi,

in Steves Formel musst du die fettgedruckte Zahl in 4 abändern und in C4 deiner Beispieltabelle einfügen. Dann nach rechts und unten ziehen.


Zitat:=WENNFEHLER(INDEX($B$4:$B$9;AGGREGAT(15;6;ZEILE($B$4:$B$9)-3/($A$4:$A$9=$A17);SPALTE(A1)));"")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#8
Hallo Jockel,

Besten Dank ich glaube so klappts.Smile

Gruss
Antwortento top
#9
Nun ja es klappt bei 2 Nummern.

Ich habe versucht, die Formel auf die ganze Liste anzupassen aber irgendwie spinnt es.
Es hat eben auch einige die nur 1 Bild habe und Solche die bis 17 habe.

Ich habe hier mal die ganze Liste angehängt (Sortierung 1)

Könnten mir eventeull hier wer dabei helfen die Formel von oben auf das anzupassen?

Sorry nochamls für das viele Fragen und Bitten.

Gruss


Angehängte Dateien
.xlsx   Sortierung 1.xlsx (Größe: 213,73 KB / Downloads: 4)
Antwortento top
#10
Hola,

Was komplett fehlt ist die Liste der Nummern aus Spalte A, so wie Jockel es in A13 und A14 gezeigt hat. Wo ist die?


Aktuell würde es für die 6130 so aussehen:


Code:
=WENNFEHLER(INDEX($B$3:$B$7052;AGGREGAT(15;6;ZEILE($B$3:$B$7052)-2/($A$3:$A$7052=6130);SPALTE(A1)));"")


Wenn du Liste der Nummern erzeugt hast, kannst du die 6130 in der Formel durch die Zelle mit der ersten Nummer ersetzen.

Gruß,
Steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste