Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Hilfe bei Formeln
#1
Hallo Smile

Für eine Auswertung bräuchte ich bitte Hilfe. Hatte es schon selbst versucht mit den Funktionen LINKS() und RECHTS(), aber da es ein wenig eilig ist, frage ich nun hier.

Nutze Open Office, aber ist hier vermutlich egal.
In den gelb hinterlegten Bereich sollen die entsprechenden Formeln für die Werte die da jetzt so dort reingeschrieben wurden, es ist alles mit Kommentaren erklärt.

Vielen Dank!


Angehängte Dateien
.xls   8.xls (Größe: 11,5 KB / Downloads: 11)
to top
#2
Hallo, meinst Du so für I3..:

=WENN(ISTZAHL(SUCHEN("@";B3));--TEIL(C3;SUCHEN(" ";C3)+1;SUCHEN("-";C3)-SUCHEN(" ";C3)-1);"")

für K3

=GLÄTTEN(WENN(ISTZAHL(SUCHEN("@";B3));TEIL(B3;SUCHEN("@";B3)+1;99);""))


cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo, ja genau so ist es richtig für Spalte I und K. Danke!
Smile
to top
#4
(05.03.2015, 23:02)MDGGB schrieb: Hallo, ja genau so ist es richtig für Spalte I. Danke!
Smile

... und in K siehe editierten Beitrag...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
(05.03.2015, 23:04)Jockel schrieb:
(05.03.2015, 23:02)MDGGB schrieb: Hallo, ja genau so ist es richtig für Spalte I. Danke!
Smile

... und in K siehe editierten Beitrag...

Meinst du ich könnte diese Formeln umbauen für Spalten J und L, oder braucht es da ganz andere Formeln?
to top
#6
Hallo, für L3..:


=WENN(ISTZAHL(SUCHEN("@";B3));"";B3)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo

Meine Vorschläge.
Kunde, von oder @Werte@ Kunde WertZuhause Wert@ Kunde, OrtZuhause, Kunde von OrtDifferenzen Werte @Differenzen Werte Zuhause@ Kunde, Wert Kriterium 1@ Kunde, Differenzen Wert Kriterium 1
          
MünchenA 100-60 100 München    
@ BerlinB 60-10060 Berlin   2 
HamburgB 50-100 50 Hamburg -50  
BonnA 100-50 100 Bonn 50  
BielefeldA 100-40 100 Bielefeld 0  
@ DüsseldorfA 100-50100 Düsseldorf 40 119
@ ZürichB 60-10060 Zürich -40 2312
@ SalzburgB 50-10050 Salzburg -10 16-7

ZelleFormel
I3=WENN(LINKS(B3;1)="@";--TEIL(C3;3;SUCHEN("-";C3)-3);"")
J3=WENN(I3="";--TEIL(C3;3;SUCHEN("-";C3)-3);"")
K3=WENN(I3="";"";GLÄTTEN(TEIL(B3;3;99)))
L3=WENN(J3="";"";GLÄTTEN(B3))
M3=WENNFEHLER(I3-VERWEIS(9^99;I$2:I2);"")
N3=WENNFEHLER(J3-VERWEIS(9^99;J$2:J2);"")
O3=WENNFEHLER(SVERWEIS(K3;'Kriterium 1'!$A$3:$B$10;2;FALSCH);"")
P3=WENNFEHLER(O3-VERWEIS(9^99;O$2:O2);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#8
Hallo, für J3..:



=WENN(ISTZAHL(SUCHEN("@";B3));"";--TEIL(C3;SUCHEN(" ";C3)+1;VERWEIS(9^9;FINDEN("-";C3;ZEILE(A:A)))-SUCHEN(" ";C3)-1))
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#9
(05.03.2015, 23:22)shift-del schrieb: Hallo

Meine Vorschläge.

oder so... ;-)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
(05.03.2015, 23:22)shift-del schrieb: Hallo

Meine Vorschläge.
Kunde, von oder @Werte@ Kunde WertZuhause Wert@ Kunde, OrtZuhause, Kunde von OrtDifferenzen Werte @Differenzen Werte Zuhause@ Kunde, Wert Kriterium 1@ Kunde, Differenzen Wert Kriterium 1
          
MünchenA 100-60 100 München    
@ BerlinB 60-10060 Berlin   2 
HamburgB 50-100 50 Hamburg -50  
BonnA 100-50 100 Bonn 50  
BielefeldA 100-40 100 Bielefeld 0  
@ DüsseldorfA 100-50100 Düsseldorf 40 119
@ ZürichB 60-10060 Zürich -40 2312
@ SalzburgB 50-10050 Salzburg -10 16-7

ZelleFormel
I3=WENN(LINKS(B3;1)="@";--TEIL(C3;3;SUCHEN("-";C3)-3);"")
J3=WENN(I3="";--TEIL(C3;3;SUCHEN("-";C3)-3);"")
K3=WENN(I3="";"";GLÄTTEN(TEIL(B3;3;99)))
L3=WENN(J3="";"";GLÄTTEN(B3))
M3=WENNFEHLER(I3-VERWEIS(9^99;I$2:I2);"")
N3=WENNFEHLER(J3-VERWEIS(9^99;J$2:J2);"")
O3=WENNFEHLER(SVERWEIS(K3;'Kriterium 1'!$A$3:$B$10;2;FALSCH);"")
P3=WENNFEHLER(O3-VERWEIS(9^99;O$2:O2);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

(05.03.2015, 23:32)Jockel schrieb: Hallo, für J3..:



=WENN(ISTZAHL(SUCHEN("@";B3));"";--TEIL(C3;SUCHEN(" ";C3)+1;VERWEIS(9^9;FINDEN("-";C3;ZEILE(A:A)))-SUCHEN(" ";C3)-1))

Vielen Dank für die kompetente Hilfe Smile
Wenn ich anschließend noch eine weitere Frage dazu habe, schreibe ich die hier rein oder in einen neuen Thread?
Gruß
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste