Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Geburtstags-Aufgabe (wo ist mein Fehler?)
#1
Hallo,

ich habe eine Aufgabe, wo 1000 Geburtstage gegeben sind.
Nun soll berechnet werden wie viele von den Geburtstagen im aktuellem Jahr an einem Montag,Dienstag,...... Geburtstag haben.

Die Aufgabe habe ich soweit gelöst aber wenn ich zur Probe die Summe aller Geburtstage nochmal berechnen lassen will kommt 999 raus obwohl es ja 1000 Geburtage sind.
Ich finde meinen Fehler einfach nicht.

Ich hoffe ihr könnt mir helfen.
Die Aufgabe ist im Anhang.

Vielen Dank im Voraus.

MfG Felipo


Angehängte Dateien
.xlsx   Geburtstage.xlsx (Größe: 52,92 KB / Downloads: 18)
Antwortento top
#2
Hi

Es gibt keinen 29.02.2015. Schau mal in Zeile 801
Grüße,
Winny
[-] Folgende(r) 1 Benutzer sagt Danke an Winny für diesen Beitrag:
  • Felipo95
Antwortento top
#3
(09.05.2015, 12:21)Winny schrieb: Hi

Es gibt keinen 29.02.2015. Schau mal in Zeile 801

Ahhh, Danke.
Ist ja blöd, da einen 29.02. (Schaltjahr) mit einzubauen, wenn es den nur alle 4 Jahre gibt >.<
Antwortento top
#4
Hi Felipo,

den Fehler hast du ja jetzt gefunden.

Du könntest dir aber zwei Hilfsspalten sparen. Wäre das eine Option?

Tabelle1

BCDEF
2Jahr(alt)20152015Anzahl
305.02.2008DonnerstagMontag140
420.11.1967FreitagDienstag151
525.04.2011SamstagMittwoch160
614.11.2003SamstagDonnerstag142
701.12.1996DienstagFreitag134
814.11.1935SamstagSamstag131
909.12.2012MittwochSonntag141
1003.04.1977FreitagSumme999
1104.02.1979Mittwoch
Formeln der Tabelle
ZelleFormel
C3=WENN(ISTFEHLER(TEXT(B3;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B3)*1;TAG(B3)*1);"TTTT"))
E3=TAG(ZEILE(A2))
F3=ZÄHLENWENN($C$3:$C$1002;TEXT($E3;"TTTT"))
C4=WENN(ISTFEHLER(TEXT(B4;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B4)*1;TAG(B4)*1);"TTTT"))
E4=TAG(ZEILE(A3))
F4=ZÄHLENWENN($C$3:$C$1002;TEXT($E4;"TTTT"))
C5=WENN(ISTFEHLER(TEXT(B5;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B5)*1;TAG(B5)*1);"TTTT"))
E5=TAG(ZEILE(A4))
F5=ZÄHLENWENN($C$3:$C$1002;TEXT($E5;"TTTT"))
C6=WENN(ISTFEHLER(TEXT(B6;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B6)*1;TAG(B6)*1);"TTTT"))
E6=TAG(ZEILE(A5))
F6=ZÄHLENWENN($C$3:$C$1002;TEXT($E6;"TTTT"))
C7=WENN(ISTFEHLER(TEXT(B7;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B7)*1;TAG(B7)*1);"TTTT"))
E7=TAG(ZEILE(A6))
F7=ZÄHLENWENN($C$3:$C$1002;TEXT($E7;"TTTT"))
C8=WENN(ISTFEHLER(TEXT(B8;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B8)*1;TAG(B8)*1);"TTTT"))
E8=TAG(ZEILE(A7))
F8=ZÄHLENWENN($C$3:$C$1002;TEXT($E8;"TTTT"))
C9=WENN(ISTFEHLER(TEXT(B9;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B9)*1;TAG(B9)*1);"TTTT"))
E9=TAG(ZEILE(A8))
F9=ZÄHLENWENN($C$3:$C$1002;TEXT($E9;"TTTT"))
C10=WENN(ISTFEHLER(TEXT(B10;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B10)*1;TAG(B10)*1);"TTTT"))
F10=SUMME(F3:F9)
C11=WENN(ISTFEHLER(TEXT(B11;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B11)*1;TAG(B11)*1);"TTTT"))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hallöchen,

weil bei Günter immer noch 999 rauskommt, hier mein Ansatz - mal nur in Zeile 801. Gehört natürlich in die komplette Spalte.

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDE
80129.02.2012Mittwoch01.03.2015Sonntag

ZelleFormel
C801=TEXT(B801;"TTTT")
D801=WENNFEHLER(TEXT(B801;"TT.MM")*1;TEXT(B801+1;"TT.MM")*1)
E801=TEXT(D801;"TTTT")
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
Hi André,

es muss 999 herauskommen.

Das war die Aufgabe:

Zitat:Nun soll berechnet werden wie viele von den Geburtstagen im aktuellem Jahr an einem Montag,Dienstag,...... Geburtstag haben.
Am angegebenen Tag kann niemand geboren sein!

Anbieten würde sich eventuell die Mitteilung, dass Fehler vorliegen. Entsprechend muss nur die Formel in Spalte C abgeändert werden:

Code:
=WENN(ISTFEHLER(TEXT(B801;"TT.MM")*1);"Fehler";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B801)*1;TAG(B801)*1);"TTTT")) anstatt:
=WENN(ISTFEHLER(TEXT(B801;"TT.MM")*1);"";TEXT(DATUM(JAHR(HEUTE()*1);MONAT(B801)*1;TAG(B801)*1);"TTTT"))

Und die Ausgabe der Fehleranzahl:

Tabelle1

EF
9Sonntag141
10Summe999
11Fehler:1
Formeln der Tabelle
ZelleFormel
E9=TAG(ZEILE(A8))
F9=ZÄHLENWENN($C$3:$C$1002;TEXT($E9;"TTTT"))
F10=SUMME(F3:F9)
F11=ZÄHLENWENN(C3:C1500;"Fehler")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Nach deinem Vorschlag hat der Kandidat statt am 29.2.15, was falsch ist, da 2015 kein Schaltjahr ist und entsprechend an diesem Tag niemand geboren sein kann, einfach einen Tag später Geburtstag. Und das muss nicht zwingend richtig sein. Vielleicht war es ja nur ein Tippfehler und sollte 28.2. heißen? Da sollte lieber auf den Fehler aufmerksam gemacht werden. ;)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#7
Hallo Günter,

nach Deiner Auffassung haben die am 29.02. geborenen also 2015 keinen Geburtstag? Die werden da aber nicht begeistert sein ... 22
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
(09.05.2015, 19:35)schauan schrieb: Hallo Günter,

nach Deiner Auffassung haben die am 29.02. geborenen also 2015 keinen Geburtstag? Die werden da aber nicht begeistert sein ...  22


Hi André,

da hast du leider etwas falsch verstanden. :(
Die Spalte B sind die Geburtsdaten!! Hier wurde als Tag der Geburt der 29.2.2015 - also in diesem Jahr am 29.2. - eingetragen, was wohl nachweislich falsch ist ;). Die Spalte C wirft den Tag aus, an dem das Geburtstagskind im heutigen Jahr (also 2015) aus Spalte B feiern darf.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#9
Hallo,

das könnte man ohne jegliche Hilfsspalte lösen:

Tabelle1

BCDE
2Jahr(alt)2015Anzahl
305.02.2008Montag 140
420.11.1967Dienstag151
525.04.2011Mittwoch160
614.11.2003Donnerstag142
701.12.1996Freitag134
814.11.1935Samstag132
909.12.2012Sonntag141
1003.04.1977Summe1000
Formeln der Tabelle
ZelleFormel
E3{=SUMME((WENNFEHLER(REST(TEXT($B$3:$B$1002;"TT.MM")*1;7);REST(TEXT($B$3:$B$1002-1;"TT.MM")*1;7))=REST(ZEILE(A2);7))*1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Für die, deren Geburtstag auf den 29.2. fällt, habe ich in der Formel den 28.02 eingesetzt, wenn es keinen 29.02. gibt. Duch Ändern der -1 auf +1 wird der 1.3 als Ersatzdatum gewählt.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#10
Hallo Günter,

ich sehe dort den 29.02.2012.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste