Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Fußballtabelle automatisch generieren
#1
Grüßt euch,
In Tabelle-A liegt eine alphabetische Vereinsliste mit den jeweils erzielten Punkten und der Tordifferenz vor.
Hieraus soll ohne zu sortieren automatisch die Tabelle generiert werden.
In der Webpage "Excel Formeln" [ http://www.excelformeln.de/formeln.html?welcher=283 ] liegen die Formeln für die automatische Generierung vor.
Diese Formeln funktionieren aber bei mir nicht.
Wo liegt der Fehler?
Tabelle1

ABCDEFGH
2Tabelle ATabelle B
3VereinPunkteTordifferenzPlatzVereinPunkteTordifferenz
4Mannheim18-31#ZAHL!#ZAHL!#ZAHL!
5Offenbach213#ZAHL!#ZAHL!#ZAHL!#ZAHL!
6Frankfurt14-6#ZAHL!#ZAHL!#ZAHL!#ZAHL!
7München215#ZAHL!#ZAHL!#ZAHL!#ZAHL!
8Hamburg2512#ZAHL!#ZAHL!#ZAHL!#ZAHL!
9Stuttgart215#ZAHL!#ZAHL!#ZAHL!#ZAHL!
10Hannover16-8#ZAHL!#ZAHL!#ZAHL!#ZAHL!
11Braunschweig238#ZAHL!#ZAHL!#ZAHL!#ZAHL!
12Darmstadt18-2#ZAHL!#ZAHL!#ZAHL!#ZAHL!
13Freiburg216#ZAHL!#ZAHL!#ZAHL!#ZAHL!
Formeln der Tabelle
ZelleFormel
F4=INDEX(A:A;VERGLEICH(G4;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G4=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H4=INDEX(C:C;VERGLEICH(F4;A:A;0))
E5=WENN(RUNDEN(G5;5)=RUNDEN(G4;5);"";ZEILE()-1)
F5=INDEX(A:A;VERGLEICH(G5;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G5=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H5=INDEX(C:C;VERGLEICH(F5;A:A;0))
E6=WENN(RUNDEN(G6;5)=RUNDEN(G5;5);"";ZEILE()-1)
F6=INDEX(A:A;VERGLEICH(G6;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G6=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H6=INDEX(C:C;VERGLEICH(F6;A:A;0))
E7=WENN(RUNDEN(G7;5)=RUNDEN(G6;5);"";ZEILE()-1)
F7=INDEX(A:A;VERGLEICH(G7;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G7=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H7=INDEX(C:C;VERGLEICH(F7;A:A;0))
E8=WENN(RUNDEN(G8;5)=RUNDEN(G7;5);"";ZEILE()-1)
F8=INDEX(A:A;VERGLEICH(G8;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G8=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H8=INDEX(C:C;VERGLEICH(F8;A:A;0))
E9=WENN(RUNDEN(G9;5)=RUNDEN(G8;5);"";ZEILE()-1)
F9=INDEX(A:A;VERGLEICH(G9;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G9=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H9=INDEX(C:C;VERGLEICH(F9;A:A;0))
E10=WENN(RUNDEN(G10;5)=RUNDEN(G9;5);"";ZEILE()-1)
F10=INDEX(A:A;VERGLEICH(G10;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G10=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H10=INDEX(C:C;VERGLEICH(F10;A:A;0))
E11=WENN(RUNDEN(G11;5)=RUNDEN(G10;5);"";ZEILE()-1)
F11=INDEX(A:A;VERGLEICH(G11;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G11=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H11=INDEX(C:C;VERGLEICH(F11;A:A;0))
E12=WENN(RUNDEN(G12;5)=RUNDEN(G11;5);"";ZEILE()-1)
F12=INDEX(A:A;VERGLEICH(G12;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G12=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H12=INDEX(C:C;VERGLEICH(F12;A:A;0))
E13=WENN(RUNDEN(G13;5)=RUNDEN(G12;5);"";ZEILE()-1)
F13=INDEX(A:A;VERGLEICH(G13;B$3:B$102+(C$3:C$102)/1000-ZEILE($3:$102)/10000000;0))
G13=KGRÖSSTE(WENN($A$4:$A$102<>"";(B$4:B$102+C$4:C$102/1000-ZEILE($4:$102)/10000000));ZEILE()-1)
H13=INDEX(C:C;VERGLEICH(F13;A:A;0))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
[Ich schreibe mit Excel 2007]

Lieben Gruß und Danke
Stefan
Antwortento top
#2
Hi Stefan,

hast du beachtet, dass es sich zum Teil um Matrixformeln handelt, die mit STRG-SHIFT-ENTER abgeschlossen werden müssen?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Stefan Link
Antwortento top
#3
Hallo Stefan

http://www.excelformeln.de/formeln.html
Zitat:Ein Großteil sind Array-Formeln {Matrixformeln}; - zu erkennen an den geschweiften Klammern vor dem Gleichheitszeichen und am Ende {=FORMEL}. Diese {Klammern} werden nicht eingegeben sondern zum Abschluß der Formel durch gleichzeitig Strg Shift Enter erzeugt (statt Enter allein). Wenn Du hier einen Array kopierst, diese Klammern also löschen, und die Formel wie beschrieben abschließen.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Stefan Link
Antwortento top
#4
Jetzt funkt es. Bei Stuttgart fehlt eine Nummer, weil zwischen Stuttgart und München Punkt- und Torgleichheit vorliegt. Dann müssten noch mehr Unterscheidungskriterien eingeführt werden, wie die zitierte Exelwebseite weiter ausführt.
Tabelle1

ABCDEFGH
1VereinPunkteTordifferenzPlatzVereinPunkteTordifferenz
2Mannheim18-31Hamburg2512
3Offenbach2132Braunschweig238
4Frankfurt14-63Freiburg216
5München2154München215
6Hamburg2512Stuttgart215
7Stuttgart2156Offenbach213
8Hannover16-87Darmstadt18-2
9Braunschweig2388Mannheim18-3
10Darmstadt18-29Hannover16-8
11Freiburg21610Frankfurt14-6
Formeln der Tabelle
ZelleFormel
F2{=INDEX(A:A;VERGLEICH(G2;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G2{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H2=INDEX(C:C;VERGLEICH(F2;A:A;0))
E3=WENN(RUNDEN(G3;5)=RUNDEN(G2;5);"";ZEILE()-1)
F3{=INDEX(A:A;VERGLEICH(G3;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G3{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H3=INDEX(C:C;VERGLEICH(F3;A:A;0))
E4=WENN(RUNDEN(G4;5)=RUNDEN(G3;5);"";ZEILE()-1)
F4{=INDEX(A:A;VERGLEICH(G4;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G4{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H4=INDEX(C:C;VERGLEICH(F4;A:A;0))
E5=WENN(RUNDEN(G5;5)=RUNDEN(G4;5);"";ZEILE()-1)
F5{=INDEX(A:A;VERGLEICH(G5;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G5{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H5=INDEX(C:C;VERGLEICH(F5;A:A;0))
E6=WENN(RUNDEN(G6;5)=RUNDEN(G5;5);"";ZEILE()-1)
F6{=INDEX(A:A;VERGLEICH(G6;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G6{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H6=INDEX(C:C;VERGLEICH(F6;A:A;0))
E7=WENN(RUNDEN(G7;5)=RUNDEN(G6;5);"";ZEILE()-1)
F7{=INDEX(A:A;VERGLEICH(G7;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G7{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H7=INDEX(C:C;VERGLEICH(F7;A:A;0))
E8=WENN(RUNDEN(G8;5)=RUNDEN(G7;5);"";ZEILE()-1)
F8{=INDEX(A:A;VERGLEICH(G8;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G8{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H8=INDEX(C:C;VERGLEICH(F8;A:A;0))
E9=WENN(RUNDEN(G9;5)=RUNDEN(G8;5);"";ZEILE()-1)
F9{=INDEX(A:A;VERGLEICH(G9;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G9{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H9=INDEX(C:C;VERGLEICH(F9;A:A;0))
E10=WENN(RUNDEN(G10;5)=RUNDEN(G9;5);"";ZEILE()-1)
F10{=INDEX(A:A;VERGLEICH(G10;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G10{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H10=INDEX(C:C;VERGLEICH(F10;A:A;0))
E11=WENN(RUNDEN(G11;5)=RUNDEN(G10;5);"";ZEILE()-1)
F11{=INDEX(A:A;VERGLEICH(G11;B$1:B$101+(C$1:C$101)/1000-ZEILE($1:$101)/10000000;0))}
G11{=KGRÖSSTE(WENN($A$2:$A$101<>"";(B$2:B$101+C$2:C$101/1000-ZEILE($2:$101)/10000000));ZEILE()-1)}
H11=INDEX(C:C;VERGLEICH(F11;A:A;0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
[Ich schreibe mit Excel 2007]

Lieben Gruß und Danke
Stefan
Antwortento top
#5
Hi Stefan,

das hilft Dir nicht, aber:
(28.05.2016, 08:44)Stefan Link schrieb: Bei Stuttgart fehlt eine Nummer, weil zwischen Stuttgart und München Punkt- und Torgleichheit vorliegt.

das ist aber schon lange her! 19 22
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste