Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Funktionsuche!
#1
Photo 
Hallo liebe Forum-User!

Ich suche nach einer Funktion:

B C
1.eins 1,0 1,3
2.zwei 1,5 1,7
3.eins 2,0

Summe= ?

Die Summe soll die Werte von B und C von unten nach oben zusammenzählen und zwar so, dass:

- die nur Werte zählen soll, bei denen die in der Zeile "eins" steht
- die soll den Wert aus der Spalte "C" nehmen, wenn die zeile NICHT leer ist
- die soll den Wert aus der Spalte B nehmen, falls die Spalte C leer ist. Wenn in beiden Spalten ein Wert ist, soll den Wert aus C nehmen.

Könnte mir jemand bitte helfen? Vielen Dank
Antwortento top
#2
Ohje, die Formatierung hat die Leerzeilen entfernt und daher die Werte B und C verschoben. Stellt euch vor, dass die Werte 1,0; 1,5 und 2,0 in der Spalte B stehen und 1,3 und 1,7 in der Spalte C.
Antwortento top
#3
Das Bild ist im Anhang.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Hallo,

deine Fragestellung ist leider ungenau und wirft ein paar neue Fragen auf.

Zitat:Die Summe soll die Werte von B und C von unten nach oben zusammenzählen

- Soll hier die Summe gebildet werden aus beiden Spalten zusammen oder getrennt nach B und C?
- Was meinst du mit deiner Vorgabe "von unten nach oben zusammenzählen"? Bei einer Summenbildung ist es doch Jacke wie Hose, ob ich von oben nach unten oder von unten nach oben oder aus der Mitte heraus nach oben und unten addiere. 

Zitat:die soll den Wert aus der Spalte "C" nehmen, wenn die zeile NICHT leer ist

- Wenn eine Zeile leer ist, ist der numerische Wert einer Zelle in dieser Zeile = 0. Was hat dann deine Vorgabe für eine Bewandtnis?


Zitat:die soll den Wert aus der Spalte B nehmen, falls die Spalte C leer ist. Wenn in beiden Spalten ein Wert ist, soll den Wert aus C nehmen.

- Auch hier die Frage nach der Bewandtnis deiner Vorgabe: wenn eine Spalte leer ist, kann per se daraus kein Wert entnommen werden. Was also willst du genau erreichen?

Bitte formuliere dein Problem so, dass es auch "Nichteingeweihte" verstehen können. Dann bekommst du auch umfassend Hilfe. Mit deinen bisherigen Angaben geht das mMn nicht.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hallo

Zitat:Summe= ?
Du kennst das Ergebnis nicht?

Der einfachste Weg ist eine Hilfsspalte.
 ABCDE
1 BC  
21. eins11,3 1,3
32. zwei1,51,7 0
43. eins2  2
5    3,3

ZelleFormel
E2=VERWEIS(9^9;B2:C2)*ZÄHLENWENN(A2;"*eins*")
E3=VERWEIS(9^9;B3:C3)*ZÄHLENWENN(A3;"*eins*")
E4=VERWEIS(9^9;B4:C4)*ZÄHLENWENN(A4;"*eins*")
E5=SUMME(E2:E4)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#6
Hallo,

oder so:

Tabelle1

ABCD
1 BC
2eins11,33,3
3zwei1,51,7
4eins2
Formeln der Tabelle
ZelleFormel
D2=SUMMEWENN(A2:A4;"eins";C2:C4)+SUMMEWENNS(B2:B4;A2:A4;"eins";C2:C4;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Danke euch allen! Ihr seid die Besten!!!!! Danke!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste