Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Funktion "Vergleich"
#1
Hallo zusammen,

ich habe eigentlich eine recht simple Frage. Gehen wir davon aus, dass wir in einer Zeile fünf Einträge (in diesem Fall Strings) haben:

"Apfel" | "Apfel" | "Birne" | "Mango" | "Apfel"

Ich weiß, dass man mit der Funktion {=VERGLEICH("Apfel";Array;0)} die Zahl 1 bekommt, da die Funktion stets die erste Übereinstimmung nimmt. Kann man die Funktion dahingehend austricksen, dass sie auch den fünften Eintrag findet, also die Zahl 5 wieder gibt, ohne die Einträge selber zu ändern?

Vielen Dank für die Beantwortung und einen schönen Tag noch.
to top
#2
Hallo, zuerstmal sieht es so aus, als ob Du Deine Formel als MatrixFormel abschließt, das muss nicht... Zum Anderen: Willst Du die Stelle beider Einträge oder nur des letzten oder alle..?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Okay, die geschweiften Klammern waren nicht klug platziert. Schließe die Funktion normal ab.

Mein eigentliches Ziel ist es abzufragen, ob in der Zeile bspw. das Wort "Mango" und das Wort "Apfel" nebeneinander stehen. Dies wollt ich mit der der VERGLEICH-Funktion in Kombination mit einer WENN-Abfrage erreichen.

Hoffe, es wurde jetzt klarer.
to top
#4
Hallo

Prüft ob zuerst Mango und dann Apfel kommt:
Code:
=SUMMENPRODUKT((A1:D1="Mango")*(B1:E1="Apfel"))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • BigF1Foot
to top
#5
Sehr cool. Bei meinen ersten, eigenen Beispielen klappt das wunderbar. Vielen Dank! 28
to top
#6
Hallo,

ginge auch mit Vergleich:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1ApfelApfelBirneMangoApfel
24WAHR   

ZelleFormel
A2{=VERGLEICH("Mango"&"Apfel";$A$1:$D$1&$B$1:$E$1;0)}
B2{=ISTZAHL(VERGLEICH("Mango"&"Apfel";$A$1:$D$1&$B$1:$E$1;0))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • BigF1Foot
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste