Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


Frage zu INDEX mit Matrix für Schichtkalender
#1
Hallo liebe Excel Profis!

Ich hätte eine Frage zur INDX-Funktion mit Matrix:
Ich benutze folgende Formel um eine Schichtfolge nach Datum zu realisieren:

=WENNFEHLER(INDEX({"3";"2";"X";"X";"1";"2“};REST(A1;6)+1;1);"")

In A1 ist das Datum hinterlegt, und die Matrix stellt die Schichtfolge dar (die originale Formel ist deutlich länger und umfasst 49 Schichtelemente. Damit diese hier übersichtlich bleibt, habe ich sie auf 6 Einträge gekürzt). In der Zelle wird dann die zum Datum passende Schicht angezeigt. WENNFEHLER um Fehler unsichtbar zu machen.

Nun meine Frage: Kann man die Matrix, also die Schichtfolge, auch aus Zellen „auslesen“? Die Matrix quasi aus vorhandenen Daten erstellen?
Sprich wenn sich die Schichtfolge ändert, diese nur 1x im Daten-Arbeitsblatt eintragen ohne sämtliche Formeln ändern zu müssen?

Arbeitsblatt „Daten“ (Schichtfolge):
A  B  C  D  E  F
3  2  X  X  1  2
ändern in          
A  B  C  D  E  F
2  2  3  3  X   X
Die Formel sollte dann sinngemäß etwa so aussehen:

=WENNFEHLER(INDEX({"Daten!A1";"Daten!A2";"Daten!A3";"Daten!A4";"Daten!A5";"Daten!A6“};REST(A1;6+1;1);"")

Das Ergebnis sollte dann so aussehen:
Arbeitsblatt Schichtkalender
vorher:
A      B      C      D      E       F                    
1.1.  2.1.   3.1.  4.1.   5.1.   6.1.                
3      2      X      X       1      2                    

nachher:
A      B      C      D      E       F
1.1.   2.1.   3.1.  4.1.   5.1.   6.1.
2       2      3      3       X      X
(Sorry für das missglückte Layout, das Datum bitte unter den Spalten vorstellen....)

Mein erster naiver Versuch bestand darin wie oben, einfach die Zellen als Matrix anzugeben. Das funktioniert aber leider nicht, es werden keine Daten angezeigt.

Ich hoffe ich konnte mein Problem einigermaßen verständlich machen und ihr könnt mich in die richtige Richtung schupsen, mir sagen was ich falsch mache oder mir zeigen wie die Formel richtig lauten müsste!

Grüße
gutsilli

PS: Hab mal ein Beispiel angehängt


Angehängte Dateien
.xlsx   SchichtTest_1.xlsx (Größe: 51,68 KB / Downloads: 1)
Antwortento top
#2
Datei nicht geöffnet.
  
=WENNFEHLER(INDEX({"3";"2";"X";"X";"1";"2“};REST(A1;6)+1;1);"") geht kürzer wie folgt:

=WENNFEHLER(TEIL("32XX12";REST(A1;6)+1;1);"") vor allem bei 49 statt 6 "Lottozahlen" (nur 1 statt 4 Zeichen). Außerdem packst Du die Schichtperiode in 1 statt 49 Zellen!

Zu Deiner Auswahl von Schichtfolgen dann so:
=WENNFEHLER(TEIL(SVERWEIS(Auswahl;Suchbereich;2;);REST(A1;6)+1;1);"")

mit
Auswahl: "normal", "Feiertage", "Personalmangel" usw.

Suchbereich:
normal         32XX12
Feiertage      2XX123
Personalmangel 231X13
[-] Folgende(r) 1 Benutzer sagt Danke an lupo1 für diesen Beitrag:
  • gutsilli
Antwortento top
#3
(26.07.2017, 17:47)lupo1 schrieb: ...Außerdem packst Du die Schichtperiode in 1 statt 49 Zellen!....

Besten Dank!
Wird sofort umgesetzt!!

Schönen Abend!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste