Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Formel zum Verschieben von Zellen
#1
Guten Morgen liebe alle,

ich hoffe sehr, dass mir hier jemand helfen kann. Mein Problem ist folgendes:

Ich habe eine Tabelle mit verkauften Produkten pro Postleitzahl (für verschiedene Produkte). Zu jedem Produkt tauchen nur die PLZ auf, an die das Produkt verkauft wurde. Nun habe ich eine Spalte mit allen PLZ und möchte die einzelnen verkauften Produkte dieser Spalte zuordnen.
Also statt
"PLZ / verkaufte Äpfel in diesem Gebiet" und "PLZ / verkaufte Birnen in diesem Gebiet"
möchte ich "PLZ / verkaufte Äpfel in diesem Gebiet / verkaufte Birnen in diesem Gebiets".

Ich habe bereits angefangen, per Hand zu sortieren, d.h. in den Spalten zu den einzelnen Produkten dort leere Zeilen einzufügen, wo PLZ stehen, zu denen keine Produkte verkauft wurden. Aber das ist eben sehr viel Aufwand. Deswegen würde ich mich freuen, falls mir jemand mit einer schlauen Formel dabei helfen kann! Smile

1000 Dank und viele Grüße!
to top
#2
Hallo,

kannst du mal eine Beispielsdatei hochladen und das Ganze anhand dieser Beispielsdatei erläutern - das würde das Verständnis für die Problemstellung vermutlich erleichtern.

http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß
Peter
to top
#3
Hallo Kaja,

ich würde hier eine Pivot-Tabelle vorschlagen.

Lies dich mal - falls du das noch nicht kennst - in die Hilfe ein und probiere es mal aus.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#4
Danke für den Hinweis,

ich habe eine beispielhafte Tabelle in vereinfachter Version angehängt.

Mein Ziel ist es, dass die Zellen E3 und F3 durch eine Formel verschoben werden nach C6 und D6.
Zelle E4 und F4 dann entsprechend nach C42 und D42.

Ich hoffe, dass ist einigermaßen verständlich. Huh


Angehängte Dateien
.xlsx   Beispieltabelle.xlsx (Größe: 120,05 KB / Downloads: 6)
to top
#5
(23.10.2014, 09:47)WillWissen schrieb: Hallo Kaja,

ich würde hier eine Pivot-Tabelle vorschlagen.

Lies dich mal - falls du das noch nicht kennst - in die Hilfe ein und probiere es mal aus.

Erstmal danke! Ich habe mich ein wenig eingelesen, allerdings scheint es mir so, als wenn ich mit der Pivot-Tabelle eher einen kleinen Ausschnitt darstellen könnte. Und ich möchte ja gerade das "große Ganze" abbilden. Ist das nicht eher das Gegenteil einer Pivot-Tabelle?
to top
#6
Hi Kaja,

ich hatte wohl deine Frage missverstanden. Meinst du das jetzt anhand deiner Mustertabelle so?

Sheet1

ABCDEFGHI
1Produkt AProdukt B
2PLZBundeslandProd.  AProd BPLZAnzahlPLZAnzahl
301067Sachsen0109950115611
401069Sachsen015872012797
501097Sachsen019988042773
601099Sachsen5
701108Sachsen
801109Sachsen
901127Sachsen
1001129Sachsen
1101139Sachsen
1201156Sachsen11
1301157Sachsen
1401159Sachsen
1501169Sachsen
1601187Sachsen
1701189Sachsen
1801217Sachsen
1901219Sachsen
2001237Sachsen
2101239Sachsen
2201257Sachsen
2301259Sachsen
2401277Sachsen
2501279Sachsen7
Formeln der Tabelle
ZelleFormel
C3=WENNFEHLER(SVERWEIS(A3;$E$3:FA$10000;2;0);"")
D3=WENNFEHLER(SVERWEIS(A3;$H$3:I$10000;2;0);"")
C4=WENNFEHLER(SVERWEIS(A4;$E$3:FA$10000;2;0);"")
D4=WENNFEHLER(SVERWEIS(A4;$H$3:I$10000;2;0);"")
C5=WENNFEHLER(SVERWEIS(A5;$E$3:FA$10000;2;0);"")
D5=WENNFEHLER(SVERWEIS(A5;$H$3:I$10000;2;0);"")
C6=WENNFEHLER(SVERWEIS(A6;$E$3:FA$10000;2;0);"")
D6=WENNFEHLER(SVERWEIS(A6;$H$3:I$10000;2;0);"")
C7=WENNFEHLER(SVERWEIS(A7;$E$3:FA$10000;2;0);"")
D7=WENNFEHLER(SVERWEIS(A7;$H$3:I$10000;2;0);"")
C8=WENNFEHLER(SVERWEIS(A8;$E$3:FA$10000;2;0);"")
D8=WENNFEHLER(SVERWEIS(A8;$H$3:I$10000;2;0);"")
C9=WENNFEHLER(SVERWEIS(A9;$E$3:FA$10000;2;0);"")
D9=WENNFEHLER(SVERWEIS(A9;$H$3:I$10000;2;0);"")
C10=WENNFEHLER(SVERWEIS(A10;$E$3:FA$10000;2;0);"")
D10=WENNFEHLER(SVERWEIS(A10;$H$3:I$10000;2;0);"")
C11=WENNFEHLER(SVERWEIS(A11;$E$3:FA$10000;2;0);"")
D11=WENNFEHLER(SVERWEIS(A11;$H$3:I$10000;2;0);"")
C12=WENNFEHLER(SVERWEIS(A12;$E$3:FA$10000;2;0);"")
D12=WENNFEHLER(SVERWEIS(A12;$H$3:I$10000;2;0);"")
C13=WENNFEHLER(SVERWEIS(A13;$E$3:FA$10000;2;0);"")
D13=WENNFEHLER(SVERWEIS(A13;$H$3:I$10000;2;0);"")
C14=WENNFEHLER(SVERWEIS(A14;$E$3:FA$10000;2;0);"")
D14=WENNFEHLER(SVERWEIS(A14;$H$3:I$10000;2;0);"")
C15=WENNFEHLER(SVERWEIS(A15;$E$3:FA$10000;2;0);"")
D15=WENNFEHLER(SVERWEIS(A15;$H$3:I$10000;2;0);"")
C16=WENNFEHLER(SVERWEIS(A16;$E$3:FA$10000;2;0);"")
D16=WENNFEHLER(SVERWEIS(A16;$H$3:I$10000;2;0);"")
C17=WENNFEHLER(SVERWEIS(A17;$E$3:FA$10000;2;0);"")
D17=WENNFEHLER(SVERWEIS(A17;$H$3:I$10000;2;0);"")
C18=WENNFEHLER(SVERWEIS(A18;$E$3:FA$10000;2;0);"")
D18=WENNFEHLER(SVERWEIS(A18;$H$3:I$10000;2;0);"")
C19=WENNFEHLER(SVERWEIS(A19;$E$3:FA$10000;2;0);"")
D19=WENNFEHLER(SVERWEIS(A19;$H$3:I$10000;2;0);"")
C20=WENNFEHLER(SVERWEIS(A20;$E$3:FA$10000;2;0);"")
D20=WENNFEHLER(SVERWEIS(A20;$H$3:I$10000;2;0);"")
C21=WENNFEHLER(SVERWEIS(A21;$E$3:FA$10000;2;0);"")
D21=WENNFEHLER(SVERWEIS(A21;$H$3:I$10000;2;0);"")
C22=WENNFEHLER(SVERWEIS(A22;$E$3:FA$10000;2;0);"")
D22=WENNFEHLER(SVERWEIS(A22;$H$3:I$10000;2;0);"")
C23=WENNFEHLER(SVERWEIS(A23;$E$3:FA$10000;2;0);"")
D23=WENNFEHLER(SVERWEIS(A23;$H$3:I$10000;2;0);"")
C24=WENNFEHLER(SVERWEIS(A24;$E$3:FA$10000;2;0);"")
D24=WENNFEHLER(SVERWEIS(A24;$H$3:I$10000;2;0);"")
C25=WENNFEHLER(SVERWEIS(A25;$E$3:FA$10000;2;0);"")
D25=WENNFEHLER(SVERWEIS(A25;$H$3:I$10000;2;0);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#7
Lieber Günther,

genau so meine ich es!
1000 Dank dafür - das rettet meinen Tag (vermutlich das ganze Wochenende)!


Viele liebe Grüße!
to top
#8
hi Günther, wieso geht es bei der ersten Formel bis FA..?

gelöscht...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#9
Hi Jörg,

hast mit beidem natürlich recht. Bei ersterem ist wohl ein der Finger an der Tastatur hängen geblieben. Und bei zweitem? Ich arbeite mit dem Verweis nicht gerne, da aufsteigend sortiert sein muss. Und wenn das mal unterblieben ist...?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#10
Hallo Günther, nach nochmaliger Ansicht bin ich da ganz nah bei dir... 100
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste