Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Formel zum Addieren einer unregelmäßigen Zahlenreihe mit variablem Anfang und Ende
#1
Hallo,

ich hoffe, dass der Titel nicht allzu sehr verwirrt, aber es beschreibt in etwa das Problem, vor dem ich gerade stehe.

Aus einer unregelmäßig aufsteigenden Zahlenreihe soll eine Summe gebildet werden, jedoch soll der erste und der letzte Summand variabel bleiben.
Im Anhang habe ich ein Beispiel erstellt, in der ersten Zeile sollen etwa die Gesamtkosten von Tag 3 bis 5 auf Basis der unteren Matrix berechnet werden.

Probiert habe ich es anfangs mit einer Kombination aus allen möglichen Summenfunktionen und Sverweisen, leider bisher ohne Erfolg.
Ich hoffe, jemand hat eine Idee, wie ich es realisieren kann.

Grüße,

wurschtmieze



.xls   summen_sverweis.xls (Größe: 7,5 KB / Downloads: 3)
to top
#2
Hallo,

meinst Du so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 CDE
4Erster Summand/TagLetzter Summand/TagGesamtkosten
535950
6288600
77915000
811027200

ZelleFormel
E5=SUMME(INDEX($D$12:$D$21;VERGLEICH(C5;$C$12:$C$21;0)):INDEX($D$12:$D$21;VERGLEICH(D5;$C$12:$C$21;0)))
E6=SUMME(INDEX($D$12:$D$21;VERGLEICH(C6;$C$12:$C$21;0)):INDEX($D$12:$D$21;VERGLEICH(D6;$C$12:$C$21;0)))
E7=SUMME(INDEX($D$12:$D$21;VERGLEICH(C7;$C$12:$C$21;0)):INDEX($D$12:$D$21;VERGLEICH(D7;$C$12:$C$21;0)))
E8=SUMME(INDEX($D$12:$D$21;VERGLEICH(C8;$C$12:$C$21;0)):INDEX($D$12:$D$21;VERGLEICH(D8;$C$12:$C$21;0)))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
  • wurschtmieze
to top
#3
Klasse, vielen Dank, genau das hab ich gesucht.
Für einen Laien wie mich ist das noch eine Stufe zu hoch, aber jetzt hab ich wieder was dazu gelernt Wink
to top
#4
(09.02.2016, 22:34)wurschtmieze schrieb: Klasse, vielen Dank, genau das hab ich gesucht...

Hallo, wobei hier ff. reicht..: =SUMME(INDEX($D$12:$D$21;C5):INDEX($D$12:$D$21;D5))
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi,

in E5 diese Formel:


Zitat:=SUMME(INDEX($D$12:$D$21;VERGLEICH($C5;$C$12:$C$21;)):INDEX($D$12:$D$21;VERGLEICH($D5;$C$12:$C$21;)))

und runterziehen.

Edit:

Ich hatte nicht aktualisiert und dadurch übersehen, dass Atilla bereits viel früher exakt meinen Vorschlag als Ergebns hatte.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#6
(09.02.2016, 22:54)WillWissen schrieb: Edit:

Ich hatte nicht aktualisiert und dadurch übersehen, dass Atilla bereits viel früher exakt meinen Vorschlag als Ergebns hatte.

hi Günter, nicht exakt... ... und es geht kürzer...!!!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste