Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel wegen Zeitdaten ändern
#1
Hallo zusammen
Ich habe für die Berechnung der Nachtzeiten untenstehende Formel und die funktioniert bestens. Nun sollten aber die Zeiten nicht mehr in Standardzahlen (z.B. 8.75) sondern in Zeitdaten (08:45) in der Tabelle erfasst werden. Weiss jemand, wie ich diese Formel ändern muss, damit die weiterhin funktioniert? Diese Formel sollte die Zahlen weiterhin Dezmialzahlen (8.75) ausgeben, nur die Datenquelle ist neu in Zeitform.

WENN(WOCHENTAG(A9)=1;0;(MAX(;1-MAX(C9;$B$44)+MAX(;$C$44-C9)+MIN(D9;$C$44)+(D9>$B$44)*(D9-$B$44)-(C9D9)-C9))*(C9<>D9)*($B$44<>$C$44)))

Hoffe da hat jemand einen super Tipp Smile
Antwortento top
#2
Hallo,


Code:
=WENN(WOCHENTAG(A9)=1;0;(MAX(;1-MAX(C9;$B$44)+MAX(;$C$44-C9)+MIN(D9;$C$44)+(D9>$B$44)*(D9-$B$44)-(C9D9)-C9))*(C9<>D9)*($B$44<>$C$44))*24)
=(rest(a9;7)<>2)*(MAX(;1-MAX(C9;$B$44)+MAX(;$C$44-C9)+MIN(D9;$C$44)+(D9>$B$44)*(D9-$B$44)-(C9D9)-C9))*(C9<>D9)*($B$44<>$C$44))*24
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Sortaro
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste