Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Formel und Grafik für Mittelwert und Trend
#1
Hallo zusammen,
ich muss einige Listen von einem alten Programm nach Excel umsetzen und weiter ausführen, weil Windows 8 das Programm nicht mehr ausführt.
Es wurde und wird für jeden Tag des Jahres ein Wert eingetragen. Dieser soll fortlaufend mit dem Datum in eine Grafik übernommen werden. Den Rahmen für das ganze Jahr kann von Anfang an bestehen. Das habe ich schon hinbekommen.
Aus den täglich eingetragenen Werten muss ein fortlaufender Mittelwert und ein Trend ermittelt und ebenfalls in die Grafik eingetragen werden.
Dazu fehlen mir die Kenntnisse.
Die Versuche mache ich noch mit meinem Xp-Rechner mit Excel2007.
Diese Excel-Version ist auch auf dem neuen W8-Rechner installiert.
Danke für die Hilfe im Voraus
to top
#2
Hallo Weel,

im Prinzip so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
111
221,5
332
442,5
532,6
622,5
712,28571429

ZelleFormel
B1=MITTELWERT($A$1:A1)
B2=MITTELWERT($A$1:A2)
B3=MITTELWERT($A$1:A3)
B4=MITTELWERT($A$1:A4)
B5=MITTELWERT($A$1:A5)
B6=MITTELWERT($A$1:A6)
B7=MITTELWERT($A$1:A7)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg

Du markierst dann den Datenbereich beider Spalten und fügst ein Diagramm ein.

Die Trendlinie kannst Du im Diagrammmenü im Reiter Entwurf hinzufügen. Links hast Du dazu ein Menü "Diagrammelemente hinzufügen" Dort gibt es ein Untermenü Trendlinie mit einer Auswahl verschiedener Möglichkeiten.

   
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • WEEL
to top
#3
Hi,

ich würde dann noch die Datenauflistung in eine Tabelle umwandeln (STRG-T), dann wird die Liste bei Eintrag eines Wertes automatisch fortgeführt und auch das Diagramm wird erweitert.

Momentan habe ich nur ein Problem mit der Fortführung der Mittelwertformel:


Angehängte Dateien
.xlsb   Formeln und Grafik.xlsb (Größe: 15,43 KB / Downloads: 12)
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • WEEL
to top
#4
Hallo,

ich würde es so machen:


Angehängte Dateien
.xlsb   Formeln und Grafik.xlsb (Größe: 15,59 KB / Downloads: 12)
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • WEEL
to top
#5
Hi Edgar,

das Doofe ist, daß auch bei Deinem Beispiel (weil auf meiner Tabelle basierend) der letzten und vorletzten Mittelwertzelle immer die Formel für die letzte steht.

Tabelle1
ABC
908.01.201532,625
1009.01.201552,9
1110.01.201532,9

verwendete Formeln
Zelle Formel Bereich N/A
A9:A10=A8+1
C10=MITTELWERT($B$2:B11)
C9,C11=MITTELWERT($B$2:B9)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • WEEL
to top
#6
Hallo Ralph,

ist mir erst jetzt aufgefallen, dass er bei Eintrag einer neuen Zeile die Formel ändert. Er zeigt mir dass sogar als Fehler an und ich kann es korrigieren, ist aber blöd. Denke, dass ist ein echter Bug.
Läßt sich aber so abstellen:

Code:
=MITTELWERT($B$2:INDEX(B:B;ZEILE()))
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • WEEL
to top
#7
Hi Edgar,

(08.01.2015, 06:23)BoskoBiati schrieb: Denke, dass ist ein echter Bug.
Läßt sich aber so abstellen:

ja, gute Lösung. Mit Zeile() in der MW-Formel hatte ich es auch probiert, hat aber nicht geklappt.

.xlsb   Formeln und Grafik.xlsb (Größe: 13,78 KB / Downloads: 4)
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • WEEL
to top
#8
Hallo zusammen,

ich konnte das geschilderte Problem nicht nachvollziehen.

So sieht die zuerst eingestellte Tabelle von Ralf aus:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1DatumWertMittelwert
201.01.201511
302.01.201521,5
403.01.201532
504.01.201542,5
605.01.201553
706.01.201522,83333333
807.01.201512,57142857
908.01.201532,625
1009.01.201552,88888889
1110.01.201532,9

ZelleFormel
C2=MITTELWERT($B$2:B2)
C3=MITTELWERT($B$2:B3)
C4=MITTELWERT($B$2:B4)
C5=MITTELWERT($B$2:B5)
C6=MITTELWERT($B$2:B6)
C7=MITTELWERT($B$2:B7)
C8=MITTELWERT($B$2:B8)
C9=MITTELWERT($B$2:B9)
C10=MITTELWERT($B$2:B10)
C11=MITTELWERT($B$2:B11)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Dann gebe ich ein neues Datum und einen neuen Wert in Spalte B ein, und so sieht sie danach aus:
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1DatumWertMittelwert
201.01.201511
302.01.201521,5
403.01.201532
504.01.201542,5
605.01.201553
706.01.201522,83333333
807.01.201512,57142857
908.01.201532,625
1009.01.201552,88888889
1110.01.201532,9
1211.01.201512,72727273

ZelleFormel
C2=MITTELWERT($B$2:B2)
C3=MITTELWERT($B$2:B3)
C4=MITTELWERT($B$2:B4)
C5=MITTELWERT($B$2:B5)
C6=MITTELWERT($B$2:B6)
C7=MITTELWERT($B$2:B7)
C8=MITTELWERT($B$2:B8)
C9=MITTELWERT($B$2:B9)
C10=MITTELWERT($B$2:B10)
C11=MITTELWERT($B$2:B11)
C12=MITTELWERT($B$2:B12)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Es wäre interessant zu wissen, wie Edgar vorgegangen ist.
Gruß Atilla
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
  • WEEL
to top
#9
Hallo Atilla,

genauso. in dem Moment, in dem ich in A Enter drücke, ändert Excel die Formel ab.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • WEEL
to top
#10
Hallo und danke an alle die sich mit meinem Problem beschäftigt haben.
Eure Infos haben mir schon weiter geholfen, aber es sind noch Fragen offen.
1. Was soll bzw. bewirkt bei der Formel für den Mittelwert die Erweiterung mit dem Index?
2. Bei meinen Versuchen konnte ich nicht feststellen das die letzten Werte falsch waren.
3. Die eingetragenen Werte sind in einem Diagramm als Bereichs-Form eingetragen. Wie wird der Mittelwert als Linien-Form in diesem Diagramm eingetragen
4. Schauan hat beschrieben wie der Trend im Diagramm erzeugt wird. Das konnte ich nicht nachvollziehen. Kann das daranliegen das ich noch die Version 2007 benutze. Wenn ja, bitte Info wie ich bei dieser Version vorgehen muss.

Danke im Voraus
WEEL
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste