Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Formel mit mehreren WENN Werten verknüpfen
#1
Hallo Experten!

Ich bin gerade am Erstellen einer Stats-Excel Tabelle für mein SC2 Gameplay. Leider stoße ich bei den Formeln an meine Grenze und würde euch um Hilfe bitten.

Die Datei lade ich euch im Attachment mit dazu.

Was die Formel aussagen soll:

Grundsätzlich möchte ich im Reiter "Control Center" neben "Games" jeweils das "Win" oder "Loss" dazu gezählt haben. Diese teilen sich in Win/Loss PvT, PvZ und PvP (je nach Spiel) ein.

Damit ich das einfacher zählen kann habe ich in "Input" neben W/L den Reiter "W/L Code" erstellt. Hier möchte ich, dass Wenn im Feld E2 eine 1 steht (Code für PvT) UND in G2 eine 1 steht (steht für Win in diesem Spiel), dann soll hier (H2) eine "11" stehen. Wenn in E2 eine "1" steht aber in G2 eine 0 (steht für Loss in diesem Spiel) dann soll hier (H2) eine "12" stehen. Gleichzeitig soll die Formel aber berücksichtigen, dass im Feld E2 nicht nur "1" sondern auch "2" oder "3" stehen kann - in diesen Fällen sollen die Outputs "21" oder "22" und "31" oder "32" je nachdem ob es sich eben um ein PvT, ein PvZ oder ein PvP Spiel handelte.

Der Code wird automatisch mittel WENN Funktion aus MatchUp kreiert. Es soll in H2 immer nur ein eindeutiges Ergebnis stehen.

Wenn der Output in H2 dann eindeutig einen der sechs möglichen Codes wiedergibt, dann kann ich im Control Center den Code einfach beim jeweiligen Game zu Win oder Loss mittels ZÄHLENWENN anführen und sehe meine Statistik für die verschiedenen Spielarten.

Hoffe das ganze ist nicht zu verwirrt geschrieben - natürlich bin ich für komplett andere evtl. einfachere Ansätze gerne offen.

Danke vorab mal für eure Zeit!


Angehängte Dateien
.xlsx   Analyse.xlsx (Größe: 20,25 KB / Downloads: 6)
to top
#2
Hi,

sofern ich dein Problem richtig verstanden habe, müsste dir in Spalte H diese Formel
Zitat:=WENN(UND(G2=1;ODER(E2=1;E2=2;E2=3));E2&G2;E2&2)

helfen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo,

da bedarf es weder Hilfsspalten noch sonstige Konstrukte, dafür gibt es ZÄHLENWENNS:

Arbeitsblatt mit dem Namen 'Control Center'
 ABCD
12MatchupGamesWinLoss
13PVT321
14PVZ211
15PVP321

ZelleFormel
C13=ZÄHLENWENNS(Input!$D:$D;$A13;Input!$G:$G;2-SPALTE(A1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#4
Wink 
Danke an eure Hilfe BoskoBiati und WillWissen!

Aufgrund des Auskommens ohne Hilfstabellen werde ich den Vorschlag von BoskoBiati umsetzen - funktioniert schon mal super!

Vielen Dank nochmal!  19

Schönen Abend!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste