Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel mit Datum und Zellenbezug
#1
Hallo zusammen,

Ich bin auf der Suche nach einem Weg wie ich meinen täglichen Einsatzplan mit meiner Urlaubsdatei verbinden kann

In der Urlaubsdatei habe ich alle Werktage der breite nach aufgeführt je Mitarbeiter gibt es eine Zeile wenn der Mitarbeiter Urlaub hat oder Krank ist, ist dies mit einem K oder U gekennzeichnet.

Sobald dieser Mitarbeiter nicht anwesend ist soll mir dieser für meine Auswahlliste des Einsatzplanes nicht mehr als verfügbar erscheinen.

Ich hoffe ihr könnt mir helfen

Vielen Dank
UN
Antwortento top
#2
Hola,

Zitat:Ich hoffe ihr könnt mir helfen

mit den wenigen Angaben wird das wohl nichts. Eine Beispieldatei wäre sinnvoll.

Gruß,
steve1da
Antwortento top
#3
Hallo UN,

Ich vermute, dass Du die Auswahlliste über die Gültigkeit füllst? Erstelle in einer Hilfsspalte eine Liste mit den anwesenden Mitarbeitern. Wenn dich Leere Zeilen nicht stören, dann der obere Teil, wenn doch, der untere mit der komplizierteren Formel.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1NameStatusAuswahl
2AntonAAnton
3BertaK 
4CaesarU 
5DoraADora
6   
7NameStatusAuswahl
8AntonAAnton
9BertaKDora
10CaesarU 
11DoraA 

ZelleFormel
C2=WENN(B2="A";A2;"")
C3=WENN(B3="A";A3;"")
C4=WENN(B4="A";A4;"")
C5=WENN(B5="A";A5;"")
C8{=WENN(ZÄHLENWENN($B$8:$B$999;"A") < ZEILE(A1);"";INDEX(A$1:A$999; KKLEINSTE(WENN(ISTZAHL(SUCHEN("A";B$8:B$999));ZEILE($8:$999));ZEILE(A1))))}
C9{=WENN(ZÄHLENWENN($B$8:$B$999;"A") < ZEILE(A2);"";INDEX(A$1:A$999; KKLEINSTE(WENN(ISTZAHL(SUCHEN("A";B$8:B$999));ZEILE($8:$999));ZEILE(A2))))}
C10{=WENN(ZÄHLENWENN($B$8:$B$999;"A") < ZEILE(A3);"";INDEX(A$1:A$999; KKLEINSTE(WENN(ISTZAHL(SUCHEN("A";B$8:B$999));ZEILE($8:$999));ZEILE(A3))))}
C11{=WENN(ZÄHLENWENN($B$8:$B$999;"A") < ZEILE(A4);"";INDEX(A$1:A$999; KKLEINSTE(WENN(ISTZAHL(SUCHEN("A";B$8:B$999));ZEILE($8:$999));ZEILE(A4))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallo nochmal,

danke euch vorab.

ich hab mein Problem in der hochgeladenen Datei mal rein geschrieben, hoffe ihr versteht was ich meine...
Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html ..com/muster2

Ich weiss nicht ob ich einfach zu verquer denke, vielleicht habt ihr ja eine Idee wie man einen auf den Status des Mitarbeiters (Krank, Urlaub) bezogenen Einsatzplan erstellen kann.

Das Ziel was ich damit erreichen soll ist eine benutzerfreundliche Datei für sämtliche Generationen zu erstellen.

Nochmal danke an euch.

LG
UN
Antwortento top
#5
Hallo, bitte benutze doch die Möglichkeit hier direkt eine Datei hochzuladen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#6
Brille putzen hilft manchmalSmile, sorry

Gruß
UN


Angehängte Dateien
.xlsx   Muster 2.xlsx (Größe: 43,22 KB / Downloads: 8)
Antwortento top
#7
Hallo,

wenn Du Deinen Einsatzplan etwas anders gestalten könntest, wäre das Ganze recht einfach zu bewerkstelligen. Im Anhang mal ein Ansatz, kannst ja mal mit spielen.


Angehängte Dateien
.xlsx   Arbeitsplan.xlsx (Größe: 50,8 KB / Downloads: 8)
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste