Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel die bestimmt für Euch leicht ist :-)
#1
Moin liebe Leutz,

ich steh total auf dem Schlauch - 16 
Also, ich habe eine Formel die lautet: =WENN(ODER(C33=2;C33=3;C33=4);"0").
Die macht folgendes wenn C33 = 2 oder 3 oder 4 ist schreibt sie in die Zeile mit Formel 0.
Soweit so gut: ich möchte aber das die Formel auch noch wenn in C33=5 und 6 in die zelle 3 schreibt und wenn in C33=7 o. 8 o. 9 steht 12 schreiben u.s.w.. Aber bitte ohne Makro.

vielen Dank im vorraus
Hagen
Antwortento top
#2
Hallo,

ungetestet:

=WENN(ODER(C33>9;C33<2);"Falsch";WENN(C33>6;12;WENN(C33>4;3;0)))
Gruß
Peter
Antwortento top
#3
Hallo,

ungetestet:

=WENN(ODER(C33>9;C33<2);"Falsch";WENN(C33>6;12;WENN(C33>4;3;0)))

BTW: Wenn du in deiner Formel die 0 in Anführungszeichen setzt dann interpretiert XL das nicht als Zahl sondern als Text. Bei weiteren Berechnungen könnte das problematisch werden.
Gruß
Peter
Antwortento top
#4
(08.04.2015, 18:11)Peter schrieb: Hallo,

ungetestet:

=WENN(ODER(C33>9;C33<2);"Falsch";WENN(C33>6;12;WENN(C33>4;3;0)))

BTW: Wenn du in deiner Formel die 0 in Anführungszeichen setzt dann interpretiert XL das nicht als Zahl sondern als Text. Bei weiteren Berechnungen könnte das problematisch werden.

Hallo Peter,

vielen Dank - ich habe mich glaube ich nicht sehr gut ausgedrückt:
Also schau : Es darf nicht kleiner/ größer sein es muss genau stimmen

C33=2,3,4 soll in Zelle schreiben 0
C33=6,7,8,9,10 soll in Zelle schreiben 1
C33=12,13,14 soll in Zelle schreiben 2
C33=16,17,18 soll in Zelle schreiben 3
C33=20,21,22 soll in Zelle schreiben 4
C33=24,25,26 soll in Zelle schreiben 5
C33=28,29,30 soll in Zelle schreiben 6

sollte doch auch gehen. ODER ?

Gruß Hagen



        
Antwortento top
#5
Hallo,

was soll passieren bei den Werten 5, 11, 15 etc. die du nicht aufgeführt hast? Im ersten Posting war die 5 noch aufgeführt - jetzt fehlt dieser Wert.

Man könnte eine Matrix aufbauen und dann einfach mit Sverweis arbeiten. Das könnte z.B. so aussehen, wobei ich jetzt einfach mal die 5 als Fehler definiert habe.

Arbeitsblatt mit dem Namen 'Tabelle1'
 CDEFGH
25    von / bisWert
26    20
27    5Fehler
28    61
29    122
30    163
31    204
32    245
332 0 286
34    31Fehler

ZelleFormel
E33=SVERWEIS(C33;G26:H34;2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Matrix müsstest du dann noch auf deine tatsächlichen Verhältnisse anpassen.
Gruß
Peter
Antwortento top
#6
(08.04.2015, 18:30)Peter schrieb: Hallo,

was soll passieren bei den Werten 5, 11, 15 etc. die du nicht aufgeführt hast? Im ersten Posting war die 5 noch aufgeführt - jetzt fehlt dieser Wert.

Man könnte eine Matrix aufbauen und dann einfach mit Sverweis arbeiten. Das könnte z.B. so aussehen, wobei ich jetzt einfach mal die 5 als Fehler definiert habe.

Arbeitsblatt mit dem Namen 'Tabelle1'
 CDEFGH
25    von / bisWert
26    20
27    5Fehler
28    61
29    122
30    163
31    204
32    245
332 0 286
34    31Fehler

ZelleFormel
E33=SVERWEIS(C33;G26:H34;2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Matrix müsstest du dann noch auf deine tatsächlichen Verhältnisse anpassen.
Hallo,

ne Formel so ungefähr geht nicht:??

=WENN(ODER(C33=2;C33=3;C33=4);"0");WENN(ODER(C33=6;C33=7;C33=8);"1");WENN(ODER(C33=18;C33=19;C33=20);"3")

Gruß Hagen
Antwortento top
#7
Hallo,

sicher geht das auch, du musst nur mit der Klammersetzung ein wenig aufpassen:

=WENN(ODER(C33=2;C33=3;C33=4);0;WENN(ODER(C33=6;C33=7;C33=8);1;WENN(ODER(C33=18;C33=19;C33=20);3)))

Die Anführungszeichen um die Werte habe ich weggenommen - warum habe ich bereits in einem früheren Posting geschrieben.
Gruß
Peter
Antwortento top
#8
Hi,

(08.04.2015, 18:55)Peter schrieb: =WENN(ODER(C33=2;C33=3;C33=4);0;WENN(ODER(C33=6;C33=7;C33=8);1;WENN(ODER(C33=18;C33=19;C33=20);3)))

ha! Jetzt kann ich auch mal kürzer:

=WENN(UND(C33>1;C33<5);0;WENN(UND(C33>5;C33<9);1;WENN(UND(C33>17;C33<21);3;"falsch")))
Antwortento top
#9
(08.04.2015, 19:18)Rabe schrieb: Hi,


(08.04.2015, 18:55)Peter schrieb: =WENN(ODER(C33=2;C33=3;C33=4);0;WENN(ODER(C33=6;C33=7;C33=8);1;WENN(ODER(C33=18;C33=19;C33=20);3)))

ha! Jetzt kann ich auch mal kürzer:

=WENN(UND(C33>1;C33<5);0;WENN(UND(C33>5;C33<9);1;WENN(UND(C33>17;C33<21);3;"falsch")))
Ihr seid Genies, vielen Dank, die Klammern waren es wieder mal. Das lerne ich nie.
So ist jetzt die Formel für richtig und Sie funktioniert prächtig:

=WENN(ODER(C33=2;C33=3;C33=4);0;WENN(ODER(C33=6;C33=7;C33=8;C33=9;C33=10);1;WENN(ODER(C33=12;C33=13;C33=14);2;WENN(ODER(C33=16;C33=17;C33=18);3;WENN(ODER(C33=20;C33=21;C33=22);4;WENN(ODER(C33=24;C33=25;C33=26);5;WENN(ODER(C33=28;C33=29;C33=30);6)))))))

Also, vielen Dank. Da bin ich morgen voll der Held auf Arbeit

Grüße aus ESA
Hagen
Antwortento top
#10
(08.04.2015, 20:03)Hagen schrieb:
(08.04.2015, 19:18)Rabe schrieb: Hi,



(08.04.2015, 18:55)Peter schrieb: =WENN(ODER(C33=2;C33=3;C33=4);0;WENN(ODER(C33=6;C33=7;C33=8);1;WENN(ODER(C33=18;C33=19;C33=20);3)))

ha! Jetzt kann ich auch mal kürzer:

=WENN(UND(C33>1;C33<5);0;WENN(UND(C33>5;C33<9);1;WENN(UND(C33>17;C33<21);3;"falsch")))
Ihr seid Genies, vielen Dank, die Klammern waren es wieder mal. Das lerne ich nie.
So ist jetzt die Formel für richtig und Sie funktioniert prächtig:

=WENN(ODER(C33=2;C33=3;C33=4);0;WENN(ODER(C33=6;C33=7;C33=8;C33=9;C33=10);1;WENN(ODER(C33=12;C33=13;C33=14);2;WENN(ODER(C33=16;C33=17;C33=18);3;WENN(ODER(C33=20;C33=21;C33=22);4;WENN(ODER(C33=24;C33=25;C33=26);5;WENN(ODER(C33=28;C33=29;C33=30);6)))))))

Also, vielen Dank. Da bin ich morgen voll der Held auf Arbeit

Grüße aus ESA
Hagen

Hi Hagen, hier felht der letzte Sonst_Wert... ... was soll denn passieren, bei 5 z.B. (Peter hatte schon nachgefragt...)?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste