Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Formel: Teile einer Tabelle in andere Tabelle verlinken
#1
Hallo,

ich möchte Daten aus Tabelle 1 per Formel in Tabelle 2 verlinken ohne Leerzeilen direkt untereinander.
Es sollen von allen Zeilen, die ein x in Spalte A und eine Prozeß-Nummer (oder ungleich leer) in Spalte C haben, die Zellen C, D und E in der Tabelle 2 stehen.

Meine Vorgehensweise:
Ich trage am Anfang die Reihenfolge aller Prozesse in Spalte B ein und per x in Spalte A, ob diese Zeile verwendet werden soll. Dann sortiere ich die Ausgangstabelle nach B und in der Tabelle 2 sollen dann die Inhalte der Zellen C-E stehen, die eine Prozeß-Nummer haben und gleichzeitig in A ein x. Das Ergebnis ist dann in Tabelle 1 eine Übersicht aller Prozesse inkl. Unterprozesse, die verwendet werden und in Tabelle 2 nur die Hauptprozesse ohne Leerzeilen.

Wenn nun für eine zweite Übersicht eine andere Reihenfolge oder andere Prozesse verwendet werden, dann sollen automatisch ohne weiteres Zutun in Tabelle 2 wieder die Hauptprozesse aufgelistet sein.

Ich will es nicht per Makro machen, weil ich sonst auf jedem Rechner im Netzwerk dieses Makro freischalten müßte und die Dateivorlage liegt auf einem Netzlaufwerk.

Also suche ich die Formel für Tabelle 2 Spalte A zum runterziehen. Wie müßte die Formel denn aussehen?

Hier ist die Ausgangstabelle:
Tabelle1
ABCDE
1verwendenSortierungProzeß-NummerBezeichnung 1Bezeichnung 2
2x1'01.01.0aaaaazzzzz
34'01.01.1bbbbbyyyyy
4x2'02.01.0cccccxxxxx
5x3dddddwwwww
6'02.02.0eeeeevvvvv
7x6'02.02.1fffffuuuuu
87gggggttttt
9x8hhhhhsssss
109iiiiirrrrr
11'02.02.2jjjjjqqqqq
12kkkkkppppp
13x5'02.02.3lllllooooo
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit



Ergebnis (manuell erstellt, erst mal unsortiert):
Tabelle2
ABC
1Prozeß-NummerBezeichnung 1Bezeichnung 2
2'01.01.0aaaaazzzzz
3'02.01.0cccccxxxxx
4'02.02.1fffffuuuuu
5'02.02.3lllllooooo
6

verwendete Formeln
Zelle Formel Bereich N/A
B2:C6=WENN($A2<>"";SVERWEIS($A2;Tabelle1!$C$1:$E$13;SPALTE(B1);0);"")
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#2
Hallo Ralf, meinst Du so..?

In A2 Tabelle2

=WENNFEHLER(INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!$A$1:$A$13="x")*(Tabelle1!$C$1:$C$13<>"");ZEILE(Tabelle1!$A$1:$A$13));ZEILE(A1)));"")

8ung! Matrixformel (Strg+Umsch+Enter)

Tabelle2 B2..:

=WENN($A2<>"";SVERWEIS($A2;Tabelle1!$C$1:$E$13;SPALTE(B$1);0);"")
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hi,

(10.02.2015, 23:53)Jockel schrieb: meinst Du so..?

nicht ganz:

Tabelle2
ABC
1Prozeß-NummerBezeichnung 1Bezeichnung 2
2Prozeß-NummerBezeichnung 1Bezeichnung 2
3
4
5
6

verwendete Formeln
Zelle Formel Bereich N/A
A2:A5=WENNFEHLER(INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!$A$1:$A$13="x")*(Tabelle1!$C$1:$C$13<>"");ZEILE(Tabelle1!$A$1:$A$13));ZEILE(A1)));"")
B2:C6=WENN($A2<>"";SVERWEIS($A2;Tabelle1!$C$1:$E$13;SPALTE(B$1);0);"")
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#4
Hallo Ralf, oder vielleicht so..:

Arbeitsblatt mit dem Namen 'Tabelle2 (3)'
 ABC
1Prozeß-NummerBezeichnung 1Bezeichnung 2
2'01.01.0aaaaazzzzz
3'01.01.1bbbbbyyyyy
4'02.02.3lllllooooo
5'02.02.1fffffuuuuu
6   
7   

ZelleFormel
A2{=WENNFEHLER(INDEX(Tabelle1!$C$2:$C$13;VERGLEICH(KKLEINSTE(WENN((Tabelle1!$A$1:$A$13="x")*(Tabelle1!$C$1:$C$13<>"");Tabelle1!$B$1:$B$13);ZEILE(A1));Tabelle1!$B$2:$B$13;0);1);"")}
B2=WENN($A2<>"";SVERWEIS($A2;Tabelle1!$C$1:$E$13;SPALTE(B$1);0);"")
C2=WENN($A2<>"";SVERWEIS($A2;Tabelle1!$C$1:$E$13;SPALTE(C$1);0);"")
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hallo Ralf, hier hast Du die Formel nicht als Matrixformel abgeschlossen...

(11.02.2015, 00:19)Rabe schrieb: Hi,

(10.02.2015, 23:53)Jockel schrieb: meinst Du so..?

nicht ganz:

Tabelle2
ABC
1Prozeß-NummerBezeichnung 1Bezeichnung 2
2Prozeß-NummerBezeichnung 1Bezeichnung 2
3
4
5
6

verwendete Formeln
Zelle Formel Bereich N/A
A2:A5=WENNFEHLER(INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!$A$1:$A$13="x")*(Tabelle1!$C$1:$C$13<>"");ZEILE(Tabelle1!$A$1:$A$13));ZEILE(A1)));"")
B2:C6=WENN($A2<>"";SVERWEIS($A2;Tabelle1!$C$1:$E$13;SPALTE(B$1);0);"")
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hi Jörg,

(11.02.2015, 00:22)Jockel schrieb: hier hast Du die Formel nicht als Matrixformel abgeschlossen...

stimmt, hatte es gerade gemerkt. Peinlich, dabei hattest Du es extra dazugeschrieben.

Danke!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste