Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Formel Problem
#1
Hallo an alle,

ich habe mal eine Frage zu einer Tabelle:

In der ersten Tabelle ( unsortiert ) habe ich zwei Spalten mit Größe und Bezeichnung:

Spalte B dort sind Größen durcheinander und in Spalte C die Bezeichnung zu der Größe.

In der zweiten Tabelle ( sortiert ) ist eine Liste wo die Größen sortiert hinterlegt sind, und dort sollen jetzt automatisch die Bezeichnungen von der unsortierten Tabelle der Größe zugeordnet werden.

Jetzt habe ich das über Sverweis() probiert klappt auch soweit ganz gut (zu mindestens für die erste Zeile)
Das Problem besteht darin das wenn ich die Formel runterkopiere werden die anderen Bezeichnungen zwar gefunden stehen aber mehrmals dann darin????

Die Formel sieht momentan so aus : SVERWEIS(sortiert!B$5;unsortiert!B5:C$11;2;0)

Ich habe eine Beispiel Datei im Anhang hochgeladen.

Vielleicht kann mir jemand helfen.......oder zu mindestens in die richtige Richtung schupsen Blush

Bedanke mich schon einmal

Lg Björn


Angehängte Dateien
.xlsx   unsortiert_sortiert.xlsx (Größe: 9,27 KB / Downloads: 4)
Antwortento top
#2
Hallo Björn, wenn ich das richtig verstanden habe, müßte ff passen..:

Arbeitsblatt mit dem Namen 'sortiert'
 ABCDE
5Größe8101215
6BezeichnungKetteHoseJackeT-Shirt
7  StrumpfHut 
8     
9     
10     
11     

ZelleFormel
B6{=WENNFEHLER(INDEX(unsortiert!$C$6:$C$11;KKLEINSTE(WENN(unsortiert!$B$6:$B$11=B$5;ZEILE($A$1:$A$6));ZEILE($A1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • b.wolff78
Antwortento top
#3
Hi Jockel,
Danke erstmal für deine Antwort.......

genau sowas meine ich, ich steige zwar nicht ganz durch die Formel durch aber ich werde sie mir heute Abend noch genauer anschauen wie die Funktioniert.

Jetzt ist mir nur bei der Größe 10 aufgefallen das die Schuhe fehlen.

Die Formel lautet ja : {=WENNFEHLER(INDEX(unsortiert!$C$6:$C$11;KKLEINSTE(WENN(unsortiert!$B$6:$B$11=B$5;ZEILE($A$1:$A$6));ZEILE($A1)));"")}

Die Schuhe stehen in der unsortierten Tabelle auf C5 jetzt habe ich die Formel geändert:{=WENNFEHLER(INDEX(unsortiert!$C$5:$C$11;KKLEINSTE(WENN(unsortiert!$B$5:$B$11=C$5;ZEILE($A$1:$A$6));ZEILE($A1)));"")}

Bekomme jetzt aber bei der Größe 10 nur noch ein leeres Feld zu sehen, nehme ich deine klappt alles soweit bis auf das die Schuhe fehlen????

Ich muss ehrlich sagen bei der Formelzusammenstellung bin ich raus, da fehlt mir das Verständnis (noch19)
Antwortento top
#4
Hallo, das war ein Schusselfehler..:

Arbeitsblatt mit dem Namen 'sortiert'
 ABCDE
5Größe8101215
6BezeichnungKetteSchuheJackeT-Shirt
7  HoseHut 
8  Strumpf  
9     
10     
11     

ZelleFormel
B6{=WENNFEHLER(INDEX(unsortiert!$C$5:$C$11;KKLEINSTE(WENN(unsortiert!$B$5:$B$11=B$5;ZEILE($A$1:$A$7));ZEILE($A1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • b.wolff78
Antwortento top
#5
Hallo Jockel,

ich muss sagen wow...... 23

genau so soll es sein......

Zwei Fragen zu der Formel:

Wofür sind die beiden Klammern{} ???? Und warum wird die Zeile A mit einbezogen ZEILE($A$1:$A$7));ZEILE($A1)));"") ????

Die beiden zusammenhänge verstehe ich nicht ..............

Lg Björn
Antwortento top
#6
Hallo Björn

Zitat:Wofür sind die beiden Klammern{} ????
Bitte den Hinweis unter der Tabelle beachten.

Zitat:Und warum wird die Zeile A mit einbezogen ZEILE($A$1:$A$7));ZEILE($A1)));"") ????
Schreibe mal =ZEILE(A1) in eine beliebige Zelle und kopiere diese nach rechts und nach unten. Vielleicht fällt dir etwas auf.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • b.wolff78
Antwortento top
#7
Morgen Shift-Del......


werde ich heute Abend wenn ich Zuhause bin mal ausprobieren....

So langsam bekomme ich gefallen an Excel 19
Antwortento top
#8
(17.12.2014, 08:22)b.wolff78 schrieb: Morgen Shift-Del......


werde ich heute Abend wenn ich Zuhause bin mal ausprobieren....

So langsam bekomme ich gefallen an Excel 19


Hallo Björn, das ist der Weg...
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • b.wolff78
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste