Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Feiertage anzeigen
#1
Hallo zusammen

Ich trau mich eigentlich nicht zu fragen, da mein Wissen über excel doch sehr klein ist und ich weiß auch nicht ob dieses Forum deshalb das richtige für mich ist als Anfänger.

Ich habe nun mehrere Stunden an einer Tabelle und mit etlichen Seiten im www verbracht ohne Erfolg.

Zur Zeit möchte ich Feiertage aus einer Liste die in einem separaten Blatt stehen in einen Kalender eintragen lassen.
Diese sollen mit Namen eingetragen werden.
Durch viel lesen, ist mir bekannt, dass die Formel meinen Kalender bzw. die dort eingetragenen Daten abgleichen muss mit der Feiertagsliste um dementsprechend einen bestimmten Wert auszugeben.
Nun habe ich in meinem Kalender aber das Datum in einer Zelle stehen, darunter eine weitere Zelle die aber 2 Spalten größer ist als die des Datums weil diese miteinander verbunden sind.
In die Zelle unter das Datum soll der Feiertag eingetragen und dementsprechend farblich markiert werden.
So oder so ähnlich zumindest sollen auch die Geburtstage eingetragen werden. Am liebsten hätte ich dieses mit Namen gemacht, aber auch hier stoße ich auf das gleiche Problem.

Wenn mir doch jemand helfen möchte und kann, würde ich mich freuen wenn er mir die entsprechenden Formeln verständlich erklären könnte.

Vielen Dank für eure Geduld mit mir Nervensäge


Kalender1

ABCDEFGHIJKLMN
12007
2JanuarFebruar
3Mo. 01Do. 01
4
5Di. 02Fr. 02
6
7Mi. 03Sa. 03
8
9Do. 04So. 04
10
11Fr. 05Mo. 05
12
13Sa. 06Di. 06
14
15So. 07Mi. 07
16
Formeln der Tabelle
ZelleFormel
A1=Grundeinstellung!E3
A2=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-1))=SPALTE();DATUM($A$1;SPALTE();ZEILE()-1);"")
H2=H3
A3=DATUM(A1;SPALTE();ZEILE()-2)
H3=DATUM(A1;SPALTE()-6;ZEILE()-2)
A5=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-3))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-3))
H5=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-3))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-3))
A7=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-4))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-4))
H7=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-4))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-4))
A9=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-5))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-5))
H9=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-5))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-5))
A11=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-6))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-6))
H11=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-6))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-6))
A13=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-7))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-7))
H13=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-7))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-7))
A15=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-8))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-8))
H15=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-8))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-8))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Feiertage

ABCDEFG
12007Deutschland
2
301.01.2007NeujahrMo. 01.01.2007x
402.02.2007Mariä LichtmeßFr. 02.02.2007x
506.01.2007Hl. Drei KönigeSa. 06.01.2007x
615.02.2007AltweiberfastnachtDo. 15.02.2007x
700.01.1900RosenmontagMo. 19.02.2007
800.01.1900FastnachtDi. 20.02.2007
900.01.1900AschermittwochMi. 21.02.2007
1000.01.1900Mariä VerkündungSo. 25.03.2007
1100.01.1900GründonnerstagMi. 04.04.2007
1206.04.2007KarfreitagFr. 06.04.2007x
1308.04.2007OstersonntagSo. 08.04.2007x
1409.04.2007OstermontagMo. 09.04.2007x
Formeln der Tabelle
ZelleFormel
C1=Grundeinstellung!E3
B3=WENN(F3="x";D3;0)
D3=DATWERT("01.01."&$C$1)
B4=WENN(F4="x";D4;0)
D4=DATUM(C$1;2;2)
B5=WENN(F5="x";D5;0)
D5=DATUM(C$1;1;6)
B6=WENN(F6="x";D6;0)
D6=D$13-52
B7=WENN(F7="x";D7;0)
D7=D$13-48
B8=WENN(F8="x";D8;0)
D8=D$13-47
B9=WENN(F9="x";D9;0)
D9=D$13-46
B10=WENN(F10="x";D10;0)
D10=DATUM(C$1;3;25)
B11=WENN(F11="x";D11;0)
D11=D$12-2
B12=WENN(F12="x";D12;0)
D12=D$13-2
B13=WENN(F13="x";D13;0)
D13=DM((TAG(MINUTE(C$1/38)/2+55)&".4."&C$1)/7;)*7-6
B14=WENN(F14="x";D14;0)
D14=D$13+1

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Smilies ausgeschaltet
?mage
Gruß

Lümmel
to top
#2
Hallo,

markier die besagten Zellen ab A4 beginnen mit gedrückter Srg Taste und kopier dann folgende Formel in die Bearbeitungsleiste und schließe den Vorgang nit Enter ab.

=WENN(ZÄHLENWENN(Feiertage!$B$3:$B$14;A3);INDEX(Feiertage!$C$3:$C$14;VERGLEICH(A3;Feiertage!$B$3:$B$14;0));"")
Gruß Atilla
to top
#3
Hallo,

hab jetzt selber mal geteste, was vorgeschlagen habe. Das klappt nicht.

Dann so:
Die Formel in Zelle A4 schreiben.
Die Zelle kopieren.
Alle anderen Zellen für die Feiertage mit gedrückter Strg Taste markieren und einfügen.
Das klappt!
Gruß Atilla
to top
#4
(20.12.2014, 18:57)atilla schrieb: Hallo,

markier die besagten Zellen ab A4 beginnen mit gedrückter Srg Taste und kopier dann folgende Formel in die Bearbeitungsleiste und schließe den Vorgang nit Enter ab.

=WENN(ZÄHLENWENN(Feiertage!$B$3:$B$14;A3);INDEX(Feiertage!$C$3:$C$14;VERGLEICH(A3;Feiertage!$B$3:$B$14;0));"")

Hallo Atilla

Danke dir für die schnelle Antwort.

Leider ist das Ergebnis ein ungültiger Name #Name?

Zumindest in den Zellen wo ein Feiertag angeben werden müsste.

Andere Zellen bleiben leer.
Gruß

Lümmel
to top
#5
Sorry hatte Tippfehler in der Formel

Es funktioniert


Vielen vielen Dank

Ich muss sagen da kann man nur neidisch werden über diejenigen die von Excel so viel verstehen.
Gruß

Lümmel
to top
#6
Hallo zusammen,
habe das Thema geteilt und die Fehlerdiskussion zu Bugs und Auffälligkeiten verschoben.
http://www.clever-excel-forum.de/thread-1340.html
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste