Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Fehler #NV in Zelle
#1
Hallo zusammen,

ich habe eine Tabelle zur Stundeneingabe erstellt. Auf der Startseite wird das Jahr eingegeben. Alle Tabellen funktionieren auch, Dank der Hilfe von steve1da.
Ich habe nur noch ein Problem im Monat Februar. Solange man auf dem Reiter der Startseite ein Jahr eingibt in dem es den 29.02. gibt, klappt im Monat Februar die Berechnung. Wenn ich aber z.B. 2017 als Jahr eingebe, dann habe ich im Reiter Februar in Zelle M34 und K34 einen Fehler.

Gibt es hier noch eine Möglichkeit, wenn es den 29.02. nicht gibt, die Zeile 34 leer zu lassen?

Grüße
Uwe


Angehängte Dateien
.xlsx   Neu.xlsx (Größe: 577,45 KB / Downloads: 4)
Antwortento top
#2
Hola,

warum erzeugst du deine Datumswerte immer als TEXT?
Warum Tag und Jahr in getrennten Zellen?
Was soll =SUMME(Startseite!K9) bewirken - die Summe einer einzelnen Zelle?

Durch TEXT kannst du dir sogar den 34.02.2017 basteln - bringt dir allerding nix.
Es gibt hunderte Vorlagen dafür im Netz. 
Um Fehlermeldungen zu "beseitigen" gibt es Wennfehler().

Gruß,
steve1da
Antwortento top
#3
Hallo steve1da,

ich bin noch nicht so gut in Excel, deshalb sind da wohl auch noch Fehler drin. =SUMME(Startseite!K9) ist natürlich doof, das ändere ich noch ab.

Aber ich bekomme es mit dem WENNFEHLER nicht hin. Könntest du mir evtl. die Formel umschreiben und mir die Datei zurückschicken?

Grüße
Uwe
Antwortento top
#4
Hola,

Wennfehler() kommt immer um die ganze Formel.


Code:
=WENNFEHLER(TEXT(O34;"TTT");"")


Code:
=WENNFEHLER(SVERWEIS(E34;$A$6:$B$12;2;0)+WENN(N34="Überstundenfrei";Q6)+WENN(N34="Feiertag";Q6);"")

Aber wie gesagt, glücklich wirst du mit dem Kalender nicht da jeder Monat in jedem Jahr angepasst werden muss!
Ich schau mal wie ich morgen Zeit habe, dann bastel ich dir was.

Gruß,
steve1da
Antwortento top
#5
Moin Uwe,

ich habe mal einen Anfang gemacht. Ich stimme Steve in seiner Bewertung voll zu, will aber auch nicht alles von dir erarbeitete umwerfen. 
Meine Änderungen beziehen sich ausschließlich auf den Februar. Grundsätzlich habe ich die Spalten E:G und K geändert. Und schau dir mal die Zahlen-Formatierungen in den farblich geänderten Bereichen an. Ach ja, die Spalten O:P sind gewiss überflüssig, oder?

Schau dir einfach alles einmal an und erarbeite dir die Lösung für die weiteren Monate ...


Angehängte Dateien
.xlsx   Günthers erste Änderung - Neu.xlsx (Größe: 594,26 KB / Downloads: 7)
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
Antwortento top
#6
Hallo Günther,

vielen Dank für deine Mühe.

Nun habe ich, gerade was die Datumsanzeigen angeht, wieder etwas dazugelernt. Da war ich ja ziemlich umständlich. Ich werde die anderen Monate entsprechend ändern.
Somit sind eigentlich alle meine "selbstgemachten" Probleme behoben.

Grüße
Uwe
Antwortento top
#7
Hallo,

ich habe da auch noch eine Variante:



.xlsx   AZ_Neu.xlsx (Größe: 576,81 KB / Downloads: 6)
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
Hallo Opa Edgar,

auch dir vielen Dank. Ich habe die Tabelle jetzt hinbekommen.
Alles funktioniert bestens.

Gruß
Uwe
Antwortento top
#9
Hi,

(11.01.2017, 09:23)BoskoBiati schrieb: ich habe da auch noch eine Variante:

hier eine weiterentwickelte Variante:

.xlsx   AZ_Neu - Rabe.xlsx (Größe: 162,15 KB / Downloads: 3)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste