Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Farbige Zellen zählen
#1
Hallo zusammen,

ich habe eine Liste und je nach Zahl markiere ich diese farblich (>250 grün, 249-233 gelb, <233 rot).

Ich möchte die farbigen Zellen mit einer Bedingung zählen, wie oft welche Farbe vorgekommen ist.
Beispiel: "1" 14xrot 9xgelb 49xgrün und zusätzlich noch den Durchschnitt der gezählten Werte.

P.S. Die Summenzellen (Spalte C, G, H...) der farbigen Zellen sind irrelevant.


Angehängte Dateien
.xlsx   Mappe.xlsx (Größe: 16,69 KB / Downloads: 17)
Antwortento top
#2
Hola,

und welche Spalten sind nun wirklich relevant? Alle die, die verbunden Zellen enthalten?

Mir scheint, als suchst du Summenprodukt() oder Zählenwenns().

Gruß,
steve1da
Antwortento top
#3
Hallo,

die verbundenen Zellen sind ja die Summen der farbigen Einzelzellen. Die möchte ich nicht zählen, nur die Einzelzellen der jeweiligen Kennzahl (1-5).

Es soll halt so aussehen, wie ich es bereits händisch aufgeführt habe. Nur möchte ich es ungerne immer "zu Fuß" machen.
Theoretisch könnte man auch die Werte (>249, 249-233, <233) auslesen und diese dann zuordnen. Ich weiß nur nicht wie und was die elegantere Lösung ist, daher frage ich hier.Smile
Antwortento top
#4
Hallo

Entsprechend den bedingten Formatierungen:
B22: 0
B23: 232
C22: 233
C23: 249
D22: 251
D23: 999
Du hast da übrigens eine Definitionslücke bei 250.

Und dann diese elegante Formel in B16[:D20]:
Code:
=SUMMENPRODUKT(($D$1:$BQ$12=$A16)*($E$1:$BR$12>=B$22)*($E$1:$BR$12<=B$23)*(REST(SPALTE($D$1:$BQ$1);5)=4))+SUMMENPRODUKT(($D$1:$BQ$12=$A16)*($F$1:$BS$12>=B$22)*($F$1:$BS$12<=B$23)*(REST(SPALTE($D$1:$BQ$1);5)=4))+SUMMENPRODUKT(($A$1:$A$12=$A16)*($B$1:$B$12>=B$22)*($B$1:$B$12<=B$23))+SUMMENPRODUKT(($BV$1:$BV$12=$A16)*($BW$1:$BW$12>=B$22)*($BW$1:$BW$12<=B$23))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Guten Morgen,

danke für die Mühe und den Hinweis! Jedoch klappt es bei mir leider nicht mit der Formel.
Antwortento top
#6
Hola,


Zitat:Jedoch klappt es bei mir leider nicht mit der Formel.


klappt nicht heißt was?

Gruß,
steve1da
Antwortento top
#7
Morrn,
in der Tabelle sind noch mehr Ungereimtheiten enthalten, die eine Auswertung erschweren. Neben der von Detlef genannten ist es noch die BedingtFormatierung für zwischen, die verkehrt herum aufgebaut ist (wird von Xl ggf intern korrigiert), und die Nicht-Übereinstimmung der Farben, wo es erforderlich wäre und die teilweise Übereinstimmung, da wo es nicht erforderlich, sogar ungünstig ist, wenn man auf Basis der Farben arbeiten wollte, was ab Xl14/2010 mit VBA relativ einfach wäre.
Das Schlimmste aber ist der Tabellenaufbau! Da ein Kopf fehlt, ist auch nicht begreifbar, warum die einzelnen 3-Zeilen-Blöcke nicht generell untereinander angeordnet werden sollten, sondern wie ungünstigerweise hier nur 4 untereinander und dann die nächsten 4 daneben. So etwas verursacht unelegante, ellenlange Formeln und somit unnötige Denk- und Schreibarbeit, gerade auch bei der Variante, die nicht auf Farben, sondern auf die Werte abstellt (Shift-Del )!
Gruß, Castor
Antwortento top
#8
(06.06.2016, 06:30)WiRiMaNi schrieb: Guten Morgen,

danke für die Mühe und den Hinweis! Jedoch klappt es bei mir leider nicht mit der Formel.
Hat sich wohl erledigt.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#9
Hallo,

tut mir leid für die späte Antwort, aber ich bin gerade erst nach Hause gekommen. Heute morgen war die Zeit auch knapp, daher auch nur das kurze Statement.

Heute Morgen bekam ich als Ergebnis in der Zelle B16, das Ergebnis "3". Was ja nicht stimmen kann, da ich 14 gezählt hatte. Eben habe ich die Formel nochmal testen wollen und nun ist das Ergebnis "Wahr". Huh  Edit: Habe es noch einmal eingegeben. Bekomme tatsächlich immer wieder 3 als Ergebnis.

Die Farbe sollte schon einheitlich sein, jedoch habe ich diese nicht wiedergefunden, daher habe ich zur Demonstration die nächst ähnliche gewählt. Die Tabelle ist ansonsten nach bestem Wissen und Gewissen aufgebaut.
Antwortento top
#10
Ausnahmsweise mal mit Jeannie:
Tabelle1

ABCDEF
14Anzahl der Zählungen
15Durchschnitt
1611494972252
1722574072231
1831195272250
1942883672236
2051285272252
21
220233251
23232249999
Formeln der Tabelle
ZelleFormel
B16=SUMMENPRODUKT(($D$1:$BQ$12=$A16)*($E$1:$BR$12>=B$22)*($E$1:$BR$12<=B$23)*(REST(SPALTE($D$1:$BQ$1);5)=4))+SUMMENPRODUKT(($D$1:$BQ$12=$A16)*($F$1:$BS$12>=B$22)*($F$1:$BS$12<=B$23)*(REST(SPALTE($D$1:$BQ$1);5)=4))+SUMMENPRODUKT(($A$1:$A$12=$A16)*($B$1:$B$12>=B$22)*($B$1:$B$12<=B$23))+SUMMENPRODUKT(($BV$1:$BV$12=$A16)*($BW$1:$BW$12>=B$22)*($BW$1:$BW$12<=B$23))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste