Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excelaufgabe: Useranlage
#1
Liebe Excel-Spezialisten,

Ich bin ein richtiger Excel-Anfänger und bräuchte dringend Unterstützung.

Aufgabenstellung:

Ich habe eine Excel-Blatt mit 100 Vor- und Nachnamen, sowie Usernamen (8-stellig). 
zB. 
Markus Mayer / Username: Mayer
Siegfried Mueller / Username: Mueller
Klaus Schneidhofer / Username: Schneidh
Susanne Mayer / Username: Mayer1
Margit Schneidhofer / Username: Schneid1
Petra Schneidhofer / Username: Schneid2

Dann habe ich ein zweites Blatt in der sich Vor- und Nachnamen befinden, die in der ersten Liste nicht angeführt sind.
zB. 
Ingrid Aschauer / Username: 
Gabriele Schneidhofer / Username: 
Florian Bauer / Username:
Riccardo Mayer / Username: 

Ich benötige für die User einen Usernamen. Dabei soll von der ersten Liste überprüft werden, ob zB. Aschauer bereits vergeben ist, wenn nicht soll dieser Username bei Ingrid Aschauer eingetragen werden. Das gleich bei Gabriele Schneidhofer, ist der Name in der ersten Liste schon vergeben dann nimm den nächsten der frei ist, zb. Schneid3. Die Usernamen sollen maximal 8-stellig sein.

Ich würde mich sehr freuen wenn Ihr mir helfen könntet.

Danke
Antwortento top
#2
Hi,

(12.06.2016, 11:46)xsicht1337 schrieb: Ich benötige für die User einen Usernamen. Dabei soll von der ersten Liste überprüft werden, ob zB. Aschauer bereits vergeben ist, wenn nicht soll dieser Username bei Ingrid Aschauer eingetragen werden. Das gleich bei Gabriele Schneidhofer, ist der Name in der ersten Liste schon vergeben dann nimm den nächsten der frei ist, zb. Schneid3. Die Usernamen sollen maximal 8-stellig sein.

Am einfachsten ist es, in einer Hilfsspalte (z.B. Spalte C) in der zweiten Liste folgende Formel einzugeben:
=ZÄHLENWENN(Tabelle1!$B$4:$B$9;B4)
In Spalte B schreibst Du dann von Hand den Usernamen rein und siehst in C mit 0 oder 1, ob der Name in der Liste 1 schon vorhanden ist.

Tabelle1
AB
1Liste 1
2
3NameUsername
4Markus Mayer Mayer
5Siegfried Mueller Mueller
6Klaus Schneidhofer Schneidh
7Susanne Mayer Mayer1
8Margit Schneidhofer Schneid1
9Petra Schneidhofer Schneid2


Tabelle2
ABC
1Liste 2
2
3NameUsernamevorhanden?
4Gabriele SchneidhoferSchneidG0
5Klaus Schneidhofer Schneidh1

verwendete Formeln
Zelle Formel Bereich N/A
C4:C5=ZÄHLENWENN(Tabelle1!$B$4:$B$9;B4)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit



Oder Du machst in Liste 2 eine Gültigkeitsprüfung, damit nur Namen eingetragen werden können, die es in Liste 1 noch nicht gibt, da habe ich aber die Formel grad nicht zur Hand.


Wenn die Erzeugung des Usernamens automatisch erfolgen soll, wird eine VBA-Makro und der Algorithmus benötigt, wie der Username erzeugt/ermittelt/festgelegt wird?
Antwortento top
#3
Danke für die rasche Antwort, ich glaube ich kann damit gut arbeiten!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste