Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Excel ekennt Text als Zahl, dann wieder als Text
#1
Hallo liebe Mitstreiter,

im Bild ist die Problemstellung zu erkennen.
Da das Tool zum einstellen von Ausschnitten gerade versagt, stelle ich Euch einmal ein Bild ein, und unten die Beispieldatei.

?mage


Ich habe für das in der Datei beschriebene Problem keine Lösung.
Was haltet Ihr davon und hat vielleicht einer von Euch eine Lösung?


.xlsx   String oder Zahl.xlsx (Größe: 12,83 KB / Downloads: 9)
Gruß Atilla
to top
#2
Hallo,

das liegt schlicht und ergreifend daran, dass OExx für Excel eine als Text gespeicherte Zahl darstellt nämlich 0^xx etc. Summe ignoriert Texte. Auch alle anderen Formeln verhalten sich regelkonform: Die einen ignorieren jeden Text, die anderen erkennen als Zahl gespeicherte Texte und wandeln sie in Zahlen um.
Ich habe zur besseren Verdeutlichung aus der 0 mal eine 1 gemacht:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1 WerteZählenwennIstgleichVergleich()Typ
2 -1E102FALSCH22
3 -1E111FALSCH 2
4 -1E102FALSCH 2
5 -1E131FALSCH 2
6Summe Formel0    
7Einzel-Addition-1,012E+13    

ZelleFormel
C2=ZÄHLENWENN($B$2:$B$5;B2)
D2=B2=B3
E2=VERGLEICH(B2;$B$3:$B$5;0)
F2=TYP(B2)
B6=SUMME(B2:B5)
B7=B2+B3+B4+B5
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
?mageHi Atilla,

ich vermute, das liegt an der Exponentialschreibweise. Sobald du "normale" Zahlen in Textform vorliegen hast, stimmen deine Berechnungen wieder.

Tabelle1 (2)

ABCDEF
1WerteZählenwennIstgleichVergleich()Typ
2-102FALSCH22
3-111FALSCH2
4-102FALSCH2
5-131FALSCH2
6Summe Formel0
7Einzel-Addition-44
Formeln der Tabelle
ZelleFormel
C2=ZÄHLENWENN($B$2:$B$5;B2)
D2=B2=B3
E2=VERGLEICH(B2;$B$3:$B$5;0)
F2=TYP(B2)
C3=ZÄHLENWENN($B$2:$B$5;B3)
D3=B3=B4
F3=TYP(B3)
C4=ZÄHLENWENN($B$2:$B$5;B4)
D4=B4=B5
F4=TYP(B4)
C5=ZÄHLENWENN($B$2:$B$5;B5)
D5=B5=B6
F5=TYP(B5)
B6=SUMME(B2:B5)
B7=B2+B3+B4+B5
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B21. / Eindeutige WerteAbc
B31. / Eindeutige WerteAbc
B41. / Eindeutige WerteAbc
B51. / Eindeutige WerteAbc

Excel Tabellen im Web darstellen >> http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8

In  der Beitragsvorschau habe ich gerade festgestellt, dass das Tool aus Zahlen im Textformat "richtige" Zahlen macht. Der Screenshot soll zeigen, dass es sich lt. XL tatsächlich um Zahlentext handelt.


Angehängte Dateien Thumbnail(s)
   
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo Edgar,


So weit ist mir das Klar.

Nur woher soll ich wissen, wann Excel wie reagiert.
Einmal sind es Duplikate dann wieder nicht.

Wie kann ich Excel sagen, dass diese Werte ausschließlich als Text zu berücksichtigen sind?

Vor allem die Zählenwenn Funktion soll dann keine Doppelte anzeigen.
Gruß Atilla
to top
#5
Hallo zusammen,

mir ist schon klar, was da passiert.

Aber ich möchte, das es nicht passiert. ;-)


Ich möchte Excle sagen können, dass diese Werte als Text zu behandeln sind.
Gruß Atilla
to top
#6
Hi Atilla!
Keine Ahnung, ob es Dein spezielles Problem löst.
Aber wenn ich ein nichtdruckbares Zeichen (bei mir 160) anhänge, funktionieren alle Formeln im Sinne des Erfinders:
Ich habe Spalte A als Wert über Spalte B kopiert.

ABCDEF
1WerteZählenwennIstgleichVergleich()Typ
2-0E10  -0E10 1FALSCH#NV2
3-0E11  -0E11 1FALSCH2
4-0E12  -0E12 1FALSCH2
5-0E13  -0E13 1FALSCH2
Formeln der Tabelle
ZelleFormel
A2=B2&ZEICHEN(160)
C2=ZÄHLENWENN($B$2:$B$5;B2)
D2=B2=B3
E2=VERGLEICH(B2;$B$3:$B$5;0)
F2=TYP(B2)
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B21. / Eindeutige WerteAbc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
to top
#7
Ergänzend:
Die Summenformel ergibt dann 0, die Einzeladdition #WERT, beides korrekt.

Gruß Ralf
to top
#8
Hallo Ralf,

das wäre eine mögliche Notlösung.

Danke für Deine Antwort.
Gruß Atilla
to top
#9
Hallo atilla,

soweit ich das verfolgt habe, sind nur die Zeilen betroffen, die  0E beinhalten.


Code:
Nur woher soll ich wissen, wann Excel wie reagiert.



Das ist eigentlich von der eingesetzten Funktion abhängig. Einige arbeiten stur nach Typ ab, andere wandeln eben als Text vorliegende Zahlen um, z.B. Zählenwenn. Die vorliegenden Nummern ergeben nunmal, in eine Zahl umgewandelt, allesamt Null. Als Notloesung könnte man auch aus dem "0E" ein "0 E" machen, dann geht es auch.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#10
Hallo zusammen,

danke für Eure Einlassungen.

Aber insgesamt finde ich das Verhalten von Excel hier nicht stimmig.

Wenn Zellen als Text formatiert sind, dann sollte das auch so behandelt werden.

Für Laien sind das große Stolpersteine und man kann unwissentlich auf die Schnauze fallen.
Gruß Atilla
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste