Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

[Excel] einfaches Zählen von Zellinhalten
#1
Hallo,

anbei habe ich eine kurze Übersicht von einfachen Möglichkeiten, Inhalte von Zellen zu zählen. Hintergrund dieses Beitrages war für mich u.a. die Frage nach dem Zählen von "leeren" Zellen oder korrekt formuliert von Zellen, die Formeln enthalten und als Ergebnis "" bringen. Zur Vervollständigung  habe ich gleich weitere Zählmöglichkeiten aufgeführt, ohne jetzt auf komplexere Möglichkeiten und Bedingungen einzugehen.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1TextAnzahl1nur Zahlen
212Anzahl25alle Einträge einschl. Formeln mit Ergebnis ""
3 Zählenwenn5alle Einträge einschl. Formeln mit Ergebnis ""
4#DIV/0!Zählenwenn1nur Texte mit min. 1 Zeichen - dafür steht das ?
5#NAME?Zählenwenn + Anzahl2Texte mit min. ein Zeichen und Zahlen
6 Zählenwenn0Fehler mit #* zählen geht nicht
7 Zählenwenn1Zählenwenn #DIV/0!
8 Summe Istfehler2Anzahl aller Fehler

ZelleFormel
C1=ANZAHL(A1:A5)
C2=ANZAHL2(A1:A5)
A3=""
C3=ZÄHLENWENN(A1:A5;"<>")
A4=2/0
C4=ZÄHLENWENN(A1:A5;">?*")
A5=a0
C5=ZÄHLENWENN(A1:A5;">?*")+ANZAHL(A1:A5)
C6=ZÄHLENWENN(A1:A5;"#*")
C7=ZÄHLENWENN(A2:A5;1/0)
C8{=SUMME(ISTFEHLER(A1:A5)*1)}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste