Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Excel berechnen / Jahr Zuteilung
#1
Hallo ihr Lieben,
ich möchte in einer Excel-Datei eine Tabelle mit folgender Funktion erstellen.
Zwischen Datum 1 z.B. (01.03.2013) und Datum 2 (z.B. 31.10.2017) lasse ich mir die Tage ausrechnen. Dies ist ja kein Problem. In diesem Fall sind das 1706 Tage. Nun möchte ich aber dass die Tage pro Jahr entsprechend Spalten der jeweiligen Jahre zugeordnet werden. Also ich möchte eine Spalte mit "Tage in 2013", "Tage in 2014", "Tage in 2015" usw. und es soll automatisch die jeweiligen Tage in den Jahr in die Spalte eingetragen werden. Gibt es eine Lösung hierfür?
Vielen Dank im Vorraus! 17
to top
#2
Hallo,

gibt´s:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1  Tage in 2011Tage in 2012Tage in 2013Tage in 2014Tage in 2015Tage in 2016
201.03.201215.02.20150306365365450

ZelleFormatWert
C1"Tage in "JJJJ01.01.2011

ZelleFormel
C2=(JAHR($A2)<=JAHR(C$1))*($B2>=C$1)*(MIN($B2;--("1.1."&JAHR(C$1)+1))-MAX(C$1;$A2))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hi,

ein wenig umständlicher als die vorige Lösung dafür dynamischer
füge in A1 bzw. B1 deine Daten ein.Smile


.xlsx   demo.xlsx (Größe: 8,85 KB / Downloads: 8)
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

to top
#4
Hallo,

das wwürde ich dann noch etwas ausbauen:


Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1AnfangEnde 2015201620172018
213.03.201517.03.2018 29336636576

ZelleFormatWert
A2TT.MM.JJJJ13.03.2015
B2TT.MM.JJJJ17.03.2018

ZelleFormel
D1=WENN(SPALTE(A1)>JAHR($B2)-JAHR($A2)+1;"";JAHR($A2)+SPALTE(A1)-1)
D2=WENN(D1="";"";MIN(--("31.12."&D$1);$B2)-MAX($A2;--("1.1."&D$1)-1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste