Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

[Excel] Tipp zu SUMMEWENN (variables Suchkriterium)
#1
Das Problem ist in diesem Fall die Übergabe des Kriteriums als Zellbezug.

Liegt der Grenzwert als Konstante vor, kann die Summe problemlos mit der Funktion SUMMEWENN gebildet werden. Beispiel: alle Zellen des Bereichs A1:A20, deren Wert größer als 300 ist, sollen summiert werden

=SUMMEWENN(A1:A20;">300")

Soll der Grenzwert jedoch über eine Zelle geholt werden, akzeptiert Excel die Formel nicht. Mit folgendem Trick geht es aber doch.

Um das gewünschte Ergebnis zu erreichen, muss der Operator (im Beispiel das Größerzeichen ">") und die Grenzwertzelle mit dem Zeichen "&" verknüpft werden.

=SUMMEWENN(A1:A20;">"&C1)

Bitte generell darauf achten, dass der Operator und das Kriterium (im Falle eines konstanten Suchwertes) gemeinsam in Anführungszeichen gesetzt werden und im Falle des variablen Suchbegriffs (Bezug auf die entsprechende Zelle) nur der Operator.
Siehe ">300" bzw. ">"&C1
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste