Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


[Excel] Daten eines bestimmten Kunden in anderes Tabellenblatt kopieren
#1
Hallo,

angenommen die Ausgangstabelle sieht wie folgt aus

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1KundeRgNrSumme
2A1100
3B2200
4C3300
5A4400
6A5500
7B6600
8C7700
9D8800
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Jetzt sollen die Werte des Kunden A in einem separaten Tabellenblatt aufgelistet werden.

Eine Möglichkeit diese Aufgabenstellung ohne Matrixformeln (mit einer zusätzlichen Hilfsspalte) zu lösen könnte so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFG
1 KundeRgNrSumme KundeA
22A1100   
35A4400   
46A5500   
5#NV#NV#NV#NV   

ZelleFormel
A2=VERGLEICH($G$1;Tabelle1!$A$9:INDEX(Tabelle1!A:A;A1+1);)+A1
B2=INDEX(Tabelle1!A:A;$A2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Formel in A2 wird soweit nach unten kopiert bis die Fehlermeldung #NV erscheint, die Formel in B2 wird nach rechts und nach unten kopiert.

Wenn die Fehlermeldung #NV stört dann könnte man auch beide Formeln mit Wennfehler verbinden:

A2: =WENNFEHLER(VERGLEICH($G$1;Tabelle1!$A$9:INDEX(Tabelle1!A:A;A1+1);)+A1;"")
B2: =WENNFEHLER(INDEX(Tabelle1!A:A;$A2);"")
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste