Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


Erweiterung mit WENN Funktion
#1
Einen schönen guten Morgen an alle Exelfreunde,
Ich habe eine Formel (von Jockel) die ich gern erweitern würde.
Folgende Formel:
=WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1
Mein Wunsch wäre, wenn ich Zelle "C4" ein X einsetze soll als Ergebnis 0,00 betragen.
Diese Option hat sich erst jetzt ergeben.
Zelle "C4" Uhrzeit 7:00
Zelle "C5" Uhrzeit 10:15
Danke für Eure Hilfe
Günther
Antwortento top
#2
Hi,

meinst du das so?
=WENN(C4="X";0;WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1)

lg

EDIT.. True, False vertauscht
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 [Bild: v.gif]

Antwortento top
#3
hi Günther, da geht doch einfach...:

PHP-Code:
=WENN(C4="x";0;WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1

oder..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Guenther52
Antwortento top
#4
Danke Chris-ka, leider nicht,
In Zelle "C4" erfolgen folgende Einträge:
K=Kran; U=Urlaub; F=Feiertag werden diese Kürzel in Zelle "C4" geschrieben muß in Zelle "C6" die gearbeiteten 6,00 Stunden erscheinen.
In Zelle "C4"; X=nicht gearbeitet muß also in Zelle "C6" entweder 0,00 Stunden stehen!
Ansonsten wird die Arbeitszeit als postiv angezeigt. C4=7:00 C5=13:15 ist gleich Zelle C6=0,00
ist die Arbeitszeit kürzer als 6,00 stunden soll sie negativ angezeigt werden.
Gruß
Günther
Antwortento top
#5
(25.06.2014, 08:46)Jockel schrieb: hi Günther, da geht doch einfach...:

PHP-Code:
=WENN(C4="x";0;WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1

oder..?
Es ist einfach nur Super. Für Euch vielleicht einfach, für mich ein Problem!
Danke für die Hilfe!
Antwortento top
#6
Vielen dank an alle!
Günther
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste