Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Ergebnisse aus einer Checkliste in einer Mängelliste darstellen
#1
Hallo Ihr lieben


ich habe gerade 2 Listen gemacht.
Eine Checkliste wo ich vorhande Mängel mit einem "X" markiere.
   


jetzt möchte ich, dass diese Mängel in einer Mängelliste zusammen gefasst werden.
   

Wenn ich also z.B: bei Zimmer 101 an 5 stellen ein X mache möchte ich, dass bei der Mängeliste die Kürzel aus der Checkliste auftauchen.

Z.B.

TZ, BZ, FZ, BF, BB

ich habe es jetzt mit

=WENN('Checkliste Zimmer'!B3="x";"TZ, "(Wenn'Checkliste Zimmer'!B3="x";"BZ;(Wenn.... usw usw versucht

versucht.

Aber er zeigt dann z.B. nur das erste Kreuz an, das er findet und nicht beide.

Ich hoffe ich konnte mich halbwegs verständlich ausdrücken und Ihr habt eine lösung für mich.

Vielen Dank im Voraus
Nighty


EDIT:
hier die Excell datei Smile
   


Angehängte Dateien
.xlsx   Instandhaltung_forum.xlsx (Größe: 40,32 KB / Downloads: 6)
to top
#2
Hallo Nighty,

probiere es mal mit einer Verweisfunktion oder stelle uns deine (eventuell abgespeckte) Datei zur Verfügung. Wie du diese hochladen kannst, lies bitte hier nach.

Ich mag nämlich keine nachbauen. Wink
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
(29.04.2015, 15:51)WillWissen schrieb: Hallo Nighty,

probiere es mal mit einer Verweisfunktion oder stelle uns deine (eventuell abgespeckte) Datei zur Verfügung. Wie du diese hochladen kannst, lies bitte hier nach.

Ich mag nämlich keine nachbauen. Wink
Danke ,

Ich habe die Excell datei mal angehangen.

LG
to top
#4
Hi,

wo ist sie denn?? Hat wohl nicht geklappt, sonst könnte man in deiner Antwort einen Link zur Datei sehen.

Sorry, hatte nicht im Eingangsthread geschaut
Mit freundlichen Grüßen  Smile
Michael
to top
#5
So langsam komme ich der Sache näher...

Zur zeit sieht es so aus

Code:
=WENN('Checkliste Zimmer'!B3="x";'Checkliste Zimmer'!B2&WENN('Checkliste Zimmer'!C3="x";'Checkliste Zimmer'!C2&WENN('Checkliste Zimmer'!D3="x";'Checkliste Zimmer'!D2;"")))
jetzt habe ich noch 2 Punkte...
zum Einem habe ich als Ausgabe im moment die Erbenisse zusammen (B2 - TZ ; C2 - BZ ; D2 - FZ)
Ausgegeben wird das nun zusammen "TZBZFZ"
Ich hätte aber gerne die Ausgabe durch , getrennt.
TZ, BZ, FZ,
wie become ich das Komma und die leerzeile dazwischen.
2. Problem oder eher eine Hoffnung.
Muss ich diese Formel jetzt bis Spalte AH so per hand schreiben oder kann ich Excell irgendwie klar machen,
dass er diese Regel von Zeile B3 bis AH3 durchgehend machen soll.
Gruß und Danke
Nighty
   
to top
#6
Hi Nighty,

hier mal eine Antwort für das generelle Zusammenfügen von Texten.

Du kannst deine Bezeichnungen so mit einem Komma versehen:

Code:
=C13&", "&C13&", "&C15


Am Rest deines Problems hatte ich schon eine Weile - ohne Erfolg - getüftelt. Ich vermute mal, dass es eine elegantere Lösung gibt. Nur für heute ist Schluss mit denken. Wink
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#7
(29.04.2015, 20:32)WillWissen schrieb: Hi Nighty,

hier mal eine Antwort für das generelle Zusammenfügen von Texten.

Du kannst deine Bezeichnungen so mit einem Komma versehen:


Code:
=C13&", "&C13&", "&C15


Am Rest deines Problems hatte ich schon eine Weile - ohne Erfolg - getüftelt. Ich vermute mal, dass es eine elegantere Lösung gibt. Nur für heute ist Schluss mit denken. Wink

Danke dir, das hat mir schon viel geholfen.... Smile
Gruß Nighty
to top
#8
Jetzt habe ich ein neues problem festgestellt..... 22

Die Anzeige funktioniert solange wie alle angekreuzt sind, sobald an einer Stelle kein X ist bricht er ab.

   
to top
#9
Hallo Nighty,

da fehlt irgendwo noch was, wie hier in meinemBeispiel ein "Nein"

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1Ja 
2FALSCH1

ZelleFormel
A1=WENN(B1=C1;"Ja")
A2=WENN(B2=C2;"Ja")
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste