Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Duplikate entfernen
#1
Hallo,

ich habe folgende Datei über 10.000 Zeilen und mehreren Spalten:

[Bauteil]     [Termin]     [spätester Termin für Bauteil]  
x                 2008
x                 2005
x                 2014
x                 2014
y                 2001
y                 2016
y                 2011
z                 2015

Am Ende soll mir in der letzten Spalte ©  für das jeweilige Bauteil (Spalte A) der Termin (aus Spalte B) ausgegeben werden, welcher am höchsten und dort eine 1 schreiben. Andernfalls in die anderen Zeilen zum Bauteil x eine 0
Danach kann ich die Zeilen löschen, welche je Bauteil ein niedrigeres Datum haben bzw. über die Funktion die Duplikate entfernen, welche Ihren Termin im gleichen Jahr haben.

Weiß jemand eine Lösung / Formel?

Danke!
to top
#2
Hallo!
Bei der Datenmenge ein Paradebeispiel für eine Pivottabelle:
Einfügen, Pivot-Tabelle
Bauteil in Zeilenbeschriftung, Termin in Werte
Spalte Termin Werte zusammenfassen als Maximum

Die Pivot kannst Du jetzt kopieren und als Wert in ein neues Tabellenblatt kopieren um die Verbindung zur Datenbasis zu löschen.
Die Ursprungstabelle darfs Du jetzt entsorgen ...

Gruß Ralf
to top
#3
Danke für den Tipp.
Funktioniert auch soweit mit dem Anzeigen, bloß muss die Excel für spätere Auswerten erhalten bleiben (ist schon eine Pivot aus der mehrere Infos später noch gewonnen werden müssen).
to top
#4
Hallo,

ich würde erst nach Bauteile dann nach Jahr aufsteigend sortieren und in die Hilfsspalte folgende Formel:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1[Bauteil]    [Termin]    [spätester
2x20050
3x20080
4x20140
5x20141
6y20010
7y20110
8y20161
9z20151

ZelleFormel
C2=WENN(A3<>A2;1;0)
C3=WENN(A4<>A3;1;0)
C4=WENN(A5<>A4;1;0)
C5=WENN(A6<>A5;1;0)
C6=WENN(A7<>A6;1;0)
C7=WENN(A8<>A7;1;0)
C8=WENN(A9<>A8;1;0)
C9=WENN(A10<>A9;1;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

sonst müsste sicher eine Array Formel ran, was dann bei so vielen Zeilen die Performance stark beeinträchtigen könnte.
Gruß Atilla
to top
#5
Hi,

(15.02.2016, 15:23)sebogrz schrieb: bloß muss die Excel für spätere Auswerten erhalten bleiben (ist schon eine Pivot aus der mehrere Infos später noch gewonnen werden müssen).

daß Du die Ursprungstabelle löschen darfst, heißt ja nicht, daß Du sie auch löschen mußt.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#6
Sad 
Hallo,

hat leider nicht funktioniert. Die Formel "merkt" nicht, dass sie beim nächsten Bauteil wieder von vorne anfangen muss, das Bauteil mit den jeweiligen Jahren zu vergleichen.
Habe auch bereits mit Index und Vergleich experimentiert, aber dort auch zu keiner Lösung gefunden   Huh Undecided Dodgy
to top
#7
Hallo,

dann vielleicht so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1[Bauteil]    [Termin]    [spätester
2x20051
3x20081
4x20140
5x20141
6y20011
7y20111
8y20161
9z20151

ZelleFormel
C2=WENN(ODER(A3<>A2;B2<>B3);1;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla
to top
#8
Eine andere Herangehensweise wäre, nochmal Sortieren nach Bauteil (z.B. alle Bauteile X untereinander) und dann weitersortieren nach dem höchsten Datum zuerst.

Dann jeweils in die erste Zeile wenn ein neues Bauteil auftaucht (z.B. X), in Hilfsspalte die 1 schreiben und in die Restlichen die 0.
Gibt es dafür eine Funktion?

Quasi:

X    2016    1
X    2015    0
X    2014    0
X    2013    0
Y    2016    1
Y    2015    0
Y    2014    0
Z    2013    1
Z    2010    0

Danke und Gruß

Sebo
to top
#9
Ja, sebo!
Die nennt sich Daten, Duplikate entfernen …
(in diesem Fall nur auf Spalte A angewandt, löscht sie die nachfolgenden Duplikate)

Gruß Ralf
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste